none
%appdata% fix

    Question

  • recently i downloaded borderlands from steam and i recieved an error that wouldnt allow me to play, when i went through the troubleshooting i found the correct fix and did all  of the steps. The only problem is when one of the files would work i recieved an error that said this program couldnt locate the %appdata% file. This all started awhile ago when i was moding minecraft i made a shortcut to the %appdata% file on my desktop. From this point on whenever i tried downloading new games i would recieve errors relating to the %appdata% file, for example skype cant update, and i cant update java, i also cant install any .net framework. im wondering if there is anyway for me to fix this problem? please help

    Sunday, March 11, 2012 3:17 AM

Answers

  • Did you create a NEW account with admin priveleges. It should have its own Appdata folder in the correct location.

    What .NET Framework version(s) are you trying to install? Bear in mind that .NET Framework versions 2.0, 3.0 and 3.5 through 3.5 SP1 are installed as part of Windows 7. You cannot install those versions yourself.

    If you have attempted to install .NET Framework 4.0 and failed, provide complete install logs as follows:

    Please collect your install logs with this:

    http://www.microsoft.com/downloads/details.aspx?FamilyID=E0DA314F-6216-4A18-BC6B-7D29CF83AF20&displaylang=e&displaylang=en

    After you run Collect.exe, you'll find vslogs.cab in your %temp% directory. Please upload vslogs.cab to a public site, like SkyDrive, and post the link here.

    • Proposed as answer by Alexander Sun Monday, March 12, 2012 5:49 AM
    • Marked as answer by Alexander Sun Thursday, March 29, 2012 6:18 AM
    Sunday, March 11, 2012 5:52 PM
  • Hi Mitchell6565,

    Welcome to the MSDN forum.

    Please try MVP’s suggestions first. Then please check this registry key:

    HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\User Shell Folders

    On my side, the value of this key is “%USERPROFILE%\AppData\Roaming”.

    NOTE: Please back up your registry before modification. You can try these: File>>Export…>>Set “Export range” as All>>Save.

    If you have any other problems, please feel free to let me know.

    Best Regards,


    Alexander Sun [MSFT]
    MSDN Community Support | Feedback to us

    • Marked as answer by Alexander Sun Thursday, March 29, 2012 6:18 AM
    Monday, March 12, 2012 6:10 AM

All replies

  • What is your Windows version and Service Pack level?

    As %appdata% is the Appdata folder associated with the currently signed on user, and the things you did may have corrupted that user, I suggest you create a new user account with administrative privileges and log on with the new account to see if that helps.

    Sunday, March 11, 2012 2:47 PM
  • my windows version is windows 7, and i dont know my service pack, we have an administrator account but it makes the same error.

    Sunday, March 11, 2012 4:28 PM
  • Did you create a NEW account with admin priveleges. It should have its own Appdata folder in the correct location.

    What .NET Framework version(s) are you trying to install? Bear in mind that .NET Framework versions 2.0, 3.0 and 3.5 through 3.5 SP1 are installed as part of Windows 7. You cannot install those versions yourself.

    If you have attempted to install .NET Framework 4.0 and failed, provide complete install logs as follows:

    Please collect your install logs with this:

    http://www.microsoft.com/downloads/details.aspx?FamilyID=E0DA314F-6216-4A18-BC6B-7D29CF83AF20&displaylang=e&displaylang=en

    After you run Collect.exe, you'll find vslogs.cab in your %temp% directory. Please upload vslogs.cab to a public site, like SkyDrive, and post the link here.

    • Proposed as answer by Alexander Sun Monday, March 12, 2012 5:49 AM
    • Marked as answer by Alexander Sun Thursday, March 29, 2012 6:18 AM
    Sunday, March 11, 2012 5:52 PM
  • Hi Mitchell6565,

    Welcome to the MSDN forum.

    Please try MVP’s suggestions first. Then please check this registry key:

    HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\User Shell Folders

    On my side, the value of this key is “%USERPROFILE%\AppData\Roaming”.

    NOTE: Please back up your registry before modification. You can try these: File>>Export…>>Set “Export range” as All>>Save.

    If you have any other problems, please feel free to let me know.

    Best Regards,


    Alexander Sun [MSFT]
    MSDN Community Support | Feedback to us

    • Marked as answer by Alexander Sun Thursday, March 29, 2012 6:18 AM
    Monday, March 12, 2012 6:10 AM