none
Could not connect to server

    Question

  • TF205020: Could not connect to server ‘access.trivadis.com/........’. This server was used in your last session, but it might be offline or unreachable. Confirm that the server is available on the network. To attempt to connect again, or to a different server, click ‘Connect To Team Foundation Server’ in Team Explorer or the Team menu.The server returned the following error: TF400324: Team Foundation services are not available from server access.trivadis.com/.....\Trivadis.Technical information (for administrator):  Unable to connect to the remote server

    This message is displayed when I connect through a VPN connection from a customer to the external, cloud based TFS site access.trivadis.com. It is the same for Visual Studio 2010 and 2012

    When I work without VPN, NO ERRROR occurs.

    Working directly in the customers network I have another result:

    Visual Studio 2010: works sometimes perfectly, but not always, error occurs rarely.

    Visual Studio 2012: HTTP code 407: Proxy Authentication Required ( Forefront TMG requires authorization to fulfill the request. Access to the Web Proxy filter is denied.  ) Retry.
    Occurs always

    This error occurs since yesterday. In the time before it worked fine during half a year for VS2010 and 3 weeks for VS2012.

    Does have anyone ideas?

    Thanks for your help

    Hans

    Thursday, November 22, 2012 1:03 PM

Answers

  • I’ve read through your issue and troubleshooting steps and while I do not have an answer I do have some things for you to consider and a request for a bit more information if you don’t mind. First, I think the difference between why 2010 does not cache your credentials and why 2012 appears to is due to the rewrite of the GUI. It is now heavily web influenced and therefore your IE settings probably have an impact.

    When you say removing the credentials from credentials manager fixes it, which credentials have been cached? VPN or VS, or perhaps something else…

    We did have an issue a while back around using multiple accounts (Local PC, VPN Account, and the Domain Account to launch VS) where users were not getting prompted for their credentials after the initial prompt to launch VS. I don’t recall it effecting subsequent logins but it might have. In that case a user would use one account to establish the VPN connection and another once connected to launch Visual Studio. What would happen is that when they would click on a link, say to change a permissions or add a user, they would get a permission denied message even though the account they logged into VS did have permission.

    What we found was that when IE was launched to adjust the permission, it was trying to use the VPN connection credentials I (IIRC). This would have been OK if it prompted for correct credentials but it did not. I don’t even think adding the correct credentials to cred manager resolved it. I’m trying to find that info so if it applies I can relay it to you.

    With all of that being said, I think to troubleshoot this one must take into account any IE settings that might come into play. Maybe IE is caching the credentials. When I look at Security =>Custom Level => User Authentication I see several options one could set for how IE should behave. Perhaps changing or resetting this might help. I’m sure there are other setting worth checking but it would be very difficult to troubleshoot through the forum and hopefully this helps provide you with something that helps resolve this, but if it does not, please go ahead and open a support case so we can take an in depth look at the issue.

    • Marked as answer by tvddev Tuesday, December 11, 2012 9:45 AM
    Thursday, December 06, 2012 3:17 PM

All replies

  • Hi Hans,

    Thank you for your post.

    For connect with TFService via VPN, you can refer to http://social.msdn.microsoft.com/Forums/en-US/TFService/thread/42fdff6f-175d-4e2b-af20-5de9e11997aa

    Regards,


    Lily Wu [MSFT]
    MSDN Community Support | Feedback to us

    Friday, November 23, 2012 2:31 AM
  • After a long during trial and error session with a network specialist we found following workaround:

    1. Delete all windows and generic credentials in Control Panel > Credential Mananger for the server in question.
    2. Don't allow storing credentials in credential manager when Visual Studio 2010/2012 asks for credentials while conneting to the Team System Server.

    Obviousely in some circumstances Visual Studio does not pass the credentials stored in credential manager correctely. If there are not credentials for the server in question, Visual Studio 2010/2012 asks every time the credentials and logs in successfully.

    This never happend using a machine with Visual Studio 2010 installed only.

    Since I am using Visual Studio 2012 in parallel I experienced two side effects:

    1. On one machine Visual Studio 2010 does not work any more, it crashes without leaving any message. Deinstalling/reinstalling of VS2010 and/or VS2012 does not help.
    2. Log in problems, mainly with VS2012, rarely with VS2010 on two other machines as described in this thread.

    So, if anybody knows a reason, why I have to remove the credentials in credential manager for successfully log in to the team system server, I would very appreciate it.

    Thanks for your help


    • Edited by TVDAG Tuesday, November 27, 2012 1:29 PM
    Friday, November 23, 2012 7:35 AM
  • Hi Hans,

    How about the issue now?  I suggest you mark useful post as answer, it will be very beneficial for other community members having the similar questions.

    If anything is unclear, please free feel to let me know.

    Best Regards,


    Lily Wu [MSFT]
    MSDN Community Support | Feedback to us

    Tuesday, November 27, 2012 4:18 AM
  • Hi Lily

    My workaround is still a workaround, and even not a good workaround.
    What I need is an answer to why I need since a week to remove my credentials when connecting to Team System.

    Could it be a windows update on Windows 7. Is the problem on the windows server 2008, is it a tiny patch for Team System, or is there no issue with windows and team system?

    How could I track the credential processing? Why are username and password obviousely differently proccessed when cominging from credential manager or from manual input?

    So, when there is no response to those questions, we can close this thread as unanswererd.

    Thanks for your help

    Hans

    Tuesday, November 27, 2012 1:42 PM
  • Hi Hans,

    Please try to clear IE browser history include cookies. You can refer to http://social.msdn.microsoft.com/Forums/en-US/TFService/thread/4c887b08-60fe-40fb-8e25-81ab4c267003?prof=required

    Regards,


    Lily Wu [MSFT]
    MSDN Community Support | Feedback to us

    Wednesday, November 28, 2012 2:33 AM
  • Hi Lily

    Thank you for this advice. I deleted all stuff in the browsing history, but the problem has not gone.

    A colleague works with the same vpn connection on an identical machine and has no problems.
    The only difference: This machine has VS2010 installed only, no any other installation of VS2012.

    On my machine VS2010 and VS2012 are installed in parallel.

    From VS2012 (Version 11.0.50727.1) following components are installed:

    VS2012 Shell (Integrated)
    VS2012 Shell (Integrated) Language Pack - ENU
    VS2012 Shell (Isolated)
    VS2012 Shell (Isolated) Language Pack - ENU

    Along with VS2012 I also installed MS SQL Server Data Tools 2012 (Version 11.1.211101.1) with the componens

    SQL Server 2012 Data-Tier App Framework
    SQL Server 2012 Express LocalDB
    SQL Server 2012 Management Objects
    SQL Server 2012 Transact-SQL Compiler Service
    SQL Server 2012 Transact-SQL ScriptDom
    SQL Server 2012 T-SQL Language Service

    Is it possible that VS2010 und VS2012 installed in parallel causes this problem?

    Actually I had the following situation:

    1. Delete credentials in credential manager
    2. Starting VS2012 username and password are asked, remember my credentialy is checked.
    3. Starting VS2010, wants to connect to the same team system project. The error
      in question occurs, but the option to connect as another user is offered within the error message.
    4. I click this option and indicate the same credentials as in VS2012. But the check box remember my credentials is not offered
    5. VS2010 connects this time successfully to the same team system project.
    6. Subsequent closing and restarting VS2010 has always the same effect:
      The credentials are asked without the check box remember my credentials.
      Connection to the same team System project is alwas successful.
    7. Checking the credential manager shows that the credentials for the site are not stored yet.
    8. I close VS2012.
    9. Checking the credential manager now shows that the credentials for the team system server are store.
    10. I reopen VS2012. The error occurs again, but there is no option to change the user.
    11. I open VS2010 again, surprisingly my credentials are asked (without option to remember the credentials). After typing my credentials connection to team system is successfulls.

    After this session I can say that:
    VS2010 does not recognizes credentials stored by VS2012.
    I also retyped the password in the credentials stored by VS2012. In that case VS2012
    asks the credentials again, though the same password has been typed in.
    The trigger for asking the credentials are changing or deleting the genecric credential created by VS2012. Removing the Windows Credential generated by VS2012 has no effect.

    Thanks for you help

    • Edited by TVDAG Wednesday, November 28, 2012 11:37 AM
    Wednesday, November 28, 2012 9:56 AM
  • Hi Hans,

    I am trying to involve someone to further look at this issue. There might be some time delay. Appreciate your patience.

    Would you please email me(v-liliw@microsoft) your email address, for not miss your email, please include this case URL information in the mail.

    Regards,


    Lily Wu [MSFT]
    MSDN Community Support | Feedback to us

    Thursday, November 29, 2012 7:56 AM
  • Hans,

    This forum is for support of the Team Foundation Service (TFS.VisualStudio.com) specifically. It appears you are connecting to access.trivadis.com, which is not a collection in our service. I have moved your thread to a more appropriate forum for better support.


    Trevor Hancock (Microsoft)
    Please remember to "Mark As Answer" the replies that help.

    Friday, November 30, 2012 4:00 PM
  • I’ve read through your issue and troubleshooting steps and while I do not have an answer I do have some things for you to consider and a request for a bit more information if you don’t mind. First, I think the difference between why 2010 does not cache your credentials and why 2012 appears to is due to the rewrite of the GUI. It is now heavily web influenced and therefore your IE settings probably have an impact.

    When you say removing the credentials from credentials manager fixes it, which credentials have been cached? VPN or VS, or perhaps something else…

    We did have an issue a while back around using multiple accounts (Local PC, VPN Account, and the Domain Account to launch VS) where users were not getting prompted for their credentials after the initial prompt to launch VS. I don’t recall it effecting subsequent logins but it might have. In that case a user would use one account to establish the VPN connection and another once connected to launch Visual Studio. What would happen is that when they would click on a link, say to change a permissions or add a user, they would get a permission denied message even though the account they logged into VS did have permission.

    What we found was that when IE was launched to adjust the permission, it was trying to use the VPN connection credentials I (IIRC). This would have been OK if it prompted for correct credentials but it did not. I don’t even think adding the correct credentials to cred manager resolved it. I’m trying to find that info so if it applies I can relay it to you.

    With all of that being said, I think to troubleshoot this one must take into account any IE settings that might come into play. Maybe IE is caching the credentials. When I look at Security =>Custom Level => User Authentication I see several options one could set for how IE should behave. Perhaps changing or resetting this might help. I’m sure there are other setting worth checking but it would be very difficult to troubleshoot through the forum and hopefully this helps provide you with something that helps resolve this, but if it does not, please go ahead and open a support case so we can take an in depth look at the issue.

    • Marked as answer by tvddev Tuesday, December 11, 2012 9:45 AM
    Thursday, December 06, 2012 3:17 PM
  • Hi Kevin

    Many thanks to your detailed advice. I followed your instructions and yes, this is it!

    First it didn't worked, but in my case the Option "Prompt for user name and password" (Control Panel > Internet Options > Security > Custom level > Settings User Authentication > Logon) must be activated while the zone Internet is selected.

    Now it even work with registered credentials ("Remember my credentials" check during login at the team system server)

    Many thanks again and 1000 points for you

    Regards,

    Hans

    Tuesday, December 11, 2012 9:45 AM