none
Need help with TRK0005: Failed to locate: "CL.exe

    Question

  • Error 1 error TRK0005: Failed to locate: "CL.exe". The system cannot find the file specified. C:\Desktop\Bomb Catcher Game\TRACKER Bomb_Catcher

    I'm using a book I got from my library on trying to learn how to use Direct X, but one of the sample programs does not seem to compliling, for reasons I cannot seem to figure out, if you could help that would be a huge help, If you need any other information I will gladly give it. The above error is the only one I get when trying to compiling the program and I do not know how to fix it.

     

    Thursday, May 26, 2011 12:29 PM

Answers

  • Hi Arc

     

    cl.exe is Visual Studio compiler. So it should be in your Visual Studio installation directory such as C:/Program Files\Microsoft Visual Studio 10.0\VC\ce\bin.

    If there is not a cl.exe in your directory, please try to reinstall your VS.

    If the file is in your directory, you can repair VS.

     

    In addition, can you tell some other detail about your issue? For example, which version of Visual Studio and Windows have you used? Have your installed two different kinds of Visual Studio?

     

    I hope my suggestion can help you to resolve your issue. If anything is unclear, please feel free and let me know.

     

    Best Regards,

    Rob

     

     


    Rob Pan [MSFT]
    MSDN Community Support | Feedback to us
    Get or Request Code Sample from Microsoft
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    • Marked as answer by Rob Pan Thursday, June 02, 2011 1:42 AM
    Monday, May 30, 2011 9:01 AM

All replies

  • Hi Arc

     

    cl.exe is Visual Studio compiler. So it should be in your Visual Studio installation directory such as C:/Program Files\Microsoft Visual Studio 10.0\VC\ce\bin.

    If there is not a cl.exe in your directory, please try to reinstall your VS.

    If the file is in your directory, you can repair VS.

     

    In addition, can you tell some other detail about your issue? For example, which version of Visual Studio and Windows have you used? Have your installed two different kinds of Visual Studio?

     

    I hope my suggestion can help you to resolve your issue. If anything is unclear, please feel free and let me know.

     

    Best Regards,

    Rob

     

     


    Rob Pan [MSFT]
    MSDN Community Support | Feedback to us
    Get or Request Code Sample from Microsoft
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    • Marked as answer by Rob Pan Thursday, June 02, 2011 1:42 AM
    Monday, May 30, 2011 9:01 AM
  • As Rob Pan commented, You can check whether this path included in %PATH% environment variable.  If you are getting this error in VS IDE, you can check the installation log for make sure successful installation.

     

    If you trying to compile from command line, you can start from Windows shortcut menu "Visual Studio 2008 Command Prompt " options.

     

     


    Thanks and Regards Selvam http://www15.brinkster.com/selvamselvam/
    Monday, May 30, 2011 9:13 AM
  • Hello. I had same problem before, and I found such problem seems because you did not installed C#.

    If you did not install C# with C++ for VS 2008, such error will not be solved.

     

    Johan Kim


    • Edited by JohanKim Monday, May 30, 2011 9:21 AM Adding
    Monday, May 30, 2011 9:21 AM
  • problem is easily solved by going to VS2010 and setting the executable directory withing the project settings... I had changed this myself thinking it would point to the exectuable to debug, not so, it is the directory that has the cl.exe bin.   Try using default path, if that does not work find out where the cl.exe is and just set the path there.

    Tuesday, December 18, 2012 5:03 AM
  • problem is easily solved by going to VS2010 and setting the executable directory withing the project settings... I had changed this myself thinking it would point to the exectuable to debug, not so, it is the directory that has the cl.exe bin.   Try using default path, if that does not work find out where the cl.exe is and just set the path there.

    Tuesday, December 18, 2012 5:03 AM
  • problem is easily solved by going to VS2010 and setting the executable directory withing the project settings... I had changed this myself thinking it would point to the exectuable to debug, not so, it is the directory that has the cl.exe bin.   Try using default path, if that does not work find out where the cl.exe is and just set the path there.

    Tuesday, December 18, 2012 5:03 AM