none
.Netframework 4.0 not working

    Question

  • I have tried every solution possible there is in the forums, but none of them work.

    I can not install microsoft word, autocad 2012 because I need to install .Net framework v4.0.30319.

     

    I went on the website and installed the latest full version for windows 7-32 bit ultimate. I installed it and it was perfectly fine. I restarted the computer and tried to installed microsoft word however it still asks me to install .net framwork 4.0. I checked the uninstall/install programs in control panel. It shows that I've installed the framework already. I went on the forums and checked many ways and tried to solve it but none of them works. So now I can only collect my log files using this application. If anyone out there can help me out I'd be very happy. I can send in my log files and help anyone out here can help me out.

    Tuesday, January 10, 2012 2:53 AM

All replies

  • Hi Agrnox,

     

    Welcome to the MSDN forum.

     

    Could you please upload the vslogs.cab file located in %temp% folder to an open website like Windows Live SkyDrive or send it to me (E-mail: v-alsun_at_microsoft_dot_com)?

    Note: Please attach the link of this post in the mail.

     

    I also recommend you use .NET Framework Setup Verification Tool to verify .NET Framework 4: http://blogs.msdn.com/b/astebner/archive/2008/10/13/8999004.aspx

    Please post the first 25 lines and the last 10 lines here.

     

    If you have any other concerns, please free feel to let me know.

     

    Best Regards,


    Alexander Sun [MSFT]
    MSDN Community Support | Feedback to us
    Wednesday, January 11, 2012 6:00 AM
  • [01/11/12,22:09:01] Beginning of new SetupVerifier activity logging session
    [01/11/12,22:09:01] Activity log file location: C:\Users\Ray\AppData\Local\Temp\setupverifier_main_01-11-12_22.09.01.txt
    [01/11/12,22:09:01] Error log file location: C:\Users\Ray\AppData\Local\Temp\setupverifier_errors_01-11-12_22.09.01.txt
    [01/11/12,22:09:01] Build created on December 29, 2011
    [01/11/12,22:09:01] Detected operating system: Windows 7 (x86)
    [01/11/12,22:09:01] Install state for .NET Framework 1.0: not installed.
    [01/11/12,22:09:01] Install state for .NET Framework 1.1: not installed.
    [01/11/12,22:09:01] Install state for .NET Framework 2.0: installed with service pack 2.
    [01/11/12,22:09:01] Install state for .NET Framework 3.0: installed with service pack 2.
    [01/11/12,22:09:01] Install state for .NET Framework 3.5: installed with service pack 1.
    [01/11/12,22:09:01] Install state for .NET Framework 4 Client: installed with no service packs.
    [01/11/12,22:09:01] Install state for .NET Framework 4 Full: installed with no service packs.
    [01/11/12,22:09:01] Not adding product '.NET Framework 1.0' because it is not currently installed
    [01/11/12,22:09:01] Not adding product '.NET Framework 1.1' because it is not currently installed
    [01/11/12,22:09:01] Not adding product '.NET Framework 1.1 SP1' because it is not currently installed
    [01/11/12,22:09:01] Not adding product '.NET Framework 2.0' because it is not currently installed
    [01/11/12,22:09:01] Not adding product '.NET Framework 2.0 SP1' because it is not currently installed
    [01/11/12,22:09:01] Not adding product '.NET Framework 3.0' because it is not currently installed
    [01/11/12,22:09:01] Not adding product '.NET Framework 3.0 SP1' because it is not currently installed
    [01/11/12,22:09:01] Not adding product '.NET Framework 3.5' because it is not currently installed
    [01/11/12,22:09:04] Starting verification for product .NET Framework 4 Full
    [01/11/12,22:09:04] Section [Files - .NET Framework 4 Client (Common)] - start parsing entries
    [01/11/12,22:09:04] File C:\Windows\Microsoft.NET\assembly\GAC_32\CustomMarshalers\v4.0_4.0.0.0__b03f5f7f11d50a3a\CustomMarshalers.dll (version 4.0.30319.1) is installed on the system
    [01/11/12,22:09:04] File C:\Windows\Microsoft.NET\assembly\GAC_32\ISymWrapper\v4.0_4.0.0.0__b03f5f7f11d50a3a\ISymWrapper.dll (version 4.0.30319.1) is installed on the system
    [01/11/12,22:09:04] File C:\Windows\Microsoft.NET\assembly\GAC_32\Microsoft.Transactions.Bridge.Dtc\v4.0_4.0.0.0__b03f5f7f11d50a3a\Microsoft.Transactions.Bridge.Dtc.dll (version 4.0.30319.1) is installed on the system
    ==========================================================
    First 25 lines above
    ==========================================================
    [01/11/12,22:09:06] Processing custom action 'Custom Action - .NET Framework 4.0 test application'
    [01/11/12,22:09:06] ExecutablePath = 'Netfx40TestApplication.exe'
    [01/11/12,22:09:06] FriendlyName = '.NET Framework 4 test application'
    [01/11/12,22:09:06] TimeoutSeconds = '300'
    [01/11/12,22:09:06] WaitOnExit = 'true'
    [01/11/12,22:09:06] Silent = 'true'
    [01/11/12,22:09:06] Launching process 'Netfx40TestApplication.exe' now
    [01/11/12,22:09:06] Process successfully launched. Waiting 300 seconds for it to complete.
    [01/11/12,22:09:06] ****ERROR**** Process 'Netfx40TestApplication.exe' exited with return code -2146232576
    [01/11/12,22:09:06] ****ERROR**** Verification failed for product .NET Framework 4 Full
    ============================================================
    Last 10 lines above
    ============================================================
    Thursday, January 12, 2012 6:12 AM
  • Hi Agrnox,

     

    Welcome to the MSDN forum.

     

    From your log:

    [01/11/12,22:09:06] ****ERROR**** Process 'Netfx40TestApplication.exe' exited with return code -2146232576

    [01/11/12,22:09:06] ****ERROR**** Verification failed for product .NET Framework 4 Full

    It means the .NET Framework 4 on your side is corrupt. I recommend you try to repair .NET Framework 4 in Control Panel first. Then try to verify it again. You also can repair it in command lines: http://blogs.msdn.com/b/astebner/archive/2009/04/16/9553804.aspx

     

    If the verification fails again, I recommend you uninstall .NET Framework 4 and reinstall it: http://www.microsoft.com/download/en/details.aspx?id=17718

     

    If you have any other questions, please feel free to let me know.

     

    Best Regards,


    Alexander Sun [MSFT]
    MSDN Community Support | Feedback to us
    Thursday, January 12, 2012 8:44 AM
  • [01/12/12,07:34:37] Beginning of new SetupVerifier activity logging session
    [01/12/12,07:34:37] Activity log file location: C:\Users\Ray\AppData\Local\Temp\setupverifier_main_01-12-12_07.34.37.txt
    [01/12/12,07:34:37] Error log file location: C:\Users\Ray\AppData\Local\Temp\setupverifier_errors_01-12-12_07.34.37.txt
    [01/12/12,07:34:37] Build created on December 29, 2011
    [01/12/12,07:34:37] Detected operating system: Windows 7 (x86)
    [01/12/12,07:34:37] Install state for .NET Framework 1.0: not installed.
    [01/12/12,07:34:37] Install state for .NET Framework 1.1: not installed.
    [01/12/12,07:34:37] Install state for .NET Framework 2.0: installed with service pack 2.
    [01/12/12,07:34:37] Install state for .NET Framework 3.0: installed with service pack 2.
    [01/12/12,07:34:37] Install state for .NET Framework 3.5: installed with service pack 1.
    [01/12/12,07:34:37] Install state for .NET Framework 4 Client: installed with no service packs.
    [01/12/12,07:34:37] Install state for .NET Framework 4 Full: installed with no service packs.
    [01/12/12,07:34:37] Not adding product '.NET Framework 1.0' because it is not currently installed
    [01/12/12,07:34:37] Not adding product '.NET Framework 1.1' because it is not currently installed
    [01/12/12,07:34:37] Not adding product '.NET Framework 1.1 SP1' because it is not currently installed
    [01/12/12,07:34:37] Not adding product '.NET Framework 2.0' because it is not currently installed
    [01/12/12,07:34:37] Not adding product '.NET Framework 2.0 SP1' because it is not currently installed
    [01/12/12,07:34:37] Not adding product '.NET Framework 3.0' because it is not currently installed
    [01/12/12,07:34:37] Not adding product '.NET Framework 3.0 SP1' because it is not currently installed
    [01/12/12,07:34:37] Not adding product '.NET Framework 3.5' because it is not currently installed
    [01/12/12,07:34:44] Starting verification for product .NET Framework 4 Client
    [01/12/12,07:34:44] Section [Files - .NET Framework 4 Client (Common)] - start parsing entries
    [01/12/12,07:34:44] File C:\Windows\Microsoft.NET\assembly\GAC_32\CustomMarshalers\v4.0_4.0.0.0__b03f5f7f11d50a3a\CustomMarshalers.dll (version 4.0.30319.1) is installed on the system
    [01/12/12,07:34:44] File C:\Windows\Microsoft.NET\assembly\GAC_32\ISymWrapper\v4.0_4.0.0.0__b03f5f7f11d50a3a\ISymWrapper.dll (version 4.0.30319.1) is installed on the system
    [01/12/12,07:34:44] File C:\Windows\Microsoft.NET\assembly\GAC_32\Microsoft.Transactions.Bridge.Dtc\v4.0_4.0.0.0__b03f5f7f11d50a3a\Microsoft.Transactions.Bridge.Dtc.dll (version 4.0.30319.1) is installed on the system
    ============================================================================]
    First 25 lines
    ===========================================================
    [01/12/12,07:34:46] Not running action 'Registry - .NET Framework 4 Client (Wow6432Node)' for product '.NET Framework 4 Client' because the OS condition does not match
    [01/12/12,07:34:46] Processing custom action 'Custom Action - .NET Framework 4.0 test application'
    [01/12/12,07:34:46] ExecutablePath = 'Netfx40TestApplication.exe'
    [01/12/12,07:34:46] FriendlyName = '.NET Framework 4 test application'
    [01/12/12,07:34:46] TimeoutSeconds = '300'
    [01/12/12,07:34:46] WaitOnExit = 'true'
    [01/12/12,07:34:46] Silent = 'true'
    [01/12/12,07:34:46] Launching process 'Netfx40TestApplication.exe' now
    [01/12/12,07:34:46] Process successfully launched. Waiting 300 seconds for it to complete.
    [01/12/12,07:34:46] ****ERROR**** Process 'Netfx40TestApplication.exe' exited with return code -2146232576
    [01/12/12,07:34:46] ****ERROR**** Verification failed for product .NET Framework 4 Client
    ==========================================================
    Last 10 lines
    ==========================================================
    I still have error after un-installing it, and re-installing it.
    Thursday, January 12, 2012 3:38 PM
  • Hi Agrnox,

     

    I checked your log. There are no .NET Framework 4 log generated in 1/13/2012. I recommend you try to collect the fresh log by the following steps:

    ·         Please download .NET Framework 4 from: http://www.microsoft.com/download/en/details.aspx?id=17718

    ·         Check if there are any anti-virus or antispyware applications running. Make sure they are turned off during installation.

    ·         Complete or dismiss Windows Updates before installation (but turn on Windows Update service).

    ·         Clean up your “%temp%” folder (Start>>Run>>%temp%)

    ·         Run the setup file with Administrator privileges: Right-click the installer > Run as administrator.

    ·         Download and run the Log Collection Tool: http://www.microsoft.com/downloads/details.aspx?FamilyID=e0da314f-6216-4a18-bc6b-7d29cf83af20&displaylang=en

    ·         Upload the vslogs.cab file located in %temp% folder to an open website like Windows Live SkyDrive or send it to me (E-mail: v-alsun_at_microsoft_dot_com).

    Note: Please attach the link of this post in the mail.

     

    If you have any other concerns, please feel free to let me know.

     

    Best Regards,


    Alexander Sun [MSFT]
    MSDN Community Support | Feedback to us
    Friday, January 13, 2012 7:46 AM
  • Hi Agrnox,

     

    I checked your fresh vslogs.cab. Unfortunately, there is no .NET Framework log inside, so please check if there is anything like “Microsoft .NET Framework 4 Setup_xxxxxxxx_xxxxxxxxx.html” and “Microsoft .NET Framework 4 Setup_xxxxxxxx_xxxxxxxxx-MSI_netfx_Core_x86.msi.txt” in %temp% folder.

     

    If you can find them, please upload them or send them to me.

     

    Best Regards,


    Alexander Sun [MSFT]
    MSDN Community Support | Feedback to us
    Monday, January 16, 2012 8:42 AM
  • Hi Agrnox,

     

    I checked your logs.

    But the verbose log still failed to be collected. I recommend you try to use Log Collection Tool as administratotr:http://www.microsoft.com/downloads/details.aspx?FamilyID=e0da314f-6216-4a18-bc6b-7d29cf83af20&displaylang=en

    To do so: Right click>>Run as administrator.

     

    If you have any other questions, please feel free to let me know.

     

    Best Regards,


    Alexander Sun [MSFT]
    MSDN Community Support | Feedback to us
    Friday, January 27, 2012 6:58 AM
  • Hi Agrnox,

     

    I checked your Email, but it seems like the vslogs.cab you uploaded is broken. You can clean up your %temp% folder before you install .NET Framework 4. After you tried to install it, please compress the %temp% folder by some tools like WinRAR. Then upload the compressed file to an open website like Windows Live SkyDrive or send it to me (E-mail: v-alsun_at_microsoft_dot_com).

     

    If you have any other questions, please feel free to let me know.

     

    Best Regards,


    Alexander Sun [MSFT]
    MSDN Community Support | Feedback to us
    Tuesday, January 31, 2012 8:59 AM
  • Hi Alexander,

    I having the same problem here, autodesk product just wont continue saying net framework 4 not installed, yet i have installed correctly, my window 7 is on bootcamp mac os lion, does that cause problem ?

    Sunday, February 26, 2012 1:46 PM
  • [02/26/12,21:50:49] Error log file location: C:\Users\CHUNKEAT\AppData\Local\Temp\setupverifier_errors_02-26-12_21.50.49.txt
    [02/26/12,21:50:49] Build created on December 29, 2011
    [02/26/12,21:50:49] Detected operating system: Windows 7 (x86)
    [02/26/12,21:50:49] Install state for .NET Framework 1.0: not installed.
    [02/26/12,21:50:49] Install state for .NET Framework 1.1: not installed.
    [02/26/12,21:50:49] Install state for .NET Framework 2.0: installed with service pack 2.
    [02/26/12,21:50:49] Install state for .NET Framework 3.0: installed with service pack 2.
    [02/26/12,21:50:49] Install state for .NET Framework 3.5: installed with service pack 1.
    [02/26/12,21:50:49] Install state for .NET Framework 4 Client: installed with no service packs.
    [02/26/12,21:50:49] Install state for .NET Framework 4 Full: installed with no service packs.
    [02/26/12,21:50:49] Not adding product '.NET Framework 1.0' because it is not currently installed
    [02/26/12,21:50:49] Not adding product '.NET Framework 1.1' because it is not currently installed
    [02/26/12,21:50:49] Not adding product '.NET Framework 1.1 SP1' because it is not currently installed
    [02/26/12,21:50:49] Not adding product '.NET Framework 2.0' because it is not currently installed
    [02/26/12,21:50:49] Not adding product '.NET Framework 2.0 SP1' because it is not currently installed
    [02/26/12,21:50:49] Not adding product '.NET Framework 3.0' because it is not currently installed
    [02/26/12,21:50:49] Not adding product '.NET Framework 3.0 SP1' because it is not currently installed
    [02/26/12,21:50:49] Not adding product '.NET Framework 3.5' because it is not currently installed
    [02/26/12,21:50:53] Starting verification for product .NET Framework 4 Full
    [02/26/12,21:50:53] Section [Files - .NET Framework 4 Client (Common)] - start parsing entries
    [02/26/12,21:50:53] File C:\Windows\Microsoft.NET\assembly\GAC_32\CustomMarshalers\v4.0_4.0.0.0__b03f5f7f11d50a3a\CustomMarshalers.dll (version 4.0.30319.1) is installed on the system
    [02/26/12,21:50:53] File C:\Windows\Microsoft.NET\assembly\GAC_32\ISymWrapper\v4.0_4.0.0.0__b03f5f7f11d50a3a\ISymWrapper.dll (version 4.0.30319.1) is installed on the system
    [02/26/12,21:50:53] File C:\Windows\Microsoft.NET\assembly\GAC_32\Microsoft.Transactions.Bridge.Dtc\v4.0_4.0.0.0__b03f5f7f11d50a3a\Microsoft.Transactions.Bridge.Dtc.dll (version 4.0.30319.1) is installed on the system
    [02/26/12,21:50:53] File C:\Windows\Microsoft.NET\assembly\GAC_32\Microsoft.VisualBasic.Activities.Compiler\v4.0_10.0.0.0__b03f5f7f11d50a3a\Microsoft.VisualBasic.Activities.Compiler.dll (version 10.0.30319.1) is installed on the system
    [02/26/12,21:50:53] File C:\Windows\Microsoft.NET\assembly\GAC_32\mscorlib\v4.0_4.0.0.0__b77a5c561934e089\mscorlib.dll (version 4.0.30319.1) is installed on the system
    [02/26/12,21:50:53] File C:\Windows\Microsoft.NET\assembly\GAC_32\PresentationCore\v4.0_4.0.0.0__31bf3856ad364e35\PresentationCore.dll (version 4.0.30319.1) is installed on the system
    [02/26/12,21:50:53] File C:\Windows\Microsoft.NET\assembly\GAC_32\System.Data\v4.0_4.0.0.0__b77a5c561934e089\System.Data.dll (version 4.0.30319.1) is installed on the system

    First 25 lines

    [02/26/12,21:51:03] Section [Registry - .NET Framework 4 Full (Common)] - stop parsing entries
    [02/26/12,21:51:03] Section [Registry - .NET Framework 4 Full (32-bit)] - start parsing entries
    [02/26/12,21:51:03] Section [Registry - .NET Framework 4 Full (32-bit)] - stop parsing entries
    [02/26/12,21:51:03] Not running action 'Registry - .NET Framework 4 Full (64-bit)' for product '.NET Framework 4 Full' because the OS condition does not match
    [02/26/12,21:51:03] Not running action 'Registry - .NET Framework 4 Full (Wow6432Node)' for product '.NET Framework 4 Full' because the OS condition does not match
    [02/26/12,21:51:03] Processing custom action 'Custom Action - .NET Framework 4.0 test application'
    [02/26/12,21:51:03] ExecutablePath = 'Netfx40TestApplication.exe'
    [02/26/12,21:51:03] FriendlyName = '.NET Framework 4 test application'
    [02/26/12,21:51:03] TimeoutSeconds = '300'
    [02/26/12,21:51:03] WaitOnExit = 'true'
    [02/26/12,21:51:03] Silent = 'true'
    [02/26/12,21:51:03] Launching process 'Netfx40TestApplication.exe' now
    [02/26/12,21:51:04] Process successfully launched. Waiting 300 seconds for it to complete.
    [02/26/12,21:51:04] ****ERROR**** Process 'Netfx40TestApplication.exe' exited with return code -2146232576
    [02/26/12,21:51:04] ****ERROR**** Verification failed for product .NET Framework 4 Full

    last 10 lines

    Sunday, February 26, 2012 1:54 PM
  • Hello, Travis.

    It appears that you have tried to verify .NET Framework 4.0 several times, but Alexander Sun's posts indicate that you have not tried a complete removal, followed by a reinstall from the standalone installer. If I have interpreted the conversation correctly, please go through the following procedure:

    Uninstall .NET Framework 4.0 using Add/Remove...

    Make sure any remaining pieces of .NET Framework 4.0 are removed with this tool:

    http://blogs.msdn.com/b/astebner/archive/2008/08/28/8904493.aspx

    Follow these steps exactly:

    1. Download a fresh copy of the standalone installer for .NET Framework 4.0:

    http://www.microsoft.com/download/en/details.aspx?displaylang=en&id=17718

    2. Before running the installer, apply irarab's fix as follows:

    "I went to "C:\Windows\Microsoft.NET" there is a directory called "assembly".

    I looked in the directory and found some subdirectories with lots of old dot net 4 files. I renamed the directory assembly2 and tried to install Dot Net 4 and it worked!!!!

    (You can't delete the assembly directory unless you take ownership of it but you can rename it.)"

    Also, clear your %temp% directory and disable your AV software.

    The %temp% directory is a reference to the Temp folder associated with the current user. To clear it, do the following:

    Sign on to your system with the Administrator user account you will use to run the installer. Click the Start Orb and type %temp% in the search box. The search results will show the Temp folder you want. Click on the Temp folder to open it in Windows Explorer, then delete the entire contents.

    3. Run the standalone installer from step 1 As Administrator.

    Whether the install fails or succeeds, provide complete install logs as follows:

    Collect your full install logs as follows:

    Please collect your install logs with this:

    http://www.microsoft.com/downloads/details.aspx?FamilyID=E0DA314F-6216-4A18-BC6B-7D29CF83AF20&displaylang=e&displaylang=en

    After you run Collect.exe, you'll find vslogs.cab in your %temp% directory. Please upload vslogs.cab to a public site, like SkyDrive, and post the link here.


    • Edited by pvdg42MVP Tuesday, February 28, 2012 7:01 PM
    Tuesday, February 28, 2012 6:57 PM
  • pvdg42, your last post, i followed it step by step and it is still failing. It has been suggested to me to do a clean install of win7 but i REALLY want to avoid that.

    Here is my vslogs.cab:

    https://skydrive.live.com/redir.aspx?cid=5608b0e6bd84aa0a&resid=5608B0E6BD84AA0A!105&parid=root

    Below is my verification failure log:

    .NET Framework 4 Full log:

    [03/01/12,09:41:24] Section [Registry - .NET Framework 4 Full (Wow6432Node)] - stop parsing entries

    [03/01/12,09:41:24] Processing custom action 'Custom Action - .NET Framework 4.0 test application'
    [03/01/12,09:41:24] ExecutablePath = 'Netfx40TestApplication.exe'
    [03/01/12,09:41:24] FriendlyName = '.NET Framework 4 test application'
    [03/01/12,09:41:24] TimeoutSeconds = '300'
    [03/01/12,09:41:24] WaitOnExit = 'true'
    [03/01/12,09:41:24] Silent = 'true'
    [03/01/12,09:41:24] Launching process 'Netfx40TestApplication.exe' now
    [03/01/12,09:41:24] Process successfully launched. Waiting 300 seconds for it to complete.
    [03/01/12,09:41:24] ****ERROR**** Process 'Netfx40TestApplication.exe' exited with return code -2146232576
    [03/01/12,09:41:24] ****ERROR**** Verification failed for product .NET Framework 4 Full

    .NET Framework 4 Client Log:

    [03/01/12,09:42:19] Section [Registry - .NET Framework 4 Client (Wow6432Node)] - stop parsing entries
    [03/01/12,09:42:19] Processing custom action 'Custom Action - .NET Framework 4.0 test application'
    [03/01/12,09:42:19] ExecutablePath = 'Netfx40TestApplication.exe'
    [03/01/12,09:42:19] FriendlyName = '.NET Framework 4 test application'
    [03/01/12,09:42:19] TimeoutSeconds = '300'
    [03/01/12,09:42:19] WaitOnExit = 'true'
    [03/01/12,09:42:19] Silent = 'true'
    [03/01/12,09:42:19] Launching process 'Netfx40TestApplication.exe' now
    [03/01/12,09:42:19] Process successfully launched. Waiting 300 seconds for it to complete.
    [03/01/12,09:42:19] ****ERROR**** Process 'Netfx40TestApplication.exe' exited with return code -2146232576
    [03/01/12,09:42:19] ****ERROR**** Verification failed for product .NET Framework 4 Client


    • Edited by Haze123 Thursday, March 01, 2012 2:43 PM
    Thursday, March 01, 2012 2:42 PM
  • Your vslogs.cab does not have a log from installation of .NET Framework 4.0.

    If your situation is that you install .NET Framework 4.0 successfully, but it then fails verification, you have two options:

    1. You can attempt to repair it from the installed programs dialog.

    2. If this situation occurs after several install attempts, you should consider reinstalling your OS.

    Thursday, March 01, 2012 3:15 PM