none
.NET Framework 1.0 install

    General discussion

  • My friend removed some files accidently and ended up uninstalling all of the .NET Framework files.  The system is running WinXP on a desktop Compaq 6000T.  After running the Windows Installer Utility, we started to reinstall the .NET files.  When reinstalling 1.0, the system asks where to place the files and I don't know what to tell her.  I need step-by-step instructions so that I can walk her through or show her how to complete this install.
    Here is a list of what took place while trying to install:
     

    .NET Framework 1.0 – Message box - need to name location where you want files…..I did not know where to put them.
    .NET Framework 1.0 Service Pack 3Message box – NET Framework 1.0 SP 3 – The upgrade Patch cannot be installed by Windows installer service because the program to be upgraded may be missing or the upgrade may update a different version of the program.
    .NET Framework 1.1Setup complete.
    .NET Framework l.l Service Pack 1 Successfully installed on Microsoft .NET Framework 1.1.  Must restart computer..Click yes.  However, when restarted computer got message box - hpqimzone.exe – Common Language Runtime Debugging Services - Heading

    Application has generated an exception that could not be handled
    Click OK to terminate the application
    Click cancel to debug the application….Clicked…No debugger found    

    .NET Framework 2.0 – Successfully Installed. 

    .NET Framework 2.0 Service Pack 1 Message box - Setup has detected that this computer does not meet the requirement to install this software.  These requirements must be met before you can install Microsoft NET Framework 2.0 SP1.

     

    .NET Framework 3.0 – Message box – You must install this service pack to complete installation.  Microsoft .NET Framework 3.0 requires that this service pack be installed prior to installation.  Service Pack 2 

    .NET Framework 3.0 Service Pack 1 -

    Encountered problem during setup..Setup could not download all of the necessary files….To attempt another download, Click Exit and then restart setup. 

    .NET Framework 3.5Message box

    Windows XP Service Pack 2 update information

    You must install this service pack to complete installation.  Microsoft NET Framework 3.5 requires that this service pack be installed prior to the installation.  

    Microsoft Windows Installer 3.1

    You must install Windows Installer 3.1 to complete installation.  Microsoft NET Framework 3.5 requires that Windows 3.1 be installed prior to the installation.

    Can you help me to get this install complete?
    Bob

    • Changed type YiChun Chen Monday, August 31, 2009 7:33 AM Do not follow up
    Monday, August 24, 2009 7:47 PM

All replies

  • Hi Rjlump55,

    Thank you for your detail information.

    I can understand that you want to install all the .NET Framework. Let's start the following steps to install .NET Frameworks.

    Some clarification:
    Is your XP the Media Center Edition or Tablet PC Edition? Please right click "My Computer" >> Click "Properties" >> Check "System" in "General" tab.

    If your XP is Home or Professional Edition, please try using the following steps to solve the problem:
    - Download the .NET Framework cleanup tool and choose to clean up the version of the .NET Framework that is causing problems on your system
    - Download and install the version of the .NET Framework that you cleaned up in step 1 (such as the .NET Framework 1.0, .NET Framework 1.1 or .NET Framework 2.0
    - (optional) Download and run the .NET Framework verification tool to double-check that all .NET Framework files are correctly installed
    - Download and install the desired .NET Framework service pack (such as .NET Framework 1.0 SP3 or .NET Framework 1.1 SP1) by running the setup package directly instead of using Windows Update. Running it directly will allow the service pack setup to display error dialogs instead of having Windows Update suppress them.

    If your XP is Media Center or Tablet PC Edition, the above steps can be applied to all .NET Frameworks except .NET Framework 1.0 since .NET Framework 1.0 is includes as OS component in these editions. We need other tricks to repair .NET Framework 1.0 on these operation systems.

    Hope this helps.

    Best regards,
    Yichun Chen
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    Welcome to the All-In-One Code Framework! If you have any feedback, please tell us.
    Wednesday, August 26, 2009 8:29 AM
  • Hi Rjlump55,

    We are changing the issue type to “Comment” because you have not followed up with the necessary information. If you have more time to look at the issue and provide more information, please feel free to change the issue type back to “Question” by editing your initial post and changing the radio button at the top of the post editor window. If the issue is resolved, we will appreciate it if you can share the solution so that the answer can be found and used by other community members having similar questions.

    Thank you!
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    Welcome to the All-In-One Code Framework! If you have any feedback, please tell us.
    Monday, August 31, 2009 7:33 AM