none
Start without debugging button missing in Visual Studio 2010?

    Question

  • Hi,
    I cannot find the Start Without debugging option under Debug menu in Visual Studio 2010, visual basic settings. Is this feature removed??
    I've tried adding it from Tools->Customize->Commands, but the button/command is not to be found there either.
    Mcad
    Tuesday, January 26, 2010 9:11 AM

Answers

  • Hi Mcad,

    Thank you for your post.

    I've changed my development environment to Visual Basic as default via Tools menu >> Import and Export Settings >> Reset all settings.
    Then I could reproduce the same scenario as you mentioned in the following screen shot:


    When I changed it back to Visual C# IDE, I could find Start Without debugging option. Thus, it seems that this option is not available by default in Visual Basic IDE. To invoke this feature, we could press "Ctrl + F5" or change the IDE from Visual Basic to C#.

    BTW, this forum is for the support of Visual Studio RTM installation. Since your issue is related to VS2010 Beta, you could post your thread on Visual Studio 2010 Install and Setup forum. This will make answer searching in the forum easier and be beneficial to other community members as well.

    Thank you for your understanding.

    Best regards,
    Yichun Chen


    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    Welcome to the All-In-One Code Framework! If you have any feedback, please tell us.
    • Marked as answer by Mcad01 Wednesday, January 27, 2010 10:31 AM
    Wednesday, January 27, 2010 7:38 AM

All replies

  • Hi Mcad,

    Thank you for your post.

    I've changed my development environment to Visual Basic as default via Tools menu >> Import and Export Settings >> Reset all settings.
    Then I could reproduce the same scenario as you mentioned in the following screen shot:


    When I changed it back to Visual C# IDE, I could find Start Without debugging option. Thus, it seems that this option is not available by default in Visual Basic IDE. To invoke this feature, we could press "Ctrl + F5" or change the IDE from Visual Basic to C#.

    BTW, this forum is for the support of Visual Studio RTM installation. Since your issue is related to VS2010 Beta, you could post your thread on Visual Studio 2010 Install and Setup forum. This will make answer searching in the forum easier and be beneficial to other community members as well.

    Thank you for your understanding.

    Best regards,
    Yichun Chen


    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    Welcome to the All-In-One Code Framework! If you have any feedback, please tell us.
    • Marked as answer by Mcad01 Wednesday, January 27, 2010 10:31 AM
    Wednesday, January 27, 2010 7:38 AM
  • Thanx,
    Reproduced your findings at my machine. Still baffled why it doesnt appear in VB settings - will post in correct forum. Thanx :)
    Mcad
    Wednesday, January 27, 2010 10:32 AM
  • Hi Mcad,

    It's my pleasure!

    Have a great week.

    Best regards,
    Yichun Chen
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    Welcome to the All-In-One Code Framework! If you have any feedback, please tell us.
    Thursday, January 28, 2010 3:28 AM
  • I had a similar with  C#  problem and I found the following solution: In the "Tools/Settings" Menu I checked the "Expert Settings" and the Start Without Debugging showed up again

     

     

     

    • Proposed as answer by Carter Smith Sunday, May 29, 2011 2:37 PM
    Thursday, March 17, 2011 12:58 PM
  • This is very frustrating in VS 2010 and quite poor that start without debugger button is not available. Apparently if you upgrade from VS2005 this button is available, if its a fresh install it is not anywhere. Here is the solution.

    Tools >> Customize. Than command tab and select toolbar. Select build toolbar. NOW select 'Add Command' button. This brings another list of all commands which contain everything. Go into 'Debug' in the catagories lilst on left side and you will find the 'start without debugger'. Add that to the toolbar (built toolbar). Make sure you hae 'build' toolbar turn on in the IDE and it will be added to it.


    • Proposed as answer by serkan sendur Wednesday, May 18, 2011 12:29 AM
    Tuesday, April 05, 2011 6:48 PM
  • Thanks uml, you have been very helpful.
    Wednesday, May 18, 2011 12:29 AM
  • Marcos has the correct answer. The default is 'basic settings' which does not include the CTRL + F5 option to start without debugging. Change your settings to Expert to correct this.
    Tuesday, September 06, 2011 1:23 PM