none
Error on adding new Packages to the VS Prerequisites Dialog Box

    Question

  • I was trying to add some prerequisites 3rd party tools in Setup project prerequisites dialog box. In Bootstrapper, I write Product.xml and Package.xml manifest files. and added to the right location "~\Program Files\Microsoft SDKs\Windows\v6.0A\Bootstrapper\Packages\~"
    but  still new entry is not showing in dotnet project Prerequisites box (Properties\Prerequisites) 

    Here is my sample Product.xml file. Please help me to find out where I am doing wrong.

    <?xml version="1.0" encoding="utf-8"?>
    <Product xmlns="http://schemas.microsoft.com/developer/2004/01/bootstrapper" ProductCode="Custom.Bootstrapper.Package.RemoteDesktop">

    <RelatedProducts>
    <DependsOnProduct Code="Microsoft.Net.Framework.2.0" />
    </RelatedProducts>

    <PackageFiles>
    <PackageFile Name="Setup.RemoteDesktopManager.6.9.8.0.exe"/>
    </PackageFiles>

    <InstallChecks>

    <RegistryCheck Property="IsRemoteDesktopInstalled" Key="HKEY_CURRENT_USER\Software\RemoteDesktopManager" />

    </InstallChecks>

    <Commands>
    <Command PackageFile="Setup.RemoteDesktopManager.6.9.8.0.exe" Arguments="">

    <InstallConditions>
    <BypassIf
    Property="IsRemoteDesktopInstalled"
    Compare="ValueGreaterThan" Value="0"/>
    <FailIf Property="AdminUser"
    Compare="ValueNotEqualTo" Value="True"
    String="NotAnAdmin"/>
    </InstallConditions>

    <ExitCodes>
    <ExitCode Value="0" Result="Success"/>
    <ExitCode Value="1641" Result="SuccessReboot"/>
    <ExitCode Value="3010" Result="SuccessReboot"/>
    <DefaultExitCode Result="Fail" String="GeneralFailure"/>
    </ExitCodes>
    </Command>
    </Commands>
    </Product>

    Thanks in Advance :)


    Friday, August 31, 2012 6:29 AM

Answers

All replies