none
BUG - Capacity in TFS (Service) no longer works

    Question

  • When I try and set capacity for a Sprint in TFS I am no longer able to perform any changes to the capacities listed whether it be to the fields - capacity per day, activity or days off. I am also unable to copy the capacities from a previous sprint. I was able to do both before but now the Save and Copy icons are grayed out. I am in the Project Administrators group only and should have full permission.
    Tuesday, January 22, 2013 2:18 PM

Answers

  • Hi,

    Thank you for your post.

    I test the issue in my side. "contents", "capacity" and "work details" work properly in my side. Please make a try again.

    Hope you can provide following information to help narrow down the issue:
    1. It seems the issue is you cannot edit "Capacity Per Day", "Activity" and "Days Off" now, but you can edit them before. If I have misunderstood anything, please free feel to let me know.
    2. Hope you can show us a screen shot of the issue.
    3. Please let other team member make a try. This information can help us know the issue exists for specific user or not.

    Regards,


    Lily Wu
    MSDN Community Support | Feedback to us
    Develop and promote your apps in Windows Store
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    Wednesday, January 23, 2013 3:17 AM

All replies

  • Hi,

    Thank you for your post.

    I test the issue in my side. "contents", "capacity" and "work details" work properly in my side. Please make a try again.

    Hope you can provide following information to help narrow down the issue:
    1. It seems the issue is you cannot edit "Capacity Per Day", "Activity" and "Days Off" now, but you can edit them before. If I have misunderstood anything, please free feel to let me know.
    2. Hope you can show us a screen shot of the issue.
    3. Please let other team member make a try. This information can help us know the issue exists for specific user or not.

    Regards,


    Lily Wu
    MSDN Community Support | Feedback to us
    Develop and promote your apps in Windows Store
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    Wednesday, January 23, 2013 3:17 AM
  • Hi Lily,

    I actually wrote up a complete scenario on this with screen shots but it wouldn't let me submit it. I received a Popup saying I am not able to submit images and this is what it said - "Body text cannot contain images or links until we are able to verify your account." I am logged in.

    Here is basically how I "fixed" it:

    I was on the Project Admin group only and I cannot do anything with capacity. This group has full permissions set to Allow on everything. I then add myself (while staying in the admin group) to a new group which has the following permissions:

    The default project team.
    Create test runs Inherited Allow
    Delete team project Deny
    Delete test runs Inherited Allow
    Edit project-level information Inherited Allow
    Manage test configurations Not Set
    Manage test environments Inherited Allow
    View project-level information Allow
    View test runs

    Inherited All

    This works as I am now able to add in capacity and copy it from one iteration to another. Hope this helps.
    Wednesday, January 23, 2013 5:38 PM
  • Hi, 

    You can upload the screenshot on your SkyDrive, then share us the link.

    Friday, January 25, 2013 9:28 AM
  • Hi, 

    How about the issue now?

    If anything is unclear, please free feel to let me know. 

    Regards,


    Lily Wu
    MSDN Community Support | Feedback to us
    Develop and promote your apps in Windows Store
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    Tuesday, January 29, 2013 1:19 AM
  • I think the Capacity issue has been solved. I may end up creating a new bug for an issue where while I am the top level admin for the collection I cannot remove myself from the build group for a project. It says I don't have permission. I also am having an issue with permissions relating to doing a build in general. If I add myself the the Team group for the project then I can no longer see builds, but I can see the builds if I am just in the Build group alone. But then I am not available for tasks on the project nor am I in the list for setting capacity. I even went so far as to set all the permissions from the very top level all the way down to Allow explicitly and I still get the error that I don't have permission. Not good.
    Tuesday, January 29, 2013 2:46 PM
  • Hi,

    Thank you for your response information.

    In this thread, we are mainly discussing about "Capacity" issue. Seems you have other permission issue on build and on other usage. It would be better if you open up a new thread for the new question. In this way, our discussion here will not deviate too much from the original issue. This will make answer searching in the forum easier and be beneficial to other community members as well.

    Thank you for your understanding.

    Best Regards,


    Lily Wu
    MSDN Community Support | Feedback to us
    Develop and promote your apps in Windows Store
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    Wednesday, January 30, 2013 6:56 AM
  • Hi,

    Since we haven't heard from you for a long time, I temporarily close this case. I mark useful reply as answer. If you have any concerns, please feel free to reopen it or submit a new question. Thanks for your understanding.

    Regards,


    Lily Wu
    MSDN Community Support | Feedback to us
    Develop and promote your apps in Windows Store
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    Monday, February 04, 2013 2:22 AM