none
<customErrors> tag should have its "mode" attribute set to "Off".

    Question

  • Running a vb.net application on a windows 2003 server I receive the following error message, I checked: the mode attribute of the customErrors tag in the config file is set to "Off" and it still produces the same problem.

    I read in some forum that if the config file is unreadable then this error message would occure so I removed the config file completely and created a new one and still no luck.

    Please Help!

    Server Error in '/abeltools/Admin' Application.

    Runtime Error

    Description: An application error occurred on the server. The current custom error settings for this application prevent the details of the application error from being viewed remotely (for security reasons). It could, however, be viewed by browsers running on the local server machine.

    Details: To enable the details of this specific error message to be viewable on remote machines, please create a <customErrors> tag within a "web.config" configuration file located in the root directory of the current web application. This <customErrors> tag should then have its "mode" attribute set to "Off".

    <!-- Web.Config Configuration File -->
    
    <configuration>
        <system.web>
            <customErrors mode="Off"/>
        </system.web>
    </configuration>

    Notes: The current error page you are seeing can be replaced by a custom error page by modifying the "defaultRedirect" attribute of the application's <customErrors> configuration tag to point to a custom error page URL.

    <!-- Web.Config Configuration File -->
    
    <configuration>
        <system.web>
            <customErrors mode="RemoteOnly" defaultRedirect="mycustompage.htm"/>
        </system.web>
    </configuration>

    Wednesday, August 30, 2006 8:29 PM

Answers

  • You might be mis-interpreting the error message here.  ASP is telling you that your VB.NET code crashed with an unhandled exception.  But it is not allowed to tell you why.  It recommends that you modify the web.config file so that *is* allowed to tell you why.  Easiest thing to do is to recreate the error while you browse on the IIS server itself.  Or modify the web.config file, there'll be lots of people that can tell you how at forums.asp.net...
    Wednesday, August 30, 2006 8:58 PM

All replies

  • You might be mis-interpreting the error message here.  ASP is telling you that your VB.NET code crashed with an unhandled exception.  But it is not allowed to tell you why.  It recommends that you modify the web.config file so that *is* allowed to tell you why.  Easiest thing to do is to recreate the error while you browse on the IIS server itself.  Or modify the web.config file, there'll be lots of people that can tell you how at forums.asp.net...
    Wednesday, August 30, 2006 8:58 PM
  • Running a vb.net application on a windows 2003 server I receive the following error message, I checked: the mode attribute of the customErrors tag in the config file is set to "Off" and it still produces the same problem.

    I read in some forum that if the config file is unreadable then this error message would occure so I removed the config file completely and created a new one and still no luck.

    Please Help!

    Description: An application error occurred on the server. The current custom error settings for this application prevent the details of the application error from being viewed remotely (for security reasons). It could, however, be viewed by browsers running on the local server machine.

    Details: To enable the details of this specific error message to be viewable on remote machines, please create a <customErrors> tag within a "web.config" configuration file located in the root directory of the current web application. This <customErrors> tag should then have its "mode" attribute set to "Off".

    <!-- Web.Config Configuration File -->
    
    
    
    <configuration>
    
      <system.web>
    
        <customErrors mode="Off"/>
    
      </system.web>
    
    </configuration>

    Notes: The current error page you are seeing can be replaced by a custom error page by modifying the "defaultRedirect" attribute of the application's <customErrors> configuration tag to point to a custom error page URL.

    <!-- Web.Config Configuration File -->
    
    
    
    <configuration>
    
      <system.web>
    
        <customErrors mode="RemoteOnly" defaultRedirect="mycustompage.htm"/>
    
      </system.web>
    
    </configuration>

    Server Error in '/abeltools/Admin' Application.

    Runtime Error

     


    Tuesday, May 18, 2010 9:42 PM
  • I had a same problem and now it is solved 

    in IIS settings properties->ASP.NET tag change FRAMEWORK , after this reset IIS and check again

    else after do below steps:

    HomeDirectory->Application Pool->change Pool settings else make new pool according to framework settings 

    also change ->Home directory->Execute permissions->Scritps and Executables


    --Himanshu Kulkarni


    Friday, February 22, 2013 12:35 PM