none
WIC installer error while trying to install Net 3.0

    General discussion

  • Hi. I'm trying to install Games for Windows Live and it requires the NET 3.0. The installation of the NET does not work. Here is the error log.

    [02/28/09,17:54:17] WIC Installer: [2] Error code 1603 for this component means "Fatal error during installation.
    "
    [02/28/09,17:54:17] WIC Installer: [2] Setup Failed on component WIC Installer
    [02/28/09,17:54:20] WapUI: [2] DepCheck indicates WIC Installer is not installed.
    [02/28/09,17:54:20] WapUI: [2] DepCheck indicates Microsoft .NET Framework 3.0 was not attempted to be installed.
    [02/28/09,18:09:23] WIC Installer: [2] Error code 1603 for this component means "Fatal error during installation.
    "
    [02/28/09,18:09:23] WIC Installer: [2] Setup Failed on component WIC Installer
    [02/28/09,18:09:26] WapUI: [2] DepCheck indicates WIC Installer is not installed.
    [02/28/09,18:09:26] WapUI: [2] DepCheck indicates Microsoft .NET Framework 3.0 was not attempted to be installed.
    [02/28/09,18:13:28] WIC Installer: [2] Error code 1603 for this component means "Fatal error during installation.
    "
    [02/28/09,18:13:28] WIC Installer: [2] Setup Failed on component WIC Installer
    [02/28/09,18:13:33] WapUI: [2] DepCheck indicates WIC Installer is not installed.
    [02/28/09,18:13:33] WapUI: [2] DepCheck indicates Microsoft .NET Framework 3.0 was not attempted to be installed.
    [03/04/09,11:49:33] WIC Installer: [2] Error code 1603 for this component means "Fatal error during installation.
    "
    [03/04/09,11:49:33] WIC Installer: [2] Setup Failed on component WIC Installer
    [03/04/09,11:49:36] WapUI: [2] DepCheck indicates WIC Installer is not installed.
    [03/04/09,11:49:36] WapUI: [2] DepCheck indicates Microsoft .NET Framework 3.0 was not attempted to be installed.
    [03/04/09,12:07:03] WIC Installer: [2] Error code 1603 for this component means "Fatal error during installation.
    "
    [03/04/09,12:07:03] WIC Installer: [2] Setup Failed on component WIC Installer
    [03/04/09,12:07:05] WapUI: [2] DepCheck indicates WIC Installer is not installed.
    [03/04/09,12:07:05] WapUI: [2] DepCheck indicates Microsoft .NET Framework 3.0 was not attempted to be installed.
    [03/04/09,14:55:36] WIC Installer: [2] Error code 1603 for this component means "Fatal error during installation.
    "
    [03/04/09,14:55:36] WIC Installer: [2] Setup Failed on component WIC Installer
    [03/04/09,14:55:41] WapUI: [2] DepCheck indicates WIC Installer is not installed.
    [03/04/09,14:55:41] WapUI: [2] DepCheck indicates Microsoft .NET Framework 3.0 was not attempted to be installed.


    Please tell me a solution for this problem.
    • Changed type YiChun Chen Wednesday, March 11, 2009 2:42 AM Do not follow up
    Wednesday, March 04, 2009 1:06 PM

All replies

  • Help.
    Thursday, March 05, 2009 12:59 AM
  • Hi Myccaynen,

    Welcome to MSDN forums.

    More clarification with you. What is your OS?

    Could you please try to help me to use collect tool to collect the log files of .Net Framework 3.0 from your "%temp%" folder?
    http://blogs.msdn.com/heaths/archive/2008/05/09/visual-studio-and-net-log-collection-utility.aspx

    Then compress them into a zip file and post a link back.

    Steps:
    - Try to clean your "%temp%" folder
    - Install .Net Framework 3.0
    - Collect the logs from "%temp%" folder

    Thanks

    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    Friday, March 06, 2009 2:19 AM
  • Hi Myccaynen,

    We are changing the issue type to “Comment” because you have not followed up with the necessary information. If you have more time to look at the issue and provide more information, please feel free to change the issue type back to “Question” by editing your initial post and changing the radio button at the top of the post editor window. If the issue is resolved, we will appreciate it if you can share the solution so that the answer can be found and used by other community members having similar questions.

    Thank you!

     


    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    Wednesday, March 11, 2009 2:41 AM