none
Failed to install .NEt Framework 4.0

    Question

  • I uninstalled it because I was getting errors and I couldn't repair it.  I tried clearing out my temp folder and run as administrator but it keeps failing.

     

    I got the log here hope this will help

    https://skydrive.live.com/redir.aspx?cid=e09b79a57dd0f01e&resid=E09B79A57DD0F01E!108

     

    Thanks for the quick response.

    Saturday, October 15, 2011 1:45 AM

Answers

  • From the logs, here's your core issue:

    "Exe (C:\b57028f0e90c411c191064f189cb\Windows6.1-KB958488-v6001-x64.msu) failed with 0x240006 - (null).
     PerformOperation on exe returned exit code 2359302 (translates to HRESULT = 0x240006)

    INSTALLMESSAGE_ERROR [There is a problem with this Windows Installer package. Please refer to the setup log for more information. ]
     MSI (C:\b57028f0e90c411c191064f189cb\netfx_Core_x64.msi) Installation failed. Msi Log: Microsoft .NET Framework 4 Setup_20111014_213020945-MSI_netfx_Core_x64.msi.txt
     PerformOperation returned 1603 (translates to HRESULT = 0x80070643)"

    I suggest you read through this thread, especially Alexander Sun's answer as it pertains to the KB issue.

    http://social.msdn.microsoft.com/Forums/en-US/netfxsetup/thread/9f3e6515-32ce-4163-8496-8d7835de2a55

    I would also ask you to follow all steps in the suggestions I offer in the same thread, as I note from your vslogs that there were several attempts to install .NET Framework 4.0 without clearing your %temp% directory before each attempt.

     

    • Marked as answer by Alexander Sun Tuesday, October 25, 2011 3:12 AM
    Saturday, October 15, 2011 2:02 PM

All replies

  • From the logs, here's your core issue:

    "Exe (C:\b57028f0e90c411c191064f189cb\Windows6.1-KB958488-v6001-x64.msu) failed with 0x240006 - (null).
     PerformOperation on exe returned exit code 2359302 (translates to HRESULT = 0x240006)

    INSTALLMESSAGE_ERROR [There is a problem with this Windows Installer package. Please refer to the setup log for more information. ]
     MSI (C:\b57028f0e90c411c191064f189cb\netfx_Core_x64.msi) Installation failed. Msi Log: Microsoft .NET Framework 4 Setup_20111014_213020945-MSI_netfx_Core_x64.msi.txt
     PerformOperation returned 1603 (translates to HRESULT = 0x80070643)"

    I suggest you read through this thread, especially Alexander Sun's answer as it pertains to the KB issue.

    http://social.msdn.microsoft.com/Forums/en-US/netfxsetup/thread/9f3e6515-32ce-4163-8496-8d7835de2a55

    I would also ask you to follow all steps in the suggestions I offer in the same thread, as I note from your vslogs that there were several attempts to install .NET Framework 4.0 without clearing your %temp% directory before each attempt.

     

    • Marked as answer by Alexander Sun Tuesday, October 25, 2011 3:12 AM
    Saturday, October 15, 2011 2:02 PM
  • Hi Ripepi,

     

    Welcome to the MSDN forum.

     

    Have you tried MVP’s suggestion? Does it work?

     

    If you have any other concerns, please feel free to let me know.

     

    Best Regards,


    Alexander Sun [MSFT]
    MSDN Community Support | Feedback to us
    Get or Request Code Sample from Microsoft
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    Monday, October 17, 2011 8:52 AM