none
.NET Runtime version 2.0.50727.3053 - Fatal Execution Engine Error

    General discussion

  • I am receiving the following error anytime I try to run a .net application:

    XXX has encountered a problem and needs to close.  We are sorry for the inconvenience.


    From the Event Viewer:

    .NET Runtime version 2.0.50727.3053 - Fatal Execution Engine Error (7A097706) (80131506)

    For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.



    I have tried re-installing .net frameworks 2,3, and 3.5 but problem persists. 

    • Changed type Figo Fei Friday, October 03, 2008 2:37 AM to comment
    Friday, September 26, 2008 11:12 PM

All replies

  • What is your Windows version?

    Please use the .NET verification tool to verify the installation: http://blogs.msdn.com/astebner/archive/2008/03/03/8015158.aspx

    Also check out if the security settings on the machine(Control panel > Administrative tool > .NET Framework 2.0 configuration) has granted the application permissions.

    Thanks.
    Please remember to mark the replies as answers if they help and unmark them if they provide no help. http://forums.msdn.microsoft.com/en-US/vssetup/thread/60424309-bd78-4ca2-b618-03c4a16123b6
    Monday, September 29, 2008 3:48 AM
  • I am using Windows XP. I ran the tool from 2.0 up to 3.5 and everything checked okay.

    I wasn't able to run the .net configuration because that msc is not installed on the computer. 
    Monday, September 29, 2008 5:40 PM
  • Is the Windows XP with latest sp3 or at least sp2?

    Please double check out that whether ALL the .NET applications are infected or there are some survivors.
    Also try rebooting the machine into safemode to eliminate other software interferences.

    The .NET Framework 2.0 configuration tool is within .NET Framework 2.0 SDK, it's available here: http://www.microsoft.com/downloads/details.aspx?familyid=fe6f2099-b7b4-4f47-a244-c96d69c35dec&displaylang=en

    Thanks.
    Please remember to mark the replies as answers if they help and unmark them if they provide no help. http://forums.msdn.microsoft.com/en-US/vssetup/thread/60424309-bd78-4ca2-b618-03c4a16123b6
    Tuesday, September 30, 2008 2:16 AM
  • I tried running in safe mode and sure enough, I could get the programs running again.  I'm not sure if its every .net program on my computer but definately quite a few.

    I'm not sure where to begin troubleshooting for something like this.  Is there any documentation I could look through?  I tried disabling Symantec EndPoint (Antivirus, antispyware, etc) but that didn't help.
    Tuesday, September 30, 2008 11:41 PM
  • I'm not sure it is .NET Framework security configuration issue or not, but for security settings you can refer to this article: http://www.15seconds.com/issue/040121.htm (Configuring .NET Code Access Security)

    To test and isolate potential causes, you can try creating a simple Helloworld .NET application by VS Express edition(it is free and available at www.microsoft.com/Express) to see if it works on the machine and then go further.

    thanks
    Please remember to mark the replies as answers if they help and unmark them if they provide no help. http://forums.msdn.microsoft.com/en-US/vssetup/thread/60424309-bd78-4ca2-b618-03c4a16123b6
    Wednesday, October 01, 2008 2:23 AM
  • The .Net programs run when I compile and run from Visual Studio.  If I try to run the same program again compiled outside of VS, it gives me the error.
    Wednesday, October 08, 2008 7:15 PM
  • I have the same problem.

    How you been able to resolve this issue?
    Wednesday, February 04, 2009 4:35 PM
  • I tried to run the Microsoft "

    Windows SDK for Windows Server 2008 and .NET Framework 3.5"

    and I get the SAME ERROR MESSAGE.

    Is Microsoft still alive or coming into work?

    Wednesday, February 04, 2009 5:37 PM
  • I have isolated this to Symantec Endpoint Protection. The SEP is intercepting the .NET framework. The SEP application is NOT reporting any threats.

    As soon as I uninstall (not just disable) SEP, my .NET applications start working again.

    When I reinstall SEP, my .NET applications stop working. Even my "Hello World" test applications fail to run.

    This took three days to isolate.
    Friday, February 06, 2009 2:38 PM
  • I got the same problems , and then I has download the pack name VS90SP1-KB958017-x86.exe but this program install failed.

    I used WinXp SP2, Framework 3.5 SP1, and Visual Studio 2008.

    Please help me fix this problem.

    PS: My projetc has written by WPF and when I pressed F5 to run program the VS 2008 automatic quit.

    Wednesday, March 25, 2009 4:05 PM
  • I have the same problem! When I try to build my projet, VS 2008 quit without error.  In the event viewer I can see (.NET Runtime version 2.0.50727.3053 - Fatal Execution Engine Error (7A2E0F92) (0). All my projects was working well 3 weeks ago.

    For now, all of my projects seem to have this problem.  I was able to bypass it by creating a new project and importing(...Add / Exigting item)  all the forms from the corrupted project to the new project.
    I get this error in Windows and Web project.
    I hope there is a solution for that problem because I don't want to recreate all of my projects!
    Friday, April 17, 2009 4:45 PM
  • This error is killing a application i run and i was wondering if there was a way to find out what causes it. i have tried various .Net hotfixes and still crashed my application after 5 mins.

     

    does anyone have any updated fixes ?

     

    Thursday, August 04, 2011 2:55 PM
  • I don't have any fixes for you, but I do have a suggestion.

    PLEASE start your own thread!!

    You've added your post to a THREE year old thread that nobody reads, so it is highly unlikely that you'll get any help here.

    Start a new thread with all necessary information about YOUR problem. Be sure to include your Windows version and Service Pack level, and which .NET Framework version(s) you have installed.

    Thursday, August 04, 2011 7:52 PM