none
.NET framework updates KB2572073/2633880/2518864 will not install

    Question

  • .NET framework updates KB2572073/2633880/2518864

    after seemingly installing these updates successfully, the update icon reappears to download exactly the same.

    checking the installed updates list, they are not installing at all.

    help please!!

    Tuesday, May 22, 2012 10:31 AM

Answers

  • Appears I may have got one of my systems fixed. (i hope i hope)

    1) Created clone image of drive (cover my bu--).

    2) Tried to "Remove" .net Framework 2.0, it would NOT let me.

    3) Chose the "Change/Remove" option button on .Net Framework 3.5 SP1. One of the options that it came up with was to "Repair" "Return 3.5 to its original state. 

    4) Did a "shutdown", and since it was waiting to do the update AGAIN, I DID NOT choose the "Install updates and shutdown", I chose the "SHUTDOWN".

    5) Brought the system back up, immediately went into "Windows Updates" and checked for updates.  Hot Diggity there are no updates!!

    Now I just need to try that on my second system.

    Tuesday, May 22, 2012 5:14 PM
  •  Thanks CHUKSASI

    I resolved my problem, based on your solution, with a couple of exceptions.

    I did #3: "Chose the "Change/Remove" option button on .Net Framework 3.5 SP1. One of the options that it came up with was to "Repair" "Return 3.5 to its original state."

    Then I accidently chose to "Install updates and shutdown".  As it shut down, it said it was installing 3 updates.  When Windows restarted, they yellow shield was still there, telling me I needed to install those 3 updates.  I clicked on "install".  After I was done, the shield did not pop up again, so I went to Windows Update and after searching, there are no updates, and the shield has not popped up again.

    Wierd solution, but it worked for me.

    Thanks again, CHUKASI

    Avatar of CHUCKASI

    Tuesday, May 22, 2012 10:38 PM

All replies

  • The KB's you cite appear to be for .NET Framework 2.0.

    First, we need to determine the status of your .NET Framework 2.0. To do that, you need to run the .NET Framework Verification Tool, found here:

    http://blogs.msdn.com/b/astebner/archive/2008/10/13/8999004.aspx

    Post the first ~15 lines and last 15 lines of tool output from the tool here.

    Also, what is your Windows version?

    Tuesday, May 22, 2012 1:25 PM
  • Having the same problem myself on multiple computers.

    Have found many suggestions dating back to October 2011.

    I sure hope you have a solution.

    Tuesday, May 22, 2012 2:06 PM
  • Here are the results from MY netframeverify

    I am running Windows XP 32bit SP3

    [<st1:date day="22" month="5" year="2012">05/22/12</st1:date>,<st1:time hour="11" minute="12">11:12:38</st1:time>] Beginning of new SetupVerifier activity logging session

    [<st1:date day="22" month="5" year="2012">05/22/12</st1:date>,<st1:time hour="11" minute="12">11:12:38</st1:time>] Activity log file location: C:\DOCUME~1\CMP\LOCALS~1\Temp\setupverifier_main_05-22-12_11.12.37.txt

    [<st1:date day="22" month="5" year="2012">05/22/12</st1:date>,<st1:time hour="11" minute="12">11:12:38</st1:time>] Error log file location: C:\DOCUME~1\CMP\LOCALS~1\Temp\setupverifier_errors_05-22-12_11.12.37.txt

    [<st1:date day="22" month="5" year="2012">05/22/12</st1:date>,<st1:time hour="11" minute="12">11:12:38</st1:time>] Build created on <st1:date day="29" month="12" year="2011">December 29, 2011</st1:date>

    [<st1:date day="22" month="5" year="2012">05/22/12</st1:date>,<st1:time hour="11" minute="12">11:12:38</st1:time>] Detected operating system: Windows XP (x86)

    [<st1:date day="22" month="5" year="2012">05/22/12</st1:date>,<st1:time hour="11" minute="12">11:12:38</st1:time>] Install state for .<st1:stockticker>NET</st1:stockticker> Framework 1.0: not installed.

    [<st1:date day="22" month="5" year="2012">05/22/12</st1:date>,<st1:time hour="11" minute="12">11:12:38</st1:time>] Install state for .<st1:stockticker>NET</st1:stockticker> Framework 1.1: not installed.

    [<st1:date day="22" month="5" year="2012">05/22/12</st1:date>,<st1:time hour="11" minute="12">11:12:38</st1:time>] Install state for .<st1:stockticker>NET</st1:stockticker> Framework 2.0: installed with service pack 2.

    [<st1:date day="22" month="5" year="2012">05/22/12</st1:date>,<st1:time hour="11" minute="12">11:12:38</st1:time>] Install state for .<st1:stockticker>NET</st1:stockticker> Framework 3.0: installed with service pack 2.

    [<st1:date day="22" month="5" year="2012">05/22/12</st1:date>,<st1:time hour="11" minute="12">11:12:38</st1:time>] Install state for .<st1:stockticker>NET</st1:stockticker> Framework 3.5: installed with service pack 1.

    [<st1:date day="22" month="5" year="2012">05/22/12</st1:date>,<st1:time hour="11" minute="12">11:12:38</st1:time>] Install state for .<st1:stockticker>NET</st1:stockticker> Framework 4 Client: not installed.

    [<st1:date day="22" month="5" year="2012">05/22/12</st1:date>,<st1:time hour="11" minute="12">11:12:38</st1:time>] Install state for .<st1:stockticker>NET</st1:stockticker> Framework 4 Full: not installed.

    [<st1:date day="22" month="5" year="2012">05/22/12</st1:date>,<st1:time hour="11" minute="12">11:12:38</st1:time>] Starting verification for product .<st1:stockticker>NET</st1:stockticker> Framework 2.0

    [<st1:date day="22" month="5" year="2012">05/22/12</st1:date>,<st1:time hour="11" minute="12">11:12:38</st1:time>] Section [Files - .<st1:stockticker>NET</st1:stockticker> Framework 2.0 (Common)] - start parsing entries

    [<st1:date day="22" month="5" year="2012">05/22/12</st1:date>,<st1:time hour="11" minute="12">11:12:38</st1:time>] File C:\WINDOWS\system32\mscoree.dll (version 4.0.31106.0) is installed on the system

    [<st1:date day="22" month="5" year="2012">05/22/12</st1:date>,<st1:time hour="11" minute="12">11:12:45</st1:time>] Key: HKLM\SOFTWARE\Microsoft\.NETFramework

           Value: InstallRoot

           Expected Data:       c:\windows\microsoft.net\framework\

           Actual Data:  c:\windows\microsoft.net\framework\

    [<st1:date day="22" month="5" year="2012">05/22/12</st1:date>,<st1:time hour="11" minute="12">11:12:45</st1:time>] Section [Registry - .<st1:stockticker>NET</st1:stockticker> Framework 2.0 (32-bit)] - stop parsing entries

    [<st1:date day="22" month="5" year="2012">05/22/12</st1:date>,<st1:time hour="11" minute="12">11:12:45</st1:time>] Not running action 'Registry - .<st1:stockticker>NET</st1:stockticker> Framework 2.0 (64-bit)' for product '.<st1:stockticker>NET</st1:stockticker> Framework 2.0' because the OS condition does not match

    [<st1:date day="22" month="5" year="2012">05/22/12</st1:date>,<st1:time hour="11" minute="12">11:12:45</st1:time>] Not running action 'Registry - .<st1:stockticker>NET</st1:stockticker> Framework 2.0 (Wow6432Node)' for product '.<st1:stockticker>NET</st1:stockticker> Framework 2.0' because the OS condition does not match

    [<st1:date day="22" month="5" year="2012">05/22/12</st1:date>,<st1:time hour="11" minute="12">11:12:45</st1:time>] Processing custom action 'Custom Action - .<st1:stockticker>NET</st1:stockticker> Framework 2.0 test application'

    [<st1:date day="22" month="5" year="2012">05/22/12</st1:date>,<st1:time hour="11" minute="12">11:12:45</st1:time>] ExecutablePath = 'Netfx20TestApplication.exe'

    [<st1:date day="22" month="5" year="2012">05/22/12</st1:date>,<st1:time hour="11" minute="12">11:12:45</st1:time>] FriendlyName = '.<st1:stockticker>NET</st1:stockticker> Framework 2.0 test application'

    [<st1:date day="22" month="5" year="2012">05/22/12</st1:date>,<st1:time hour="11" minute="12">11:12:45</st1:time>] TimeoutSeconds = '300'

    [<st1:date day="22" month="5" year="2012">05/22/12</st1:date>,<st1:time hour="11" minute="12">11:12:45</st1:time>] WaitOnExit = 'true'

    [<st1:date day="22" month="5" year="2012">05/22/12</st1:date>,<st1:time hour="11" minute="12">11:12:45</st1:time>] Silent = 'true'

    [<st1:date day="22" month="5" year="2012">05/22/12</st1:date>,<st1:time hour="11" minute="12">11:12:45</st1:time>] Launching process 'Netfx20TestApplication.exe' now

    [<st1:date day="22" month="5" year="2012">05/22/12</st1:date>,<st1:time hour="11" minute="12">11:12:45</st1:time>] Process successfully launched. Waiting 300 seconds for it to complete.

    [<st1:date day="22" month="5" year="2012">05/22/12</st1:date>,<st1:time hour="11" minute="12">11:12:46</st1:time>] Process 'Netfx20TestApplication.exe' exited with return code 0

    [<st1:date day="22" month="5" year="2012">05/22/12</st1:date>,<st1:time hour="11" minute="12">11:12:46</st1:time>] Section [Files - .<st1:stockticker>NET</st1:stockticker> Framework netfxperf.dll] - start parsing entries

    [<st1:date day="22" month="5" year="2012">05/22/12</st1:date>,<st1:time hour="11" minute="12">11:12:46</st1:time>] File C:\WINDOWS\system32\netfxperf.dll (version 4.0.31106.0) is installed on the system

    [<st1:date day="22" month="5" year="2012">05/22/12</st1:date>,<st1:time hour="11" minute="12">11:12:46</st1:time>] Section [Files - .<st1:stockticker>NET</st1:stockticker> Framework netfxperf.dll] - stop parsing entries

    [<st1:date day="22" month="5" year="2012">05/22/12</st1:date>,<st1:time hour="11" minute="12">11:12:46</st1:time>] Verification succeeded for product .<st1:stockticker>NET</st1:stockticker> Framework 2.0

    [<st1:date day="22" month="5" year="2012">05/22/12</st1:date>,<st1:time hour="11" minute="12">11:12:46</st1:time>] SetupVerifier exiting with return value 0

    Tuesday, May 22, 2012 4:25 PM
  • .NET framework updates KB2572073/2633880/2518864

    after seemingly installing these updates successfully, the update icon reappears to download exactly the same.

    checking the installed updates list, they are not installing at all.

    help please!!

    I have the exact problem as desribed above, as of this morning.  I have 2 computers, both running Windows XP  SP 3.  On one, the updates installed just fine. On the other, I had the problem as desribed above.

    Here are the first 15 lines of the output of the verification tool:

    ======================================================================
    [05/22/12,12:40:56] Beginning of new SetupVerifier activity logging session
    [05/22/12,12:40:56] Activity log file location: C:\DOCUME~1\Morey\LOCALS~1\Temp\setupverifier_main_05-22-12_12.40.56.txt
    [05/22/12,12:40:56] Error log file location: C:\DOCUME~1\Morey\LOCALS~1\Temp\setupverifier_errors_05-22-12_12.40.56.txt
    [05/22/12,12:40:56] Build created on December 29, 2011
    [05/22/12,12:40:56] Detected operating system: Windows XP (x86)
    [05/22/12,12:40:56] Install state for .NET Framework 1.0: not installed.
    [05/22/12,12:40:56] Install state for .NET Framework 1.1: installed with service pack 1.
    [05/22/12,12:40:56] Install state for .NET Framework 2.0: installed with service pack 2.
    [05/22/12,12:40:56] Install state for .NET Framework 3.0: installed with service pack 2.
    [05/22/12,12:40:56] Install state for .NET Framework 3.5: installed with service pack 1.
    [05/22/12,12:40:56] Install state for .NET Framework 4 Client: not installed.
    [05/22/12,12:40:56] Install state for .NET Framework 4 Full: not installed.
    [05/22/12,12:40:56] Not adding product '.NET Framework 1.0' because it is not currently installed
    [05/22/12,12:40:56] Not adding product '.NET Framework 1.1' because it is not currently installed
    [05/22/12,12:40:56] Not adding product '.NET Framework 2.0' because it is not currently installed
    [05/22/12,12:40:56] Not adding product '.NET Framework 2.0 SP1' because it is not currently installed

    Here are the last 15 lines form the output  of the verification tool:

    [05/22/12,12:41:20] Key: HKLM\SOFTWARE\Microsoft\NET Framework Setup\NDP\v2.0.50727
     Value: SP
     Expected Data: 2
     Actual Data: 2
    [05/22/12,12:41:20] Section [Registry GE - .NET Framework 2.0 SP2 (Common)] - stop parsing entries
    [05/22/12,12:41:20] Section [Registry GE - .NET Framework 2.0 SP2 (32-bit)] - start parsing entries
    [05/22/12,12:41:20] Section [Registry GE - .NET Framework 2.0 SP2 (32-bit)] - stop parsing entries
    [05/22/12,12:41:20] Not running action 'Registry GE - .NET Framework 2.0 SP2 (64-bit)' for product '.NET Framework 2.0 SP2' because the OS condition does not match
    [05/22/12,12:41:20] Processing custom action 'Custom Action - .NET Framework 2.0 test application'
    [05/22/12,12:41:20] ExecutablePath = 'Netfx20TestApplication.exe'
    [05/22/12,12:41:20] FriendlyName = '.NET Framework 2.0 test application'
    [05/22/12,12:41:20] TimeoutSeconds = '300'
    [05/22/12,12:41:20] WaitOnExit = 'true'
    [05/22/12,12:41:20] Silent = 'true'
    [05/22/12,12:41:20] Launching process 'Netfx20TestApplication.exe' now
    [05/22/12,12:41:20] Process successfully launched. Waiting 300 seconds for it to complete.
    [05/22/12,12:41:20] Process 'Netfx20TestApplication.exe' exited with return code 0
    [05/22/12,12:41:20] Section [Files - .NET Framework netfxperf.dll] - start parsing entries
    [05/22/12,12:41:21] File C:\WINDOWS\system32\netfxperf.dll (version 4.0.31106.0) is installed on the system
    [05/22/12,12:41:21] Section [Files - .NET Framework netfxperf.dll] - stop parsing entries
    [05/22/12,12:41:21] Verification succeeded for product .NET Framework 2.0 SP2

    I would sure appreciate any suggestions you may have.

    Morey Kays

    Tuesday, May 22, 2012 4:49 PM
  • Appears I may have got one of my systems fixed. (i hope i hope)

    1) Created clone image of drive (cover my bu--).

    2) Tried to "Remove" .net Framework 2.0, it would NOT let me.

    3) Chose the "Change/Remove" option button on .Net Framework 3.5 SP1. One of the options that it came up with was to "Repair" "Return 3.5 to its original state. 

    4) Did a "shutdown", and since it was waiting to do the update AGAIN, I DID NOT choose the "Install updates and shutdown", I chose the "SHUTDOWN".

    5) Brought the system back up, immediately went into "Windows Updates" and checked for updates.  Hot Diggity there are no updates!!

    Now I just need to try that on my second system.

    Tuesday, May 22, 2012 5:14 PM
  • Excellent news! Hope the rest goes well for you.
    Tuesday, May 22, 2012 5:37 PM
  • Appears to have worked on my second computer with the problem also.

    • Proposed as answer by makays Tuesday, May 22, 2012 10:30 PM
    • Unproposed as answer by makays Tuesday, May 22, 2012 10:30 PM
    • Proposed as answer by makays Tuesday, May 22, 2012 10:31 PM
    Tuesday, May 22, 2012 6:22 PM
  •  Thanks CHUKSASI

    I resolved my problem, based on your solution, with a couple of exceptions.

    I did #3: "Chose the "Change/Remove" option button on .Net Framework 3.5 SP1. One of the options that it came up with was to "Repair" "Return 3.5 to its original state."

    Then I accidently chose to "Install updates and shutdown".  As it shut down, it said it was installing 3 updates.  When Windows restarted, they yellow shield was still there, telling me I needed to install those 3 updates.  I clicked on "install".  After I was done, the shield did not pop up again, so I went to Windows Update and after searching, there are no updates, and the shield has not popped up again.

    Wierd solution, but it worked for me.

    Thanks again, CHUKASI

    Avatar of CHUCKASI

    Tuesday, May 22, 2012 10:38 PM