none
.net framework 3.5, where's the dll's?

    Question

  • I am using windows 7, I see a few listed in here but not much. E:\Windows\Microsoft.NET\Framework\v3.5\

    I thought perhaps maybe they would be included with the sdk? So I try and install everything from windows sdk for windows 7 and .net framework 3.5 service pack 1. I look in here and sub folders and don't see many dll's either. 

    E:\Program Files\Microsoft SDKs\Windows\v7.0

    Monday, March 05, 2012 11:30 AM

Answers

All replies

  • Is there some reason you are looking for individual DLL's in an embedded framework? Can you provide the name(s) of the DLL(s) you are looking for?

    If you suspect that the .NET Framework 3.5 installed as part of Windows 7 is not working correctly, please use this tool to verify the framework:

    http://blogs.msdn.com/b/astebner/archive/2008/10/13/8999004.aspx 

    Post the first 15 and last 15 lines of tool output here.

    Have you activated all the .NET Framework 3.5.1 subfeatures? Control Panel->Programs and Features->Turn Windows Features on and off...

    Locate "Microsoft .NET Framework 3.5.1" in the Windows Features list, expand the node and check all subfeatures.

    If you discover verification issues, this is the technique for repairing embedded frameworks:

    http://blogs.msdn.com/b/astebner/archive/2007/03/26/how-to-repair-the-net-framework-2-0-and-3-0-on-windows-vista.aspx

    Monday, March 05, 2012 4:06 PM
  • 1. The program I'm using uses the .net framework dll's to build applications.


    2. Not sure if it's installed rite or not, I just think I'm missing the dll files and not sure what to do to get them.


    3. Yes, the 3.5 option in windows features and the sub folders under it are all checked.


    [03/05/12,12:10:47] Beginning of new SetupVerifier activity logging session
    [03/05/12,12:10:47] Activity log file location: E:\Users\stephy\AppData\Local\Temp\setupverifier_main_03-05-12_12.10.47.txt
    [03/05/12,12:10:47] Error log file location: E:\Users\stephy\AppData\Local\Temp\setupverifier_errors_03-05-12_12.10.47.txt
    [03/05/12,12:10:47] Build created on December 29, 2011
    [03/05/12,12:10:47] Detected operating system: Windows 7 (x86)
    [03/05/12,12:10:47] Install state for .NET Framework 1.0: not installed.
    [03/05/12,12:10:47] Install state for .NET Framework 1.1: installed with no service packs.
    [03/05/12,12:10:47] Install state for .NET Framework 2.0: installed with service pack 2.
    [03/05/12,12:10:47] Install state for .NET Framework 3.0: installed with service pack 2.
    [03/05/12,12:10:47] Install state for .NET Framework 3.5: installed with service pack 1.
    [03/05/12,12:10:47] Install state for .NET Framework 4 Client: installed with no service packs.
    [03/05/12,12:10:47] Install state for .NET Framework 4 Full: not installed.
    [03/05/12,12:10:47] Not adding product '.NET Framework 1.0' because it is not currently installed
    [03/05/12,12:10:47] Not adding product '.NET Framework 1.1 SP1' because it is not currently installed
    [03/05/12,12:10:47] Not adding product '.NET Framework 2.0' because it is not currently installed
    [03/05/12,12:10:47] Not adding product '.NET Framework 2.0 SP1' because it is not currently installed
    [03/05/12,12:10:47] Not adding product '.NET Framework 3.0' because it is not currently installed
    [03/05/12,12:10:47] Not adding product '.NET Framework 3.0 SP1' because it is not currently installed
    [03/05/12,12:10:47] Not adding product '.NET Framework 3.5' because it is not currently installed
    [03/05/12,12:10:47] Not adding product '.NET Framework 4 Full' because it is not currently installed




















    [03/05/12,12:11:03] Section [Files - .NET Framework 3.0 SP1AndLater (Common)] - start parsing entries
    [03/05/12,12:11:03] File E:\Program Files\Reference Assemblies\Microsoft\Framework\v3.0\RedistList\FrameworkList.xml (no version info) is installed on the system
    [03/05/12,12:11:03] Section [Files - .NET Framework 3.0 SP1AndLater (Common)] - stop parsing entries
    [03/05/12,12:11:03] Processing custom action 'Custom Action - .NET Framework 2.0 test application'
    [03/05/12,12:11:03] ExecutablePath = 'Netfx20TestApplication.exe'
    [03/05/12,12:11:03] FriendlyName = '.NET Framework 2.0 test application'
    [03/05/12,12:11:03] TimeoutSeconds = '300'
    [03/05/12,12:11:03] Silent = 'true'
    [03/05/12,12:11:03] Launching process 'Netfx20TestApplication.exe' now
    [03/05/12,12:11:03] Process successfully launched. Waiting 300 seconds for it to complete.
    [03/05/12,12:11:04] Process 'Netfx20TestApplication.exe' exited with return code 0
    [03/05/12,12:11:04] Section [Files - .NET Framework netfxperf.dll] - start parsing entries
    [03/05/12,12:11:04] File E:\Windows\system32\netfxperf.dll (version 4.0.31106.0) is installed on the system
    [03/05/12,12:11:04] Section [Files - .NET Framework netfxperf.dll] - stop parsing entries
    [03/05/12,12:11:04] Verification succeeded for product .NET Framework 3.5 SP1

    Monday, March 05, 2012 8:27 PM
  • Your .NET Framework 3.5 SP1 is correctly installed and verified.

    What is the program that "uses the .net framework dll's to build applications" and is it certified by the publisher to be Windows 7 compatible?

    Monday, March 05, 2012 10:34 PM
  • limnor.com  is the program, codeless/visual programming

    E:\Windows\Microsoft.NET\Framework\v3.5

    I only see 4 dll files, shouldn't there be like 100 more/less?

    Don't see anything of them in the sub folders here either.

    E:\Program Files\Microsoft SDKs\Windows\v7.0

    Yes, I'm a newbie. I didn't think getting this stuff would be this hard lol..

    Monday, March 05, 2012 10:51 PM
  • I suggest you contact the publishers of the software at "limnor.com" if you are having issues using it in Windows 7.

    As your embedded .NET Framework 3.5, in Windows 7, is installed and verifies correctly, I don't think you have a .NET Framework issue.

    It appears that Limnor has a forum, here:

    http://www.limnor.com/ 

    Click Support->Forum

    Tuesday, March 06, 2012 4:00 PM
  • Hi stephanie0001,

    Welcome to the MSDN forum.

    I agree with pvdg42. You have successfully installed .NET Framework 3.5 so your question now turns to be "How to find the specific DLL when programming". So please ask your question to that specific forum.

    Best regards,


    Barry Wang [MSFT]
    MSDN Community Support | Feedback to us

    Wednesday, March 07, 2012 2:42 AM
  • I would have thought they would have come included with the framework or the windows sdk for program developers..
    Wednesday, March 07, 2012 5:46 AM
  • Hello, stephanie0001.

    Did you contact the Limnor technical support people to ask about your issue and Windows 7 compatibility?

    It appears from entries on the LImnor web site that their product has not been updated beyond a beta release for .NET Framework 3.5 a couple of years ago.

    As Windows 7 is the first Windows version to include .NET Framework 3.0 as an embedded OS part, it may be that the Limnor tool is not compatible.

    Wednesday, March 07, 2012 3:30 PM