none
Getting RID of Just-In-Time debugger

    Question

  • Hello all.

    I installed Visual Studio, and had no problems.  Except one.  The Just-In-Time debugger.  It seems to come up all the time now, and it has broken Winamp AND Cakewalk SONAR 5.  I tried disabling it in Visual Studio's options, but that doesn't stop the pop up and the subsequent shut down of the program (which did NOT happen before).  Any ideas?
    Thursday, January 26, 2006 4:28 AM

Answers

  • Although anything is possible I suppose, it seems unlikely that installing the Just-In-Time debugger caused these applications to start crashing. But I guess if you really want to know if that is the problem, you can try removing HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\AeDebug\Debugger.

    If it was me, I would take a look at where the app was crashing, and send a bug report to the product support team that own's your crashing app.

    Friday, January 27, 2006 3:02 PM
    Moderator

All replies

  • Although anything is possible I suppose, it seems unlikely that installing the Just-In-Time debugger caused these applications to start crashing. But I guess if you really want to know if that is the problem, you can try removing HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\AeDebug\Debugger.

    If it was me, I would take a look at where the app was crashing, and send a bug report to the product support team that own's your crashing app.

    Friday, January 27, 2006 3:02 PM
    Moderator
  • Solution

    Open Start>Control Panels>Internet Options: Advanced and activate (check box)

    * Disable Script Debugging (Internet Explorer)
    * Disable Script Debuggung (Other)
    Friday, February 10, 2006 3:31 PM
  • how do i get rid of just in time debugger
    Monday, February 20, 2006 4:31 PM
  • Hi,

    Try to set this key value to 1.

    HKEY_CURRENT_USER\Software\Microsoft\Windows Script\Settings\JITDebug

    Eitan.

    Tuesday, February 21, 2006 7:51 PM
  • I know this is my first post, but i want to apologize for bumping an old topic.

    But i wanted to state that what she says does the trick.

    Thank you very much Smile
    Saturday, March 31, 2007 9:27 AM
  • how do i remove that...where do i go to?
    Monday, April 09, 2007 11:54 PM
  • Hi,

    Open the registry (use regedit, Click Start, Run, Regedit).

    Go to this key:

    HKEY_CURRENT_USER\Software\Microsoft\Windows Script\Settings\JITDebug

    And set it to 0.

    Eitan

    • Proposed as answer by CondoomDokter Monday, October 17, 2011 5:18 PM
    Thursday, April 12, 2007 6:46 PM
  • I have tried every registry entry, disabled every script box in IE, and nothing works.  the only thing I can do to get rid of it is uninstall the ie developer's toolbar, but I really wanted to keep the dom explorer, as I am validating and correcting all the code in a rather large website.
    Friday, April 13, 2007 10:05 PM
  • Thank you Bill gates, I download Visual studio, and after using it a few times 8 of my programmes won't run because of your piece of ***. The simple answer would of course be to uninstall it, so why is it a piece of ***?
    I'll enlighten you, I have uninstalled it. As I am typing this, I am finding components from your  *** still on my computer, still crashing various applications.

    I have done the HKey value thingys, googled for answers and I keep getting the same reply from microsoft, it's unlikely this is to do with visual studio. Here';s a small pointer, unlikely my foot. Why is it the errors only happened AFTER I installed your programme?

    I am sick of Microsoft and Bill gates, he was on an interview recently, where he was showing off his latest media center programme. Guess what people, surprise surprise, it wouldn't work.


    And before you suggest Vista I am a gamer, so it's no games or games and errors. Great option that!

    Since I bought my computer, I have had nothing but errors with it. Why is it I get similar errors to my mum's windows 95? If you can't advance a PC in over ten years, you're either doing something wrong, or not doing it at all.


    So now we've established it is your software screwing my programmes up, and we've established I can't uninstall, even manually or from the control panel, I would like an answer that works and doesn't have a disclaimer saying, this will probably screw your comp up, it's already screwed thanks to microsoft.


    Seems to me that everyone involved with Msoft is thick. I can't make a system, but given the money Gates has, I could make a much better system than your ***. Why would it be better?
    Here's the main answer;
    IT WOULD WORK.

    So thank you for taking my money microsoft, thank you for not helping me thus far, and thank you for basically screwing up my computer with your own programmes. I wonder when we can expect an apology for the apes working on your systems?

    *silent laughter.*
    I didn't think so somehow.
    Sorry, I take the last bit back, I don't want to insult any apes that may be reading this.
    Tuesday, October 02, 2007 10:39 PM
  • I just went through the exact same thing, so don't listen to the reply post by the "Visual Studio Debugger Dev".

     

    I followed a solution a few posts down and it worked perfectly.

     

    Solution

    Open Start>Control Panels>Internet Options: Advanced and activate (check box)

    * Disable Script Debugging (Internet Explorer)
    * Disable Script Debuggung (Other)

     

    BTW - when a user disables a program from Windows, a portion of that program should no longer exist (as JIT does). It's ridiculous we have to deal with this at all. Hope this helped.
    Friday, October 05, 2007 5:09 AM
  • Already tried it mate, didn't work.

    Thanks for trying.

    I saw this book once, it's a series, internet for dummies, photoshop for dummies, and then I saw microsoft for dummies. It's more a case of microsoft BY dummies, not for them.
    Saturday, October 06, 2007 4:51 PM
  • I'm pretty sure the the JITDebugger only pops up when an app crashes.

     

    Did your apps crash a lot before?
    • Proposed as answer by seeking Wednesday, October 21, 2009 3:08 PM
    Sunday, October 07, 2007 4:22 AM
  • I am having the exact same problem. I removed the visual studio, but still getting errors from JITdebugger.

    Some people suggest to change something in internet explorer, but the problem doesn't occur in internet explorer (maybe it does, but i am not using it) so this solution doesn't work for me.
    Wednesday, October 31, 2007 10:51 AM
  • I found this actually resolved my issue with JIT:

     

    1. Click Start

    2. Click Run

    3. Type cmd (and click ok)

    4. Type drwtsn32 -i (and press enter)

     

     

    See the following for further details on the actual issue with JIT:

     

    http://support.microsoft.com/default.aspx/kb/923827

     

    • Proposed as answer by dips87 Friday, September 04, 2009 1:55 PM
    Monday, March 03, 2008 10:47 PM
  • I tried a bunch of stuff too - registry settings, IE settings - but no dice. I had to uninstall the ie developer's toolbar as well to finally rid myself of the JIT debugger. What a PITA.
    Friday, March 07, 2008 3:27 PM
  •  

    Its simple

    dont do anything with Registry

    simply follow the steps

     

    1. Open IIS Server (Internet Information Server)

    2. Open website Node and select the site in which you're getting error of Debugger of Just In time

    3. Go on Tab of Home Directory

    4. Click on Configuration button  (You will get another form)

    5. Click on Dubugging Tab.

    6. Uncheck "Enabled ASP Server-side scripting degug.

     

    I have remove the this way, try it

     

    Thanks

    Hetal Patel

    Saturday, March 08, 2008 5:54 PM
  • This did the trick for me

    Wednesday, March 26, 2008 3:10 PM
  • That got rid of the JIT debugger and put dr watson back in control, now all the suddon my apps don't crash anymore hmmmmmmmm.  Could it be that JIT was causing the crashes.  YES!!!!!!!!

     

     

     

    Tuesday, May 06, 2008 7:36 PM
  • How do you open the IIS server?  (I am not a programmer but I am having problems with JIT Debugger errors).
    Monday, July 14, 2008 1:19 AM
  • i have a solution that worked for me

    open the registry editor, and navigate to this folder:

    HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\AEDebug

    then delete the entire folder

    however this won't neccessarily (and probably definately) re-enable third party applications, but it will stop JITDebugging from running.

    I Live Life One Video Game At A Time. Play It Like You Mean It.
    Sunday, July 20, 2008 11:35 AM
  • Can I turned on the debugger again after setting the JITDebug to 0 ?
    Sunday, August 24, 2008 4:40 PM
  • My problems started when I downloaded MS SilverLight.  Now when I try to update my Zune software, it tells me that Windows Installer isn't working.  When I try to re-download Windows Installer, I keep getting the JIT Debugger error message.  I tried un-installing SliverLight, but the problem persists.

    So, to suffice, the only three programs that are affected are ALL Microsoft programs that will NOT work together.

    Great planning strategy, Bill
    Tuesday, September 30, 2008 11:32 PM
  • Changing the settings in IIS is a good approach - but if you are like me and you run a web app within IIS, you might want script debugging turned on (so the browser will display the error message) but you DON'T want the JIT Debugger to run (because this makes everything else stop - including IIS).

    So here is what I did - (after trying numerous other solutions, including editing the registry)

    I found these instruction on another site (but they did not work for me so I came up with my own solution, below):

    *** what I found elsewhere -
    You should be able to disable the JIT Debugger in Internet Explorer, via:
    Windows Control Panel > Internet Options > Advanced tab:

    Checkmark both "disable script debugging (IE/other)" options
    Uncheck "display a notification about every script error"

    Or go to: Control Panel > Admin Tools > Services
    and disable Visual Studio JIT Debugger, if listed.

    Look for a service that points to one of the following executables:

    C:\WINDOWS\system32\vsjitdebugger.exe
    C:\Program Files\Common Files\Microsoft Shared\VS7Debug\vs7jit.exe


    ********* THIS IS WHAT WORKED FOR ME:
    I went here C:\WINDOWS\system32\vsjitdebugger.exe and renamed vsjitdebugger.exe to vsjitdebuggerBACK.exe (*this worked for me)
    ...but just in case...
    Then I went here C:\Program Files\Common Files\Microsoft Shared\VS7Debug and I also renamed the folder VS7Debug (actually VS7DEBUG) to VSDebugback (VS7DEBUGback)

    And just as an FYI - it seems that this probelm occured for me because after uninstalling Visual Studio 2005 I did not uninstall SQL Server 2005.  see this article - http://support.microsoft.com/default.aspx/kb/923827

    • Proposed as answer by ron_99 Thursday, October 30, 2008 8:17 PM
    • Edited by ron_99 Thursday, October 30, 2008 8:18 PM
    Thursday, October 30, 2008 8:15 PM
  • What if you don't have IIS installed?  Also, is there a way to get rid of the just in time debugger programatically?  I'm running a bunch of tests and when one fails it throws the debugger which pauses the run and my other tests don't execute!  Very annoying!
    Tuesday, March 10, 2009 11:27 PM
  • My problem is that a lot of time I get this error with other applications. It happens a lot with Mcafee and other Win32 apps. Trying to set the ie setting does not seem to help. Now I am having one with filezilla.exe for ftp. It does not happen when I am doing development. The problem almost made PC unusable. 
    Monday, March 30, 2009 1:19 AM
  • actually its happening to me with winamp, photoshop Elements 6, safari, and IE
    Sunday, September 06, 2009 4:57 PM
  • I got it resloved by making JITDebug, 0 under HKEY_CURRENT_USER\Software\Microsoft\Windows Script\Settings

    • Proposed as answer by Pradeep Nulu Friday, November 02, 2012 9:35 AM
    Thursday, September 24, 2009 1:56 PM
  • I am so pissed right now. My computer is having the same issue here.  when the debugger starts popping up, my ixplore no longer run. slows down my whole computer, programes etc. It won't let me get rid of visual studio. I tried remove software but it's missing components so I can't delete it out of my computer. What should I do? I just slows everything and I can't even work on it. Someone please tell me what to do?
    Friday, September 25, 2009 6:58 PM
  • I would think that's the case...but I am sure my boyfriend's computer was crashed by this aswell. He's the one who uses visual basic..and he's computer kept crashing down...boot it up...then dies down...it was a virus that he caught...I believe visual basic made it vulnerable for viruses or something. 

    My computer had not had a problem for 5 years...when his computer crash a month ago, he installed visual on mine labtop. and now my labtop is not working property. I can not log on internet period. The just in time debugger keeps popping up in the middle of my work and killing my programe.

    I not a genius in computer, but I know Visual basic needs to fix this problem. It's so shittie!
    Friday, September 25, 2009 7:03 PM
  • I got it resloved by making JITDebug, 0 under HKEY_CURRENT_USER\Software\Microsoft\Windows Script\Settings


    can you put in more details...

    my problem is I can't get anywher.e.that ____ just keeps popping up. seems like it's in internet explorer. I can not go to that problem period. anything involve the net.
    Friday, September 25, 2009 7:10 PM
  • Thanks for the info - hope it works - so far so good...!
    Sue
    • Proposed as answer by seeking Wednesday, October 21, 2009 3:06 PM
    Wednesday, September 30, 2009 8:54 PM
  • I've seen a lot of suggestions in this thread, but there is a setting in Visual Studio that turns this on and off. See http://msdn.microsoft.com/en-us/library/k8kf6y2a.aspx "How to: Enable/Disable Just-In-Time Debugging".
    • Proposed as answer by seeking Wednesday, October 21, 2009 3:06 PM
    Monday, October 19, 2009 4:32 PM
  • I had Microsoft Expression installed which included Visual Studio and Silverlight. I use Windows XP. Expression continued to crash my computer and after a few weeks of technical support not being able to solve the problem for me, they let me return the software. However, I am still getting this error:
    An unhandled win32 exception occurred in svchost.exe [1480]. Just in time debugging this exeption failed with the following error: No installed debugger has Just in Time Debugging enabled. In Visual Studio Just in Time Debugging can be enabled from Tools/options/Debugging/Just in Time

    Well I don't have Visual Studio anymore, that was uninstalled. Clean.

    I do have a key in the registry where it was referred to above and it is currently set to zero. Is this the problem?

    Help me fix this because my computer crashes when I play computer games, when I use Photoshop, when I use Nero Photo Viewer, etc. etc. and I'm really really sick of this.

    Thanks!
    Friday, November 20, 2009 9:58 PM
  • I'm not sure if this is the right place to ask this question, but I'm having issues, so here goes.

    My problem started when I tried to sign in to Windows Live Messenger, it wouldn't work.  In my search to fix that, I realized that Internet Explorer would not work either, it kept displaying the error message, "Unable to show the webpage."  Then randomly, my Mozilla Firefox started to crash.  I thought all of this was due to a virus.  Next I was unable to sign into Yahoo Messenger.  Then I started getting the Just-In-Time Debugger error.  It asked me if I wanted to use Microsoft Script Editor to fix the problem.  I clicked yes and it seemed to be working well, until I received a new error, "Unable to open registry key 'HKEY_LOCAL_MACHINE\SOFTWARE\DELL\HWDiag\PCDpath' for reading."  I am now at a loss as to how to fix things.  Mozilla continues to crash (it crashed once as I tried to sign in to type this out) and nothing internet related seems to work very well.  Can anyone help me?  Please?! 
    Wednesday, December 02, 2009 10:53 PM
  • Ok people here let me clear some things up for you.  The default setting for JIT debugger in VS 2008 is set to "on" for managed and native.  This is why when ever you have a program that ends unexpectedly or freezes up ( as the all tend to do at some point) JIT debugger pops up. Once it starts running it can in fact break your programs.  Open up your Visual Studio program click tools/options/debugger and then JIT debugger.  Uncheck all the boxes and now it is off.  If you have uninstalled VS2008 and you are still finding peices of it in your registry then Download CCleaner .  This program is highly respected and will find all registry enteries from old deleted and uninstalled programs and make them go away. Almost every single program I have ever uninstalled leaves behind some unused regestry entry or .dll file in the system. I use it at work all the time.
    Friday, December 04, 2009 3:56 AM
  • Now I cannot even get windows update to work without that just in time debugger error coming up. !!!! That never happened before. I have tried setting the value to 1 as suggested above. That did not work. It already was set to zero. I uninstalled Visual Studio a long time ago with help from a microsoft tech. I did not know I'd have the just in time issue because it didn't happen again for a while and now I'd have to pay hundreds of dollars for help.

    This is just getting to be impossible!!!

    Please help, someone? Anyone???

    Sunday, December 13, 2009 2:39 PM
  • This happened to me too I then strted getting BSOD then installed windows7 maybe you can reinstall OS
    Sunday, December 13, 2009 5:17 PM
  • i have had simillar problums with debug but not with the debug with the actually program and debug has not interefeared with any of my programs yet considering i only had the program now for about 2 hours i was able to copy this repeated error to clip board i hope it helps the development team

    System.InvalidOperationException was unhandled
      Message=Collection was modified; enumeration operation may not execute.
      Source=mscorlib
      StackTrace:
           at System.ThrowHelper.ThrowInvalidOperationException(ExceptionResource resource)
           at System.Collections.Generic.List`1.Enumerator.MoveNextRare()
           at System.Collections.Generic.List`1.Enumerator.MoveNext()
           at Microsoft.VisualBasic.PowerPacks.ShapeCollection.Dispose(Boolean disposing)
           at Microsoft.VisualBasic.PowerPacks.ShapeContainer.Dispose(Boolean disposing)
           at System.ComponentModel.Component.Dispose()
           at System.Windows.Forms.Control.Dispose(Boolean disposing)
           at System.Windows.Forms.Form.Dispose(Boolean disposing)
           at WindowsApplication1.Form1.Dispose(Boolean disposing) in C:\Documents and Settings\Brian\My Documents\Visual Studio 2010\Projects\WindowsApplication1\WindowsApplication1\Form1.Designer.vb:line 13
           at System.ComponentModel.Component.Dispose()
           at System.Windows.Forms.Form.WmClose(Message& m)
           at System.Windows.Forms.Form.WndProc(Message& m)
           at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
           at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
           at System.Windows.Forms.NativeWindow.DebuggableCallback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)
           at System.Windows.Forms.UnsafeNativeMethods.CallWindowProc(IntPtr wndProc, IntPtr hWnd, Int32 msg, IntPtr wParam, IntPtr lParam)
           at System.Windows.Forms.NativeWindow.DefWndProc(Message& m)
           at System.Windows.Forms.Form.DefWndProc(Message& m)
           at System.Windows.Forms.Control.WndProc(Message& m)
           at System.Windows.Forms.ScrollableControl.WndProc(Message& m)
           at System.Windows.Forms.ContainerControl.WndProc(Message& m)
           at System.Windows.Forms.Form.WmSysCommand(Message& m)
           at System.Windows.Forms.Form.WndProc(Message& m)
           at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
           at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
           at System.Windows.Forms.NativeWindow.DebuggableCallback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)
           at System.Windows.Forms.UnsafeNativeMethods.CallWindowProc(IntPtr wndProc, IntPtr hWnd, Int32 msg, IntPtr wParam, IntPtr lParam)
           at System.Windows.Forms.NativeWindow.DefWndProc(Message& m)
           at System.Windows.Forms.Form.DefWndProc(Message& m)
           at System.Windows.Forms.Control.WndProc(Message& m)
           at System.Windows.Forms.ScrollableControl.WndProc(Message& m)
           at System.Windows.Forms.ContainerControl.WndProc(Message& m)
           at System.Windows.Forms.Form.WmNcButtonDown(Message& m)
           at System.Windows.Forms.Form.WndProc(Message& m)
           at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
           at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
           at System.Windows.Forms.NativeWindow.DebuggableCallback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)
           at System.Windows.Forms.UnsafeNativeMethods.DispatchMessageW(MSG& msg)
           at System.Windows.Forms.Application.ComponentManager.System.Windows.Forms.UnsafeNativeMethods.IMsoComponentManager.FPushMessageLoop(IntPtr dwComponentID, Int32 reason, Int32 pvLoopData)
           at System.Windows.Forms.Application.ThreadContext.RunMessageLoopInner(Int32 reason, ApplicationContext context)
           at System.Windows.Forms.Application.ThreadContext.RunMessageLoop(Int32 reason, ApplicationContext context)
           at System.Windows.Forms.Application.Run(ApplicationContext context)
           at Microsoft.VisualBasic.ApplicationServices.WindowsFormsApplicationBase.OnRun()
           at Microsoft.VisualBasic.ApplicationServices.WindowsFormsApplicationBase.DoApplicationModel()
           at Microsoft.VisualBasic.ApplicationServices.WindowsFormsApplicationBase.Run(String[] commandLine)
           at WindowsApplication1.My.MyApplication.Main(String[] Args) in 17d14f5c-a337-4978-8281-53493378c1071.vb:line 81
           at System.AppDomain._nExecuteAssembly(RuntimeAssembly assembly, String[] args)
           at System.AppDomain.ExecuteAssembly(String assemblyFile, Evidence assemblySecurity, String[] args)
           at Microsoft.VisualStudio.HostingProcess.HostProc.RunUsersAssembly()
           at System.Threading.ThreadHelper.ThreadStart_Context(Object state)
           at System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state, Boolean ignoreSyncCtx)
           at System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state)
           at System.Threading.ThreadHelper.ThreadStart()
      InnerException:
    Monday, December 14, 2009 9:30 AM
  • i have had simillar problums with debug but not with the debug with the actually program and debug has not interefeared with any of my programs yet considering i only had the program now for about 2 hours i was able to copy this repeated error to clip board i hope it helps the development team

    System.InvalidOperationException was unhandled
      Message=Collection was modified; enumeration operation may not execute.
      Source=mscorlib
      StackTrace:
           at System.ThrowHelper.ThrowInvalidOperationException(ExceptionResource resource)
           at System.Collections.Generic.List`1.Enumerator.MoveNextRare()
           at System.Collections.Generic.List`1.Enumerator.MoveNext()
           at Microsoft.VisualBasic.PowerPacks.ShapeCollection.Dispose(Boolean disposing)
           at Microsoft.VisualBasic.PowerPacks.ShapeContainer.Dispose(Boolean disposing)
           at System.ComponentModel.Component.Dispose()
           at System.Windows.Forms.Control.Dispose(Boolean disposing)
           at System.Windows.Forms.Form.Dispose(Boolean disposing)
           at WindowsApplication1.Form1.Dispose(Boolean disposing) in C:\Documents and Settings\Brian\My Documents\Visual Studio 2010\Projects\WindowsApplication1\WindowsApplication1\Form1.Designer.vb:line 13
           at System.ComponentModel.Component.Dispose()
           at System.Windows.Forms.Form.WmClose(Message& m)
           at System.Windows.Forms.Form.WndProc(Message& m)
           at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
           at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
           at System.Windows.Forms.NativeWindow.DebuggableCallback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)
           at System.Windows.Forms.UnsafeNativeMethods.CallWindowProc(IntPtr wndProc, IntPtr hWnd, Int32 msg, IntPtr wParam, IntPtr lParam)
           at System.Windows.Forms.NativeWindow.DefWndProc(Message& m)
           at System.Windows.Forms.Form.DefWndProc(Message& m)
           at System.Windows.Forms.Control.WndProc(Message& m)
           at System.Windows.Forms.ScrollableControl.WndProc(Message& m)
           at System.Windows.Forms.ContainerControl.WndProc(Message& m)
           at System.Windows.Forms.Form.WmSysCommand(Message& m)
           at System.Windows.Forms.Form.WndProc(Message& m)
           at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
           at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
           at System.Windows.Forms.NativeWindow.DebuggableCallback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)
           at System.Windows.Forms.UnsafeNativeMethods.CallWindowProc(IntPtr wndProc, IntPtr hWnd, Int32 msg, IntPtr wParam, IntPtr lParam)
           at System.Windows.Forms.NativeWindow.DefWndProc(Message& m)
           at System.Windows.Forms.Form.DefWndProc(Message& m)
           at System.Windows.Forms.Control.WndProc(Message& m)
           at System.Windows.Forms.ScrollableControl.WndProc(Message& m)
           at System.Windows.Forms.ContainerControl.WndProc(Message& m)
           at System.Windows.Forms.Form.WmNcButtonDown(Message& m)
           at System.Windows.Forms.Form.WndProc(Message& m)
           at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
           at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
           at System.Windows.Forms.NativeWindow.DebuggableCallback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)
           at System.Windows.Forms.UnsafeNativeMethods.DispatchMessageW(MSG& msg)
           at System.Windows.Forms.Application.ComponentManager.System.Windows.Forms.UnsafeNativeMethods.IMsoComponentManager.FPushMessageLoop(IntPtr dwComponentID, Int32 reason, Int32 pvLoopData)
           at System.Windows.Forms.Application.ThreadContext.RunMessageLoopInner(Int32 reason, ApplicationContext context)
           at System.Windows.Forms.Application.ThreadContext.RunMessageLoop(Int32 reason, ApplicationContext context)
           at System.Windows.Forms.Application.Run(ApplicationContext context)
           at Microsoft.VisualBasic.ApplicationServices.WindowsFormsApplicationBase.OnRun()
           at Microsoft.VisualBasic.ApplicationServices.WindowsFormsApplicationBase.DoApplicationModel()
           at Microsoft.VisualBasic.ApplicationServices.WindowsFormsApplicationBase.Run(String[] commandLine)
           at WindowsApplication1.My.MyApplication.Main(String[] Args) in 17d14f5c-a337-4978-8281-53493378c1071.vb:line 81
           at System.AppDomain._nExecuteAssembly(RuntimeAssembly assembly, String[] args)
           at System.AppDomain.ExecuteAssembly(String assemblyFile, Evidence assemblySecurity, String[] args)
           at Microsoft.VisualStudio.HostingProcess.HostProc.RunUsersAssembly()
           at System.Threading.ThreadHelper.ThreadStart_Context(Object state)
           at System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state, Boolean ignoreSyncCtx)
           at System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state)
           at System.Threading.ThreadHelper.ThreadStart()
      InnerException:

    Never mind dont ues the power pack

    apparently the

    LINE and SHAPE

    OBJECTS

    are crawlling with bugs still
    dont use or incounter this reocurring error
    User beware
    Monday, December 14, 2009 9:41 AM
  • I don't know how to remove HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\AeDebug\Debugger   I did a search and it said not a file or folder and since it isn't a program I dont' know how to find this to delete.

    Please let me know. thanks
    Thursday, January 07, 2010 3:03 PM
  • You go to Start, Run, type in regedit in the box and click ok.  Then you will be in the registry and can find that path, HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\AeDebug\Debugger
    Monday, January 11, 2010 9:46 PM
  • Thank you!  Obviously I am a layman:)  I will let you know how it works for me:)
    Tuesday, January 12, 2010 4:12 PM
  • Tried that and no change. What should I try next? Could this be a trojan or malware? I've got IE8 installed, not 7. Suggestions?
    Saturday, January 23, 2010 1:05 PM
  • hey idk for sure but have you guy just try removeing the JIT debug program?
    Sunday, January 24, 2010 12:23 PM
  • hey you can click on tools and then internet options and then you click advanced and find there to click in the box disable script deburging[interner explorer] and disable script deburging [others].   hope you get rid of just-in-time debuging.
    Thamks & Rgards,
    Sam 
    Monday, January 25, 2010 9:13 PM
  • hey you can click on tools and then internet options and then you click advanced and find there to click in the box disable script deburging[interner explorer] and disable script deburging [others].   hope you get rid of just-in-time debuging.
    Thamks & Rgards,
    Sam 
    Monday, January 25, 2010 9:15 PM
  • i just happened onto this page, and the futility of it all. i've googled my rear end off, and nothing suggested by any of these msdn post have helped.  it would be nice to try all of these suggestions but none of them work, and you all know that. there is nothing you can do , no codes, no start run, tools, nothing.... and i think i'm pretty smart, not even dep, but the clean install..so why don't some of you brainiacs fess up and  tell the masses there's nothing to fear but the just in time debugger, so reinstall your os now, completely give yourself over to the power of being made over, again, and again, and again........i didn't know that you could install software straight from microsoft, license key and all and screw up your machine so bad...i can't repeat what i'm thinking here, that it even changes settings in your media player. even o positiive blood is a universal donor, but i am finding that this is not the case with microsoft.so just before the 24 hour window expires for me, i'll take any suggestions. clean installs are painless if you meticulously back up everything ....anyone????
    Saturday, February 06, 2010 2:15 AM
  • I tried prety much everything mentioned in this thread and nothing helped to. Including deleting vsjitdebugger.exe, deleting registry keys etc. I'm asking myself - how is it even possible that even if I delete program that is suppose make this error messages it doesn't even change the error message! Its still absolutely the same! My error message looks like this: Is it the error message generated by visual studio or is it suppose to look diferent? I'm using Windows Vista Home Premium (32bit). Also I did have Visual studio installed, but along with trying to get rid of this error I uninstalled it (I also cleaned my registry be Ccleaner as suggested here earlier).
    Thursday, February 11, 2010 4:10 PM
  • I know this probably sounds stupid to you computer whizes, but how do you Open IIS Server?  I too have tried just about everything else, but no luck - thanks
    Thursday, April 29, 2010 3:50 AM
  • I have a related problem that perhaps someone here could shed some light on.  Can anyone explain why Just-In-Time Debugger continues to randomly pop up after having a virus?  I do not have, and have never had Visual Studio installed.....
    Friday, April 30, 2010 4:33 AM
  • I have a related problem that perhaps someone here could shed some light on.  Can anyone explain why Just-In-Time Debugger continues to randomly pop up after having a virus?  I do not have, and have never had Visual Studio installed.....

    I also had Just-in-Time Debugger popping up without having Visual Studio installed.  Then my computer started freezing up after 5 minutes each time it was turned on except when in safe mode.  Now XP will not load (I can't even use safe mode) and I get a message that system32\Drivers\pci.sys file is missing or corrupted.  I try to load from the CD in repair mode but even that does not work--it tells me the file is not there.  I have already tried all suggestions I could find that others used when they got the same message.  Does anyone have anything else I can try before I just give up and hope a reinstall works?
    Sunday, May 02, 2010 4:23 AM
  • Solution

    Open Start>Control Panels>Internet Options: Advanced and activate (check box)

    * Disable Script Debugging (Internet Explorer)
    * Disable Script Debuggung (Other)


    It worked and it was so simple.  Thankyou very much.  No need to cut, past all of the above info.  Simple and effective.  Leave it to a JersyGRL to get to the point.

     

    Sunday, May 30, 2010 10:54 PM
  • I know this is a very old thread, but still, my app (Winamp) did not crash even one single time until JITDebugger came up. Let me think, what could be the problem... hmmm maybe it is JITDebugger! Besides I want to decide whether an application is not operating well. The activation of Disable debugger worked out for me, winamp is working now for a few days and has been running every day without crashing.

    Z4uit
    Wednesday, June 23, 2010 11:10 AM
  • I've been having the same problem with Just-In-Time debugger preventing me from installing programs. Yesterday I tried just about everything suggested in these posts, but with no success. However, this morning I checked this link:

    http://msdn.microsoft.com/en-us/library/5hs4b7a6.aspx

    and I found that by changing the value of

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\AeDebug\Debugger

    from

     

    "c:\WINDOWS\system32\vsjitdebugger.exe" -p %ld -e %ld

    to

    0

    I solved the problem. Hooray!! I hope this helps anyone else who is having trouble.

     

    Jo

     

    Friday, June 25, 2010 7:38 AM
  •  

     This 'debugger' turned up from nowhere. Popping up constantly, instantly after rejecting it. Finally got rid of it by turning my internet options to 'always deny pop-ups'. Could this be a virus of some kind?

    -still irritaded, grrr-

    Tuesday, June 29, 2010 8:40 PM
  • I was just reading the thread! Kinda hilarious though.

    JIT is used to catch real time errors especially run-time. It is very useful for developers. To catch un handled exceptions.

    Jit comes as a part of Visual Studio. If you do not know how to manage Jit its better not to install Visual Studio (no skills to manage it will give you lots of trouble). Just the programing skills does not make a good developer. Well its not a fault of VS developer team or Bill Gates. Doh! 

    Jit will be invoked if enabled by Visual studio, instead of Dr Watson. If programs crash the crash handlers will be invoked and you will see Dr.Watson process running in the background. It will call dumprep and will create error logs; Errors will be logged in Event Viewers as well. Even a simple failure will be handled and Jit will be invoked. So programs will begin to crash while they run or install.

    Some developers set programs to use Jit and Jit will be enabled instead of Dr.Watson. Dr.Watson will be invoked in serious errors however. Its obvious. But specially if you have installed Visual Studio, you will be using JIT as well. JiT overrides the Dr.Watson Program. But you can reverse it back using two methods.

    Its a third party piece however. I wonder why these MSDN people do not know how to provide a complete answer. Each and every person does not understand Administration of programs. So its their responsibility. That is a laughing matter though. But people will be pissed off. Can't blame them either. Some  of them are not familiar with regedit tools. So the answers have to be flexible and complete.

    The bad behavior of JIT is it will suspend the program an once when an error occur. You will never be allowed to run further. So its kinda piece of ____. It also has security issues with it.

    Unfortunately if a program Invokes JIT intensionally its not possible to reverse the process. 

    Stop JIT while you have Visual Studio installed (Its a stupid thing to uninstall it without removing JIT. No way!)

    How this thing will be enabled?

     

    1. Open VS:
    2. Go to Tools and then Options.
    3. In the Options Dialog box Double click Debugging and then click JIT
    4. Enabling options:
    • Manage
    • Native
    • Script
    Click on OK.

    This sets the Registry key and will start JIT. So do the Revers to Disable it.

    You have to Disable the Keys. Method one:
    1. Click on Start Menu and Type Run (for P Hit Run box)
    2. Type in regedit and hit Enter
    3. Expand the Keys to located the place
    4. HKLM\Software\Microsoft\Windows NT\CurrentVersion\AeDebug\Debugger is one location.
    5. HKLM\Software\Microsoft\.NETFramework\DbgManagedDebugger
    6. Delete these keys. Or set the Auto key's value to 1.
    7. On a 64bit system the paths will be: HKLM\Software\Wow6432Node\Microsoft\...
    8. You may need to reboot the system as well. 
    Method two: Enable Dr.Watson using an alternative method:
    • Get a Command Window (Command Prompt)
    • Type drwtsn -i and 
    • Hit enter
    If you were using a third party debugger read this 

    Microsoft Support

     Next step

     

    Open Start>Control Panels>Internet Options: Advanced and activate (check box)

     

    • Disable Script Debugging (Internet Explorer)
    • Disable Script Debuggung (Other) 

     


    If you have enabled Server Side Script Debugging the pages will freeze if an error occurs.
    Read the enabling procedure. Steps to enable debugging portion. Do the Reverse to disable it.

    For Script Debuggers:
    Here is how you enable the JIT:
    • Click on Options then Tools
    • Click on Debugger
    • Select JIT debugger and attach to programs running on this machine
    • So now you know how it happened. Do the reverse to disable it!

    Using third party tools and software may enable this tool. If you detect one you have to avoid using it.

    If you use IIS please read here
    • Proposed as answer by Lasith-VEGA Saturday, July 10, 2010 7:37 AM
    Saturday, July 10, 2010 7:36 AM
  • Thank you so much !!  Finally got rid of that pop-up!
    Saturday, July 10, 2010 9:11 PM
  • @Jackson024

    Yes. You could either delete it or not. After deleting an exe its always good to remove the broken links but with a caution. 

    Either the Registry method or Dr.Wtsn method will do the trick.

    Welcome e'one!

    Wednesday, July 14, 2010 11:19 PM
  • As per ur suggestion  i changed the default debugger i.e drwatson to vsjitdebugger.exe in ur given regestry path & solved the problem

     

    Thanx

     

    Saturday, July 17, 2010 6:21 AM
  • mine where already checked what do i do??

     

    Saturday, July 24, 2010 8:11 PM
  • didnt work:/ for me it was already set to 0

    Saturday, July 24, 2010 8:14 PM
  • Try disabling the "Machine Debug Manager" service and then restart and see if that works.  Worked for a client of mine.
    Friday, August 20, 2010 4:58 PM
  • I am having all the the same problems as mentioned above. I first starting getting the Visual Studio Just In Time Debugger pop-ups only a few per day. Then few per hour, until recently when they started popping up all the time! Now I am getting them all the time! It finally broke windows! I don't have a start bar, no icons, no clock, nothing. I can't even run a windows search. So I came across this post and other ones, which suggested I delete 2 registry keys. This did not fix the problem, my computer is very angry! Any ideas?
    Thursday, September 02, 2010 7:23 PM
  • I deleted that key, and now all it does is bring up a box labeled Just-In-Time Debugging that reads "An Exception 'Runtime Error' has occurred in the script.

    However, no debuggers are registered that can debug this exception."

     

    Please help.

    Sunday, October 17, 2010 3:19 PM
  • That would work, except the command I was requested to enter didn't work, and I have no current debugger, apparently. Is there any way to deactivate or delete the process that alerts you to these script errors, which are apparently not causing the errors I'm encountering, as the machine only goes unstable if I close the JIT box too much, so I have come to believe that it is JIT that is causing to problem.

    I deleted the registry keys associated with JIT debugger, and now it comes up with a box saying that a script error has occured and there are no debuggers that can be used to debug. This does the exact same thing JIT usually does, which is constantly pop up at intervals and be a pain in the ____ to get rid of, even temporarily, and then brick you system and require a reset.

    Sunday, October 17, 2010 3:56 PM
  • This worked for me

     

    Monday, November 01, 2010 1:17 PM
  • Hi,

         Sorry this is so long in coming.  I acquired the problem 4 days ago, I'm not crying so much anymore, I think it is gone now. :)

         By the way: I would be leery of anything changing the Registry, if you do so, be sure to write down the old settings just in case.

         Being a technical turkey, I saw the answer that worked a long time ago but didn't know how to do what they were saying.  So I will say it my way.

         When the blooming JustInTimeDebugger window pops up, click "yes".  You should get a technical debugging page.  A pop-up that says 'continue' or 'break' should be there.  Click 'break' and that little pop-up should exit (if not click 'continue' for I must have them backwards).

         At the top of the debugger screen that is left, click "tools"; then "options".  A screen should appear with stuff at the left, when you highlight something at the left, information should appear about that subject on the right.  I did this without writing it down so I will not remember exactly but you can do it as I did.  I went through highlighting each word on the right and reading the screen it brought to the left.

         Arggh...  I am sorry that I do not remember the exact thing it said but I unchecked it.  I think it said "JIT something or alert me or something like that.  Anyway, you will find it and should be able to figure out which it is.  Don't forget to "apply" before closing the debugger window.

    Loveya,

    duane

     

     

    Sunday, November 21, 2010 6:40 PM
  • Hi,

         I am new here and not all so bright.  I assume your problem is already corrected, but just in case.

         Can you replace the key you deleted?  Did you find how to cancel the debugger from the tools in the debugger window?

    Loveya,

    Duane

    Sunday, November 21, 2010 6:43 PM
  • Old thread, but I ran into this problem today and found a solution that wasn't listed here.  Specifically, I did not want to un-install the web developer toolbar and ultimately didn't have to:

    • Go to Tools > Manage Add-Ons > Enable or Disable Add-Ons
    • Disable the IE Developer Toolbar BHO

    This got rid of the Just in Time Debugging prompt and allowed me to continue using the Developer Toolbar.  Hope this helps.

    Thursday, December 02, 2010 10:44 PM
  • Hi Eitan,

    Thank you so much for being here. I had the terrible debug bug/tab and it kept throwing me off my browser for two days. After downloading several softwares for security, nobody could get rid of it (even if I paid $$$ for their program). I followed your advice and it has been put to bed.

    Have a great Christmas and a wonderful 2011. Hope you stop by to read this thanks.

    Marie

    http://www.aussieoibooks.com.au

    http://www.smashwords.com/profile/view/marieseltenrych

     

    Wednesday, December 15, 2010 3:56 AM
  • I justmoved  vsjitdebugger.exe  to vsjitdebugger.exe.bak  and wrote a hello world program which I then named vsjitdebugger.exe

    I tried for days to get  rid of vsjitdebugger, and nothing else would work. I also had one of the guys who worked for me, do the same. It was all a huge waste of time.

     

    Now whenever something crashses, the message "Hello Sailor!"  prints to the screen, and the process terminates.

    Saturday, December 25, 2010 2:20 PM
  • Hello Everyone,

    I am a more advanced user and I have this same problem though I have discovered it in a different way.

    I am a developer with several instances of VS installed dating all the way back to 6.0 and in rare cases when I am prompted to choose among my many debuggers I don't really care.  Except when browsing the web of course where scripting errors are pretty common.  As such I typically surf with Firefox and save IE for development tasks.

    I'm not really a Microsoft guy and I hate jumping to their defense here but they did not break your programs.  They changed the way Windows deals with unhandled exceptions.  Basically your applications never worked properly but i assume Dr Watson (or whatever) used to log those errors and let you go on your merry way.  Once you installed VS or the SDK or whatever developer tool you like, they assumed you would like the ability to JIT debug.

    That said I am usually launching the VS debugger myself and for them to assume that I want to debug every unhandled exception that comes along is a nuisance.  Even more so the fact I am still getting these errors after trying to disable this damn thing every which way is really annoying.

    I am developing a windows service that must depend only on the 2.0 Framework (so no WCF).  As such I am going through the rigmarole of starting my service and attaching my debugger to the process.  I was finding it peculiar that the debugger could never get passed unhandled exceptions and once I stopped the debugger (detached from the process) I STILL got that stupid debug prompt.  No big deal right..eventually I'll compile a release build and run it through without attaching.  WRONG...the JIT debugger still wants to handle everything.  All I want is for Windows to log the event and let the service run, which I assume is the case on any non-developer machine but nope...

    I've read this whole thread and some of these posts are brilliant...still nothing has worked for me.  I have...

    Disabled JIT in VS 2003, 2005, 2008, and Windows SDK.

    Deleted the registry keys.  This is actually a Microsoft solution at http://msdn.microsoft.com/en-us/library/5hs4b7a6.aspx

    Flipped AeDebug\Auto key from 0 to 1.  (I had high hopes for this one.)

    Disabled the Machine Debug Manager service.

    I even disabled the script debugging in IE.  I know this shouldn't matter but hoping maybe it hits the right registry value.  Microsoft has done worse...

    I have to draw the line at hacking up the executables or disabling my Developer Toolbar.  Does anyone out there have any other ideas?  My error is actually a visual studio error telling me none of my instances has a JIT debugger available.  I really feels like I just haven't touched on the right registry setting yet.  Do I really need to go back and set the Dr Watson executable as the default?

    In the meantime I think I'll practice what I preach and write my own error logging and stop lazily expecting Windows to handle it for me.

    Cheers

    Wednesday, January 12, 2011 9:25 PM
  • I tried the regegit, I tried to disable the script debugging...nothing works.

    My boss had to pay $190 for some Geek Tech person to run a ton of anti virus ____..only to find it is MICROSOFT related!!!

    And now, since I've changed the key value to 0  every time I log onto the net..It opens a new window stating their is a problem with my registry and I need to click this link.. I Dont Think So!

    UGGH!!

     

    *using Windows XP and this only happens when "Your computer was recently updated"

    Thursday, January 13, 2011 6:11 PM
  • Did not work for me.  I have same problem....pop up every few seconds...to every minute or so.  Annoying.
    Dave Lamont
    • Proposed as answer by TazXan Wednesday, January 19, 2011 4:12 PM
    Tuesday, January 18, 2011 7:40 PM
  • I ran the drwtsn -i command w/o success, so I stepped into the VB debugger program and went to tools and then the JIT debugger options and unchecked the run the debugger choice.  I didn't experience any more issues on that workstation but  I didn't hang around long enough to see if it worked but i also found an executable in the startup called mobsync.exe that I disabled but didn't reboot.  There were about 10 outlook.exe programs in the task manager which could have been launched by that executable, so I ran malwarebytes on it in the meantime.
    • Proposed as answer by TazXan Wednesday, January 19, 2011 6:11 PM
    Wednesday, January 19, 2011 4:21 PM
  • Really interesting thread here, I don't have Visual studio installed, but am getting an  error message from WinTV, basicly saying that if JIT debugging is enabled, any exception will be sent to the JIT debuggerby registered on the computer rather than this dialog box. Yikes
    Saturday, January 29, 2011 7:48 PM
  • <<< If it was me, I would take a look at where the app was crashing, and send a bug report to the product support team that own's your crashing app. >>>

    I have experienced a similar problem after Visual Studio Shell (included with SQL Server 2008) was installed. The crashing app is a Microsoft IIS ASP web page - should I send the bug report to Microsoft? Makes sense to me!

    Seriously, instead of simply allowing the browser to display the 500 error message, Just In Time insists on taking over the entire server by displaying a system modal dialog box. Sounds like a bad design to me. I guess the designers of JIT never heard of log files.

     

    Wednesday, February 02, 2011 8:40 PM
  • I know this post is old but it is one of the first to appear in Google so i thought i would post a resolution...

     

    When you are prompted with this.. select yes to debug. Then when the debugger opens just go to tools>options>debugging>JIT options and disable JIT Debugging by unchecking the box.

     

    Simple.

     

    Sam

    Monday, February 21, 2011 3:50 PM
  • Quoting rasteve

    1. Click Start

    2. Click Run

    3. Type cmd (and click ok)

    4. Type drwtsn32 -i (and press enter)


    Excelent!!!
    • Proposed as answer by fade2gray Wednesday, March 30, 2011 10:56 PM
    • Unproposed as answer by fade2gray Wednesday, March 30, 2011 10:57 PM
    • Proposed as answer by fade2gray Wednesday, March 30, 2011 11:00 PM
    Wednesday, March 30, 2011 10:47 PM
  • If you have visual studio 2005 and 2008 at the sane time delet 2008. See how that works for you. And delete SQL too.

    Go to control,remove programs,SEE IF YOU HAVE BOTH OF THESE RUNNIG AT THE SAME TIME THEN DO WHAT I SAID BEFORE.


    daniel yoders.
    Wednesday, April 13, 2011 2:11 AM
  • dude it didn't work for me ... please help ! its really annoying the freaking JIT box appearing everywhere like 20 times per minute !

    thanks

    Tuesday, May 24, 2011 10:20 PM
  • agree with you man
    Sunday, May 29, 2011 3:50 PM
  • Thanks Buddy
    Sunday, May 29, 2011 3:50 PM
  • Don't know if this helps, but I had the same problem though it happened only while my laptop was connected to the tv (extended desktop or something). When I unplugged it, didn't show up anymore.
    Tuesday, May 31, 2011 6:03 PM
  • Sorry but that dos not work
    Friday, June 24, 2011 1:00 AM
  • I keep getting this message no matter what I try.

    See the end of this message for details on invoking
    just-in-time (JIT) debugging instead of this dialog box.

    ************** Exception Text **************
    System.FormatException: Input string was not in a correct format.
       at System.Number.StringToNumber(String str, NumberStyles options, NumberBuffer& number, NumberFormatInfo info, Boolean parseDecimal)
       at System.Number.ParseInt32(String s, NumberStyles style, NumberFormatInfo info)
       at Agent.BDDevice.CheckOnlineVersion()
       at Agent.BDDevice.ValidateDevice()
       at Agent.DeviceFinder.FindDevices(List`1 InputList)
       at Agent.AgentForm.WndProc(Message& m)
       at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
       at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)


    ************** Loaded Assemblies **************
    mscorlib
        Assembly Version: 2.0.0.0
        Win32 Version: 2.0.50727.4961 (win7RTMGDR.050727-4900)
        CodeBase: file:///C:/Windows/Microsoft.NET/Framework64/v2.0.50727/mscorlib.dll
    ----------------------------------------
    UpAgent
        Assembly Version: 1.0.0.0
        Win32 Version: 1.0.0.0
        CodeBase: file:///C:/Users/james/AppData/Local/Apps/2.0/4T3B8OKY.GM0/MTNJAC15.WT7/upag..tion_1f5964649fa259d4_0001.0000_e3bb9afe10f5e7eb/UpAgent.exe
    ----------------------------------------
    System
        Assembly Version: 2.0.0.0
        Win32 Version: 2.0.50727.4957 (win7RTMGDR.050727-4900)
        CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System/2.0.0.0__b77a5c561934e089/System.dll
    ----------------------------------------
    System.Windows.Forms
        Assembly Version: 2.0.0.0
        Win32 Version: 2.0.50727.4961 (win7RTMGDR.050727-4900)
        CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System.Windows.Forms/2.0.0.0__b77a5c561934e089/System.Windows.Forms.dll
    ----------------------------------------
    System.Drawing
        Assembly Version: 2.0.0.0
        Win32 Version: 2.0.50727.4927 (NetFXspW7.050727-4900)
        CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System.Drawing/2.0.0.0__b03f5f7f11d50a3a/System.Drawing.dll
    ----------------------------------------
    System.Configuration
        Assembly Version: 2.0.0.0
        Win32 Version: 2.0.50727.4927 (NetFXspW7.050727-4900)
        CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System.Configuration/2.0.0.0__b03f5f7f11d50a3a/System.Configuration.dll
    ----------------------------------------
    System.Xml
        Assembly Version: 2.0.0.0
        Win32 Version: 2.0.50727.4927 (NetFXspW7.050727-4900)
        CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System.Xml/2.0.0.0__b77a5c561934e089/System.Xml.dll
    ----------------------------------------

    ************** JIT Debugging **************
    To enable just-in-time (JIT) debugging, the .config file for this
    application or computer (machine.config) must have the
    jitDebugging value set in the system.windows.forms section.
    The application must also be compiled with debugging
    enabled.

    For example:

    <configuration>
        <system.windows.forms jitDebugging="true" />
    </configuration>

    When JIT debugging is enabled, any unhandled exception
    will be sent to the JIT debugger registered on the computer
    rather than be handled by this dialog box.

    Wednesday, July 06, 2011 10:27 PM
  • Thank you to all
    • Proposed as answer by tollmandot Monday, September 19, 2011 1:30 AM
    • Unproposed as answer by tollmandot Monday, September 19, 2011 1:30 AM
    Sunday, August 21, 2011 1:39 PM
  • Thanks Eitan Shapir... This worked like a charm!
    Cheers, Matt Bramer
    My Blog
    Send me a tweet
    Thursday, December 15, 2011 5:43 PM
  • thank rasteve ,

    It's work for me.

    I do following for further details on the actual issue with JIT:

     

    http://support.microsoft.com/default.aspx/kb/923827

    Friday, March 09, 2012 6:15 AM
  • thanks for the  given solution

    really thanks boss

    Tuesday, April 17, 2012 5:07 AM
  • Helllo! I reset it to 0 but it's still unable to open my Adobe Acrobat but my Photoshop runs. How can I reset to its default value. Thank you.

    gibugi

    Thursday, May 17, 2012 12:25 PM
  • I had to go to extremes to fix this issue, I disabled every script within Internet explorer and I disabled JIT in every copy of visual studio that I use, In the registry I went as far as to delete the JIT keys and still I got the popup window, only this time telling me that it was not connected to any instance of VS which of course it was not because I systematically disabled it everywhere.

    I use Windows7 x64 and to fix this I eventually found where the VSJitDebugger.exe was installed and just deleted it.  That will 100% work as it is no longer present on the machine to cause you an issue with any popup.  Uninstalling VS may leave it behind, so delete it direct.

    For me it was located here:

    "C:\Windows\system32\VSJitDebugger.exe"

    After deleting the EXE file - no pop ups occur :-)

    Hope that helps someone!

    Friday, October 26, 2012 9:45 AM
  • Super old post :P
    Monday, May 20, 2013 12:43 AM
  • Who would know that 7 years later that some random person like me would spend a full week trying to solve the same problem -.-
    Monday, May 20, 2013 12:45 AM
  • Try this:

    Right click My PC - Properties- Click  the Advanced Tab -Under Performance, click Settings - Click Data Excecution Prevention tab -  Select "Turn on DEP for essential Windows programs and services only

    reboot computer 

    Thursday, February 27, 2014 2:29 PM
  • I had to go to extremes to fix this issue, I disabled every script within Internet explorer and I disabled JIT in every copy of visual studio that I use, In the registry I went as far as to delete the JIT keys and still I got the popup window, only this time telling me that it was not connected to any instance of VS which of course it was not because I systematically disabled it everywhere.

    I use Windows7 x64 and to fix this I eventually found where the VSJitDebugger.exe was installed and just deleted it.  That will 100% work as it is no longer present on the machine to cause you an issue with any popup.  Uninstalling VS may leave it behind, so delete it direct.

    For me it was located here:

    "C:\Windows\system32\VSJitDebugger.exe"

    After deleting the EXE file - no pop ups occur :-)

    Hope that helps someone!

    This solved my issue - thanks,
    Thursday, August 21, 2014 11:19 PM