none
Exclusive checkout rule in TFS

    Question

  •  Exclusive checkout rule in TFS should be made default..

    Please advice how to acheive this.

    Cheers
    Raj
    • Moved by Bill.Wang Monday, October 27, 2008 5:33 AM This is a question about lock. (Moved from Team Foundation Server - Administration to Team Foundation Server - Version Control)
    Friday, October 24, 2008 7:27 AM

Answers

  • You need to turn off the Multiple Check Out option to get it to default to "Check out - Prevent other users from checking out and checking in". However, there will be no shared check out then. I do not know of a way to allow shared checkout but have the process default to locking.
    mjlarezzo
    • Marked as answer by Bill.Wang Saturday, November 01, 2008 3:19 AM
    Monday, October 27, 2008 2:15 PM
  • If you do not see the "Unchanged - Keep any existing lock" option then you are probably running TFS 2005 on your client.  The "None" setting should still work in conjunction with a team project where multiple checkout is disabled -- it will simply be overridden by the server.
    • Marked as answer by Bill.Wang Saturday, November 01, 2008 3:19 AM
    Tuesday, October 28, 2008 5:44 PM

All replies

  • Hi Raj
     

    'Enable multiple check-out' can be turned off at the team project level. See How to: Configure Check-Out Settings for more information.

     

    If you enabled multiple check-out, the default selected lock type when you check out an item is "Unchanged - Keep any existing lock". If you check-out with this type, the result lock will be:

    1. Exclusive lock if no one has already checked it out.
    2. Current lock type if it's locked by others.

    Please mark the replies as answers if they help and unmark them if they provide no help.
    Monday, October 27, 2008 5:31 AM
  • I enabled Multiple Check out option in the Team project level as a requirement.

    In this case I am able to see only following three options only..

    • None - Allow shared check out
    • Check out - Prevent other users from checking out and checking in
    • Check in - Allow other users to check out but prevent them from checking in

    Among these three selection it always default selected the None - Allow shared check out option. But want to enforce the option of Check out - Prevent other users from checking out and checking in as default option.

    In this case by default it goes with this and if user wants they can change the option.

    Hope I tried to clarify the requirement.

    Please advice.

    Cheers
    Raj

    Monday, October 27, 2008 7:25 AM
  • You need to turn off the Multiple Check Out option to get it to default to "Check out - Prevent other users from checking out and checking in". However, there will be no shared check out then. I do not know of a way to allow shared checkout but have the process default to locking.
    mjlarezzo
    • Marked as answer by Bill.Wang Saturday, November 01, 2008 3:19 AM
    Monday, October 27, 2008 2:15 PM
  • If you do not see the "Unchanged - Keep any existing lock" option then you are probably running TFS 2005 on your client.  The "None" setting should still work in conjunction with a team project where multiple checkout is disabled -- it will simply be overridden by the server.
    • Marked as answer by Bill.Wang Saturday, November 01, 2008 3:19 AM
    Tuesday, October 28, 2008 5:44 PM
  • Bill.Wang said:

    Hi Raj
     

    'Enable multiple check-out' can be turned off at the team project level. See How to: Configure Check-Out Settings for more information.

     

    If you enabled multiple check-out, the default selected lock type when you check out an item is "Unchanged - Keep any existing lock". If you check-out with this type, the result lock will be:

    1. Exclusive lock if no one has already checked it out.
    2. Current lock type if it's locked by others.

    Please mark the replies as answers if they help and unmark them if they provide no help.


    I love your reply mate !!! Keep up the good work :)
    • Proposed as answer by nrps Wednesday, February 04, 2009 4:25 AM
    Wednesday, February 04, 2009 4:25 AM