none
git Errors VS2013 RTM

    Question

  • I have been getting the following error messages using git in VS2013 RTM.

    When trying to sync a branch:

    An error occurred. Detailed message: An error was raised by libgit2. Category = Net (Error).Response status code does not indicate success: 502 (Bad Gateway).

    When changing branch:

    An error was raised by libgit2. Category = Os (Error).
    Could not remove directory '<local path>': Access is denied.

    When using the command line the git operations work correctly.

    We are using TFService for the remote git repo.


    Wednesday, October 23, 2013 1:16 AM

Answers

  • Hi MartoTS,

    I can sync local repo with remote repo by using VS2013 RTM. Can you repaire your VS2013 RTM and try again? Also, you can can see event viewer to see if there any useful info or have a try on other machines as I mentioned above.

     

    Best regards,


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Friday, October 25, 2013 8:06 AM
    Moderator

All replies

  • Hi,

    I am moving your thread into the Team Foundation Service Forum for dedicated support. Thanks for your understanding.

    Best Regards,


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Thursday, October 24, 2013 7:32 AM
  • Hi MartoTS,

    Thanks for your post. You can check if your net connection is fine, also check whether any firewall rules conflict with the push action.  From the error info, seems you don't have access to local git repo, please check your permissions. Another option is have a try on other machines to see if it works fine.

    Best regards,


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Thursday, October 24, 2013 2:58 PM
    Moderator
  • Hi Kimi,

    The errors only happens in VS, using the command line, it works fine.

    Thursday, October 24, 2013 10:19 PM
  • Hi MartoTS,

    I can sync local repo with remote repo by using VS2013 RTM. Can you repaire your VS2013 RTM and try again? Also, you can can see event viewer to see if there any useful info or have a try on other machines as I mentioned above.

     

    Best regards,


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Friday, October 25, 2013 8:06 AM
    Moderator