none
VS2008 - Google Chrome as default Web Browser for Debugging problem

    Question

  • Every once in a while I notice that suddenly my default web browser for debugging is changed to Google Chrome automatically. So when I hit F5, the web-application is launched in Google Chrome. This happens once in every 3 - 4 months.

    I have Google Chrome installed on my system, but I never use it. Not even for normal web browsing. So there is absolutely no chance that I changed that myself.

    I have to set it back to "Internal Web Browser" and it gets associated with Internet Explorer again. But I want to know how/why this change happens automatically.

    Any ideas?


    Pradeep, Microsoft MVP (Visual Basic)
    http://pradeep1210.wordpress.com


    • Edited by pradeep1210 Thursday, March 22, 2012 12:13 PM
    Thursday, March 22, 2012 12:09 PM

Answers

  • The configuration of the default browser is stored in %userprofile%\AppData\Local\Microsoft\VisualStudio\10.0\browsers.xml

    I do think it will only be modified by Visual Studio itself when you set the default browser on UI, and there shouldn't be any other process which modifies this file. You may enable auditing on this folder to monitor the modification of this file. Please refer to http://support.microsoft.com/kb/310399 to learn how to enable auditing.

    Sunday, April 01, 2012 5:58 AM

All replies

  • This is not a Visual Studio Debugger problem, the Visual Studio will also just read your System settings and boot the corresponding Web Browser.

    Once your System's default web browser changed by others(manually or by software[virus or management type tool, and also cannot exclude the some add-ins which are unknown by me]), the changed web browser will be start when you click on some link in outlook/word document and the Visual Studio want a web browser for debugging.

    Best wishes,


    Mike Zhang[MSFT]
    MSDN Community Support | Feedback to us


    Friday, March 23, 2012 3:23 AM
    Moderator
  • I think I was not clear enough. I'll try to explain more.

    The system default web browser is not changed. My system default web browser is Firefox, which I use for normal web browsing. I use Internet Explorer for Visual Studio debugging (asp.net applications). Google Chrome is installed but is never used - neither for web browsing or asp.net application debugging. So whenever I click a link or try to browse any website normally, it opens in Firefox by default.

    When I want to debug the asp.net applications, it is launched in Internet Explorer (Internal Web Browser). So if I right-click app and select Browse With..., the dialog box is shown as below:

    Now the problem is:

    Every once in a while, this default changes to Chrome, instead of the Internal Web Browser. And when this happens, my asp.net applications start launching in Google Chrome when I press F5.

    And when this problem happens, and I open this dialog, the status is like this:

    Other parts of my system are not affected in any way. Google Chrome is still not my system default web browser. Because when it opens, the message box appears asking whether I want to set it as the default web browser. And links still open by default in Firefox.

    I normally never open this dialog box (unless this problem occurs). So there is absolutely no chance that I changed it myself. But I agree with you that it could be a result of some Addin malfunctioning.

    Below is a list of what all is install with my Visual Studio (Microsoft Visual Studio 2008 Professional, Version 3.5 SP1)
    Microsoft Visual Basic 2008
    Microsoft Visual C# 2008
    Microsoft Visual C++ 2008
    Microsoft Visual Studio 2008 Tools for Office
    Microsoft Visual Studio Tools for Applications 2.0
    Microsoft Visual Web Developer 2008
    CodeRush Xpress   9.3
    Crystal Reports    
    Crystal Reports Basic for Visual Studio 2008
    DXCore for Visual Studio   9.3
    (rest all are hotfixes and security updates)


    Pradeep, Microsoft MVP (Visual Basic)
    http://pradeep1210.wordpress.com

    Friday, March 23, 2012 7:39 AM
  • Hi pradeep,

    A way to check is to unistall Chrome. If in the next three or 4 months VS starts firing up Firefox instead of Explorer then the way VS is reading your default browser settings could be the problem.

    rupex

    Friday, March 23, 2012 2:45 PM
  • Waiting for 3 or 4 months to test a problem was never so awesome! :P

    Unfortunately, I can't uninstall it because when customers report rendering issues with my application with particular web browsers, I need to open the website in those browsers to check.

    I can check from other colleague's PC also, but that would be a problem running on to someone else's PC every time  and telling them to fireup Chrome and check a particular page on our website.

    Moreover, there is no surety that if the problem doesn't occur for 3 or 4 months, it is gone forever.


    Pradeep, Microsoft MVP (Visual Basic)
    http://pradeep1210.wordpress.com

    Friday, March 23, 2012 8:06 PM
  • Too true :)
    Saturday, March 24, 2012 12:51 AM
  • After days search, I also have not got a report mentioned this issue, so I also cannot ensure if it is a real Visual Studio 2008 product issue.

    And form your issue description, it seems that the problem also cannot reproducible easily, at least can we see that we do not know how to repro the same issue, right?

    I will try to let others engineers know this issue, they will show you responds once they have any idea for you.

    The same time I would like to recommend you try the ASP.NET forums, since the experts there uses this feature usually than this forum, I think. Maybe they can show you some minds.

    Best wishes,


    Mike Zhang[MSFT]
    MSDN Community Support | Feedback to us

    Monday, March 26, 2012 6:22 AM
    Moderator
  • Thank you :)

    Pradeep, Microsoft MVP (Visual Basic)
    http://pradeep1210.wordpress.com

    Monday, March 26, 2012 11:53 AM
  • You're welcome!

    Mike Zhang[MSFT]
    MSDN Community Support | Feedback to us

    Tuesday, March 27, 2012 8:29 AM
    Moderator
  • May you try set Chrome as default browser on Windows and check how VS behaves?

    In my opinion, VS just launches System's default browser. Your problem happens because the System's default browser is set to Chrome.

    Have you ever tried open a link from some files or command line? Was the link opened in Chrome or IE? For example, you can run "start http://www.bing.com" command when the problem happens again.

    Thanks.

    Wednesday, March 28, 2012 5:03 AM
  • Neither Chrome nor Internet Explorer is my default browser. It is Firefox.

    So whenever I try to open any link etc. or type a URL in the Start > Run box, or type "start http://someurl" from command prompt, it is opened in Firefox. I also confirmed it just now to double check that what I'm writing is correct.

    I also tried to temporarily set Chrome as the default browser and see if it has any effect on Visual Studio. It has absolutely no effect. The web application continues to launch in Internet Explorer.


    Pradeep, Microsoft MVP (Visual Basic)
    http://pradeep1210.wordpress.com

    Wednesday, March 28, 2012 7:08 AM
  • The configuration of the default browser is stored in %userprofile%\AppData\Local\Microsoft\VisualStudio\10.0\browsers.xml

    I do think it will only be modified by Visual Studio itself when you set the default browser on UI, and there shouldn't be any other process which modifies this file. You may enable auditing on this folder to monitor the modification of this file. Please refer to http://support.microsoft.com/kb/310399 to learn how to enable auditing.

    Sunday, April 01, 2012 5:58 AM
  • The configuration of the default browser is stored in %userprofile%\AppData\Local\Microsoft\VisualStudio\10.0\browsers.xml

    I do think it will only be modified by Visual Studio itself when you set the default browser on UI, and there shouldn't be any other process which modifies this file. You may enable auditing on this folder to monitor the modification of this file. Please refer to http://support.microsoft.com/kb/310399 to learn how to enable auditing.

    Wow! This looks like a great solution, though I may have to wait for a long time to get any result.

    Thanks.


    Pradeep, Microsoft MVP (Visual Basic)
    http://pradeep1210.wordpress.com

    Sunday, April 01, 2012 10:53 AM
  • Monday, April 09, 2012 12:52 PM