none
Help disabling Just-In-Debugging

    Question

  • I installed .net 2.0 yesterday and now Just-In-Time Debugging has taken over my apps I work on outside of VS.net. I have followed all steps I have found to disable JIT with no results. So then I uninstalled 2.0 and reverted back to 1.1. Still, the JIT dialogue pops up. The pages I am working on are classic asp pages and the last thing I need is these JIT popups. I have been unable to find any information beyond the checkboxes in VS.net. Could  anyone shed some light on this?

    If it matters, I am on XP Pro and run VS.Net 2003.

    Thanks.

    Tuesday, February 28, 2006 9:19 PM

Answers

  • Delete the following registry keys:
    • HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\AeDebug\Debugger

    • HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\.NETFramework\DbgManagedDebugger

    On a 64-bit operating system also delete the following registry keys:

    • HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows NT\CurrentVersion\AeDebug\Debugger

    • HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\.NETFramework\DbgManagedDebugger

    Hope this will help....

    By the way, uninstalling Microsoft .NET is not a logical solution.  If you do, other programs will be affected.

    Hmmmm.. don't blame Bill, it's the matter of analyzing how .NET work and how it has been installed.  Above solution is the best and working solution in disabling JIT.

    Thursday, September 07, 2006 2:48 AM
  • I got the solution:

    • Right click My PC / Properties.
    • Click Advanced Tab
    • Under Performance, click Settings
    • Click Data Excecution Prevention tab
    • Select Turn on DEP for essential Windows programs and services only
    • Restart Windows

    This option is selected by default, but with installation of SQL 2005 or Visual Studio it changes and start to cause a series of trouble without any information to the user.

    Hope this help you.

    Bandolex.

    Sunday, August 13, 2006 6:11 AM
  • It sounds like you want to turn off script debugging on your computer.

    1) In Internet Explorer, select Tools -> Options
    2) On the Internet Options dialog, go to the Advanced tab
    3) Make sure that both of these options are checked:

     X Disable Script Debugging (Internet Explorer)
     X Disable Script Debugging (Other)

    Habib Heydarian
    Program Manager
    Visual Studio Debugger

    Wednesday, March 01, 2006 10:54 PM
    Owner

All replies

  • It sounds like you want to turn off script debugging on your computer.

    1) In Internet Explorer, select Tools -> Options
    2) On the Internet Options dialog, go to the Advanced tab
    3) Make sure that both of these options are checked:

     X Disable Script Debugging (Internet Explorer)
     X Disable Script Debugging (Other)

    Habib Heydarian
    Program Manager
    Visual Studio Debugger

    Wednesday, March 01, 2006 10:54 PM
    Owner
  • Hi Habib,

    Thanks for your response. Actually, all I am trying to do is stop JIT debugger from intercepting the errors and popping up. This never happened with .NET 1.1, only when I installed .NET 2.0. I do want to see script debugging, since I am a developer, but I am fine with my 500 error pages (working with classic ASP in that case). I followed all the suggestions I could find to stop JIT from intercepting errors (settings in VS.NET and editing the registry setting for JIT) with no luck. Today I have been on the phone with Microsoft for almost two hours and still no luck--they are going to get back to me.

    Thanks again.

    Wednesday, March 01, 2006 11:28 PM
  • Are these errors in classic ASP server side script or in client-side JScript?

    Habib Heydarian
    Program Manager
    Visual Studio Debugger

    Wednesday, March 01, 2006 11:40 PM
    Owner
  • Hi Habib,

    It is server side, VB Script, and can be as simple as a variable not declared when using Option Explicit. Where I used to deal with these via the 500 error that comes up on the page, I now first get the JIT debug dialogue popup.

    For example, this code:

    <%
    Option Explicit
    Response.Buffer = True

    Set objXMLDoc = CreateObject("Microsoft.XMLDOM")
    %>

    brings the popup because I have not declared objXMLDoc.The popup is titled Visual Studio Just-In-Time Debugger and reads in part:

    "An unhandled exception ('Variable is undefined: 'objXmlDoc'") occurred in dllhost.exe [3496]. Just-In-Time debugging this exception failed with the following error: No installed debugger has Just-In-Time debugging enabled. In Visual Studio, Just-In-Time debugging can be enabled from Tools/Options/Debugging/Just-In-Time."

    When I click OK, I then get the 500 error in my browser as I always have.

    Before I changed the registry entry, this dialogue offered to pull up Visual Studio to debug, but I removed that from the registry, but the basic interception of the error is the same. Today, we have reinstalled .NET 1.1 and still get this error.

    Thanks.

    Thursday, March 02, 2006 12:12 AM
  • Ok, thanks. I now understand the problem. What are the values of "Auto" & "Debugger" under the AeDebug registry key?

    Habib Heydarian
    Program Manager
    Visual Studio Debugger

     

    Thursday, March 02, 2006 1:13 AM
    Owner
  • Well, we got through four hours today with MS Support and still no solution. We did check the registry values you reference. They are:

    Auto = 1

    Debugger = "C:\WINDOWS\system32\vsjitdebugger.exe" -p %ld -e %ld

    When we checked, Auto equaled 0, so we set it to 1. It did not solve the problem.

    Thanks again.

    Thursday, March 02, 2006 3:54 AM
  • Ok, I can see what's happened. vsjitdebugger.exe is the JIT debugger for VS2005 and is set as the default debugger. But obviously, you've uninstalled VS2005, so this registry key should be pointing to something else. To restore the value back to VS2003, can you change the value "Debugger" to the following:

    Debugger = ""C:\Program Files\Common Files\Microsoft Shared\VS7Debug\vs7jit.exe" -p %ld -e %ld"

    HabibH.

     

    Thursday, March 02, 2006 5:31 AM
    Owner
  • Please Habib, help me.
    I get the same error message, but when i open games:
    "An unhandled win32 exception occurred in Civlization4.exe [3980]. Just-In-Time debugging this exception failed with the following error: No installed debugger has Just-In-Time debugging enabled. In Visual Studio, Just-In_time debugging can be enabled from Tools/Options/Debugging/Just-In-Time."
     
    I am some newbie in this type of programation. Can you please tell me every step i have to do in order to solve this problem?
     
    Thanks!
    Wednesday, May 31, 2006 9:55 PM
  • I have the same problem, just not as bad...  Looks like Microsoft can't even fix there software issues. Searching the web I have found many people with this problem.   My problem is that it will run on my development systems fine but when I publish the App and install on a system that does not have 2.0 framework(app installs it) These systems get the popup.  The Jit Popup tells me the make a change in the

    <configuration>

        <system.windows.forms jitDebugging="true" />

    </configuration>


    Not sure where this is?  On my Dev system so it deploys this setting with the App or on the client system, and if on the client system Where is it and how do I change it?   I was much happier with VS6.0 I know .Net is powerfull but I am not sold on it yet.


    anyone have any idea how to stop this when I publish apps so clients that install them do not see this?

    Below is the Error from the Popup

    ************** JIT Debugging **************

    To enable just-in-time (JIT) debugging, the .config file for this

    application or computer (machine.config) must have the

    jitDebugging value set in the system.windows.forms section.

    The application must also be compiled with debugging

    enabled.

     

    For example:

     

    <configuration>

        <system.windows.forms jitDebugging="true" />

    </configuration>

     

    When JIT debugging is enabled, any unhandled exception

    will be sent to the JIT debugger registered on the computer

    rather than be handled by this dialog box.


    Wednesday, August 02, 2006 1:31 PM
  • I got the solution:

    • Right click My PC / Properties.
    • Click Advanced Tab
    • Under Performance, click Settings
    • Click Data Excecution Prevention tab
    • Select Turn on DEP for essential Windows programs and services only
    • Restart Windows

    This option is selected by default, but with installation of SQL 2005 or Visual Studio it changes and start to cause a series of trouble without any information to the user.

    Hope this help you.

    Bandolex.

    Sunday, August 13, 2006 6:11 AM
  • Thanks for the help bandolex, but this setting is already on. However, the problem persists.
    I have formatted my PC and i'm certain that the only way to solve this problem is to uninstall microsoft .NET!!
    Stupid Bill Gates with his stupid programs that makes stupid bugs...
    Wednesday, August 23, 2006 1:03 AM
  • Delete the following registry keys:
    • HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\AeDebug\Debugger

    • HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\.NETFramework\DbgManagedDebugger

    On a 64-bit operating system also delete the following registry keys:

    • HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows NT\CurrentVersion\AeDebug\Debugger

    • HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\.NETFramework\DbgManagedDebugger

    Hope this will help....

    By the way, uninstalling Microsoft .NET is not a logical solution.  If you do, other programs will be affected.

    Hmmmm.. don't blame Bill, it's the matter of analyzing how .NET work and how it has been installed.  Above solution is the best and working solution in disabling JIT.

    Thursday, September 07, 2006 2:48 AM
  • On  32 bit OS I was able to delete the WindowsNT "Debugger" key

    My  .NETFramework does not have a DbgManagedDebugger key or any other key named with the words debugger so I could not do that.

    This did Not work. Nor have any of the other posts in this thread.
    I am simply amazed that a solution has not appeared in the course of the many months that this thread has been active.

    Saturday, September 09, 2006 3:21 PM
  • yes please
    Saturday, September 23, 2006 7:15 AM
  • I have the same problem.  No suggestions discussed in this thread have been helpful.  Is there anyway to keep the debugger from killing my system's normal processes?  It kills Firefox just out of the blue for instance.  I'll have several tabs up and working on stuff, and bam!  It just pops up for no reason and kills it.  This never happened before I installed this crappy .NET software.
    Tuesday, September 26, 2006 5:40 PM
  • Well it's kinda weird... I had the very same problem you have guys, and what I did is delete registry entry (see my last post) then restart my computer.  After that, I've never seen JIT debugger.  I also did that on my 2 back up servers and it made pesky JIT away.

    By the way, I remember that I had uninstall VS2005, but JIT was still there until I deleted the registry entries and restarted my comps.

    Another thing... For those who doesn't have this entry:

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\.NETFramework\DbgManagedDebugger

    It's ok.  My 2 servers didn't have that either, but registry deletion worked just fine.  I guess the most important entry need to be deleted is the other one.

    Wednesday, September 27, 2006 5:41 AM
  • On the same boat as everyone else here with the exception that my boat has finally docked. I too have been searching the internet high and low finding 25 different things to try all without success. You are not going to believe what I did to prevent the dialog from popping up.... I renamed the vsjitdebugger.exe file in my System32 directory. BADDA-BING! NO MORE DIALOG BOXES!!! Hope that this works for everyone else out there that is having this problem.

    Good Luck!

    Thursday, November 09, 2006 7:07 PM
  • Hi an2ny 97

        I to have had the same problem with just-in-time debugger,  I have deleted the the registry keys, the just-in-time debugger does not apear but the Windows Explorer has encountered a problem and needs to close, it´s the send error report,  don´t send, box apears instead, can you please help.

    Monday, November 13, 2006 2:26 PM
  • Have you tried restarting? (I guess you did now)  Anyway, there are many factors why IE behaves that way, it could be a conflicting software or IE itself has a problem.  Try upgrading your IE to latest version (v7).  Or, reinstall IE. 

    Honestly, I've never encountered IE problem in solving JIT.  I believe your IE is corrupted or something.

    Hope that would fix it.  Any questions, let us know.

    Tuesday, November 14, 2006 1:24 AM
  • i alrady tried all the things shows in this topic, i still get errors, or the "send/don't send report" report. specialy when i run games like NFS carbon:

    "an unhandled win32 exception occurred in NFSC.exe [1668]."

    2post above, you talked about renaming  vsjitdebugger.exe ...  into what? doesnt matter?

    doesn't somebody has a good solution?

    i'm also running VS2005 , disabled the JIT options, removed the keys, installed dr walson(or something) removed it again, etc.

    please help

    Wednesday, November 22, 2006 1:52 PM
  • Hi,

    I had the same issue until I realized that my admin-user account had been locked out. After unlocking it the JIT error message disappeared.

     

    Cheers, Greg

    Tuesday, November 28, 2006 4:49 PM
  • Hi,

    I had the same issue until I realized that my user account had been locked out. After unlocking it the JIT error message disappeared.

     

    Cheers, Greg

    Tuesday, November 28, 2006 4:49 PM
  • Just in case no one found this, there is a MS KB that addresses this problem at http://support.microsoft.com/default.aspx/kb/923827

    Method 1: Re-enable the Dr. Watson program to catch unhandled exceptions

    You can re-enable the Dr. Watson program to catch unhandled exceptions. After you do this, the Visual Studio JIT debugger will no longer catch unhandled exceptions. To do this, follow these steps:

    1. Click Start, click Run, type cmd, and then click OK.
    2. Type the following command, and then press ENTER:
    drwtsn32 -i

     

    • Proposed as answer by Alex Thomas Monday, May 24, 2010 2:36 AM
    Friday, December 08, 2006 10:19 PM
  • I had the same problem with JIT.  Reinstalling DR Watson did the trick.
    Monday, January 01, 2007 7:43 PM
  • Hi All!

    I've a new work (with Sybase PowerBuilder 10.5) and when i try to work (actually edit an existing DataWindow object) the PB throw the known message.
    I don't installed MS VS, or MS .net framework 2.0, i just try working in PowerBuilder, so I don't know what can I do.

    I ran  "drwtson32 -i" and it cause i have an errormessage from dr. watson, not a "just-in-time debugging" message, but editing a DataWindow doesn't work. Running is ok.


    Can anybody help me?

    Thx.
    Wednesday, January 03, 2007 3:18 PM
  • If the above solutions didn't work, Can we just delete this file "C:\WINDOWS\system32\vsjitdebugger.exe" ??? just curious =)
    Friday, January 19, 2007 8:35 AM
  • I also had this problem and tried renaming vsjitdebugger.exe to vsjitdebugger_disabled.exe and the prompts immediately ceased. Don't know the negative ramifications of this change yet as I still need to use VS2005, but the JIT prompts were very annoying.
    Wednesday, January 24, 2007 4:13 AM
  • Microsoft Gurus - any offical solution on this topic to prevent IE 7.0 from crashing?  I have similar settings with others, i.e. VS2005, .net2.0 installed in my machine and IE keeps crashing out many times during a day...
    Wednesday, January 31, 2007 8:31 PM
  • All, I am coming across the same problem and it's very frustrating.

    I understand that unhandled exceptions are being thrown, but what I don't understand is that some programs were never crashing before, so it was as if these exceptions were getting ignored.

    Is there some way to get back to this behavior?

    Dr. Watson doesn't help (it's just a different dialog box that comes up now), and renaming vsjitdebugger doesn't help either (it just says there's an unhandled win32 exception).

    Thanks!
    Tuesday, March 20, 2007 9:16 AM
  • I think there may be a number of issues being talked about in this thread:

    1) People want to be able to turn off JIT debugging (either because we didn't remove it when uninstalling, or they just don't want to see it). Please refer to post - http://forums.microsoft.com/MSDN/ShowPost.aspx?PostID=919407&SiteID=1 and scroll down to the Error Messages section. It talks about what to do to turn off jit debugging.

    2) People want the Dr. Watson behavior but not the VsJitDebugger behavior. Please refer to post - http://forums.microsoft.com/MSDN/ShowPost.aspx?PostID=919407&SiteID=1 and scroll down to the Error Message section. There is a link there talking about how to reenable Dr. Watson.

    3) People have unhandled exceptions in their application and don't want to be bothered about them. Assuming you turn off the JIT debugger, you can turn this setting off in Windows (at least XP) by following the steps here: http://support.microsoft.com/kb/310414/. This will still show a message box when an unhandled exception occurs, but you won't get the "Send to Microsoft" error dialog.

    • Proposed as answer by cassandradvb Wednesday, April 29, 2009 4:29 PM
    Tuesday, March 20, 2007 8:22 PM
    Moderator
  • 3) People have unhandled exceptions in their application and don't want to be bothered about them. Assuming you turn off the JIT debugger, you can turn this setting off in Windows (at least XP) by following the steps here: http://support.microsoft.com/kb/310414/. This will still show a message box when an unhandled exception occurs, but you won't get the "Send to Microsoft" error dialog.
     

     

    This is the problem...

    We can't use now programs that used to work on our computer.

    Something is wrong with the debugger.

    Tuesday, March 27, 2007 10:55 PM
  •  KfirF wrote:

    3) People have unhandled exceptions in their application and don't want to be bothered about them. Assuming you turn off the JIT debugger, you can turn this setting off in Windows (at least XP) by following the steps here: http://support.microsoft.com/kb/310414/. This will still show a message box when an unhandled exception occurs, but you won't get the "Send to Microsoft" error dialog.

    This is the problem...

    We can't use now programs that used to work on our computer.

    Something is wrong with the debugger.



    I agree -- in several cases, I was never even receiving the unhandled exception dialog. It's as if the installation of JIT changed this behavior.
    Wednesday, March 28, 2007 1:29 AM
  • Windows doesn't add anything to your application because a JIT debugger is installed. It simply makes a check when a unhandled exception occurs. It was making this check before the debugger was installed, the check just went nowhere.

     

    What might be happening is other software that was installed with Visual Studio could be causing the problem. Such as the .NET framework, or IE helper objects (shared dlls that get installed along with the debugger).

     

    If you have new unhandled exceptions with a particular application, I'd suggest logging issues against those applications. The easiest way to do that is when the Send Information to Microsoft comes up, click the send button.

    Wednesday, March 28, 2007 11:16 AM
    Moderator
  • In most cases I'm not getting the option to send a report. I just get the error messege & the Close button.

    I even tried re-installing some of the programs but it didn't help.

    Windows doesn't add anything to your application because a JIT debugger is installed. It simply makes a check when a unhandled exception occurs

    If nothing is added so how is it possible that the errors started to accur & the programs started to crash only after I installed Visual Studio ?

    Something is causing these crashes & it's defenetly the debugger that causes them.

     

    Wednesday, March 28, 2007 4:42 PM
  • The debugger/Visual Studio does install a number of shared dlls. Updating/Changing one of these dlls may have caused another application to crash - hence causing your problem. Even uninstalling Visual Studio may not have put these dlls back in their original state.

     

    If you can't get to the Send button anymore, another way to log bugs against Visual Studio is through the connect website. Specifically go to https://connect.microsoft.com/VisualStudio (requires a live id to log a bug).

     

    If you do log a bug, please provide as much information as possible about the crash. A crash dump is the best (of course this would require a debugger being installed ), but please put

    • the name and version of the exe that crashed
    • the steps you took that caused the problem
    • what version of Visual Studio you had originally installed
    • Screenshots of the app crashing (can help sometimes)
    • Any other information you know about what went wrong.

    The more information you provide, the more likely we'll be to repro and then fix.

     

    You can of course post that same information here, but going through connect is more likely to get a fix to your problem.
    Wednesday, March 28, 2007 6:34 PM
    Moderator
  • When I make the screenshots, what is better ?

    To make them when the just in debugger is on in the visual studio & the debugger pops up when the error occurs or when the just in debugger is off & when I run the program I get the error screen.

    Thursday, March 29, 2007 12:07 PM
  • The best thing to do is to not use a screen shot, but use a crash dump .

     

    So with the JIT debugger unstalled, when the jit debugger window pops up, attach the debugger. Then when the debugger breaks into the program, generate a crash dump. Upload this crash dump to the connect bug.

     

    For more information on generating a crash dump go here:

    http://msdn2.microsoft.com/en-us/library/fk551230(VS.80).aspx

     

    Alternatively if you can't or don't want to save a crash dump, at least attach the debugger (through the JIT debugging dialog), and copy the callstack window contents when the debugger breaks. Post this callstack to the connect issue.

     

     

     

    Thursday, March 29, 2007 3:55 PM
    Moderator
  • I posted here quite a while ago. None of the suggestions worked. Then I installed Microsoft Office 2007 Trial and the JIT debugger message has no longer appeared...
    Friday, March 30, 2007 2:09 PM
  • I seem to have the same problem. After I installed VS2005, all my applications started crashing -- especially after invoking WinHelp for a number of applications. I can reproduce the problem every time by: 1) starting WinHelp by clicking Help on the menu of an application, 2) clicking the WinHelp Search tab, 3) entering a keyword to find, 4) clicking the List Topics button, and finally 5) Closing WinHelp. After closing WinHelp, I get the error: “An Unhandled win32 exception occurred in <application name>.exe” When I click OK (or NO if the JIT Debugger is running) the application immediately crashes and I lose all my work.

     

    If I do the same thing by going to the operating system’s (Windows 2000) help via system Start menu. I get: “An Unhandled win32 exception occurred in hh.exe

     

    This happens whether the JIT debugger is on or off; and, I want to emphasize that this problem started only after installing VS2005 professional Edition.

     

    At first I thought the problem was with an upgraded application I recently installed (OmniPage V15,) but then I discovered that the same thing was happening with other applications from other vendors -- including Windows2000 itself.

     

    In fact, I just tried it with Microsoft's Notepad.exe, and it happens there to -- i.e. I click help, then help Topics, click Search, enter somthing to search, then click List Topics, then close the help, and then Notepad.exe crashed after giving me the "unhandled win32 exception exception occurred in Notepad.exe" message.


     

     

    Wednesday, April 04, 2007 3:12 AM
  • thank you this ended my error messages from VS2005 just in time debugger.  Now my next problem is can someone lead me to either an all inclusive program, or multiple programs for

     

    a) fixing my IE version 7.0.5730.11 (when i search google it shows results but when i click it takes me to other search websites, rather than the site i looked up. EX. I searched for "just in time debugger" and it returns all useful sites, i click the first, msdn2.microsoft.com/en-us/library/k7d53k7e.aspx, but it takes me to http://www.findstuff.com/search.php?query=error&source=eh )

     

    b) a set of video codec's that are all inclusive, I keep haveing video files with normal extentions crashing, I use media player classic with the k-lite bundle

     

    c) random files in my computer crash the folder that open, it mostly occures in my school work folders full of open office documents, and a few open office spread sheets.  I enter that folder either normally or while trying to save something, and one or both crash when the folder is accessed.

     

    any and all help would be greatly appreciated.

    Wednesday, April 11, 2007 6:34 AM
  •  

    I went to the submit feedback section.

    https://connect.microsoft.com/VisualStudio/feedback/ViewFeedback.aspx?FeedbackID=271150

    They didn't help me at all & closed my thread without helping.

    How can I re-open it ?


    Saturday, April 28, 2007 8:11 PM
  • It looks like it was closed as no repro. You're best bet would be to contact the vendors of the programs that crashed.
    Monday, April 30, 2007 4:27 PM
    Moderator
  • Please read again my report there.

    The support person didn't install the right program.

    I wrote there that program X crashed & he downloaded program Y & tried running it.

    You're best bet would be to contact the vendors of the programs that crashed.

    Again, like I wrote before - The program worked perfectly on my computer with no errors, it started crashing & asking me to debug only after I installed Visual Studio

    Monday, April 30, 2007 10:57 PM
  • Here's the direct link and instructions on how to disable Just-In-Time Debugging.

    http://msdn2.microsoft.com/en-us/library/k8kf6y2a.aspx

    To enable/disable Just-In-Time debugging

    1.   Open Visual Studio
    2. On the Tools menu, click Options.

    3. In the Options dialog box, select the Debugging folder.

    4. In the Debugging folder, select the Just-In-Time page.

    5. In the Enable Just-In-Time debugging of these types of code box, select or clear the relevant program types: Managed, Native, or Script.

      To disable Just-In-Time debugging, once it has been enabled, you must be running with Administrator privileges. Enabling Just-In-Time debugging sets a registry key, and Administrator privileges are required to change that key.

    6. Click OK.

    Tuesday, May 01, 2007 4:31 PM
  • I got the same problem, and they are only for the programs I've installed after visual studio professional, everything else works fine. I talked to my friends and they said you shouldn't press yes when the debugger comes up but disabled the JIT options, removed the keys and installed dr walson immediatedly. When you press yes it really screws up the programs, I think I'll probably reboot my computer.
    Thursday, May 24, 2007 10:15 AM
  • Thanks in advance for your kind support. I updated the post and include this debugging result. As I mentioned , I format my Labtop and install again all programs. When I got the internet connection I installed SQL Server 2005 at the first programj, taking care the others products could bother the installation. I would appreciate your help becaus this is affecting seriously my work.

     

    'IEXPLORE.EXE': Loaded 'C:\Program Files\Internet Explorer\IEXPLORE.EXE', No symbols loaded.
    'IEXPLORE.EXE': Loaded 'C:\WINDOWS\system32\ntdll.dll', No symbols loaded.
    'IEXPLORE.EXE': Loaded 'C:\WINDOWS\system32\kernel32.dll', No symbols loaded.
    'IEXPLORE.EXE': Loaded 'C:\WINDOWS\system32\msvcrt.dll', No symbols loaded.
    'IEXPLORE.EXE': Loaded 'C:\WINDOWS\system32\user32.dll', No symbols loaded.
    'IEXPLORE.EXE': Loaded 'C:\WINDOWS\system32\gdi32.dll', No symbols loaded.
    'IEXPLORE.EXE': Loaded 'C:\WINDOWS\system32\shlwapi.dll', No symbols loaded.
    'IEXPLORE.EXE': Loaded 'C:\WINDOWS\system32\advapi32.dll', No symbols loaded.
    'IEXPLORE.EXE': Loaded 'C:\WINDOWS\system32\rpcrt4.dll', No symbols loaded.
    'IEXPLORE.EXE': Loaded 'C:\WINDOWS\system32\shdocvw.dll', No symbols loaded.
    'IEXPLORE.EXE': Loaded 'C:\WINDOWS\system32\crypt32.dll', No symbols loaded.
    'IEXPLORE.EXE': Loaded 'C:\WINDOWS\system32\msasn1.dll', No symbols loaded.
    'IEXPLORE.EXE': Loaded 'C:\WINDOWS\system32\cryptui.dll', No symbols loaded.
    'IEXPLORE.EXE': Loaded 'C:\WINDOWS\system32\wintrust.dll', No symbols loaded.
    'IEXPLORE.EXE': Loaded 'C:\WINDOWS\system32\imagehlp.dll', No symbols loaded.
    'IEXPLORE.EXE': Loaded 'C:\WINDOWS\system32\oleaut32.dll', No symbols loaded.
    'IEXPLORE.EXE': Loaded 'C:\WINDOWS\system32\ole32.dll', No symbols loaded.
    'IEXPLORE.EXE': Loaded 'C:\WINDOWS\system32\netapi32.dll', No symbols loaded.
    'IEXPLORE.EXE': Loaded 'C:\WINDOWS\system32\wininet.dll', No symbols loaded.
    'IEXPLORE.EXE': Loaded 'C:\WINDOWS\system32\wldap32.dll', No symbols loaded.
    'IEXPLORE.EXE': Loaded 'C:\WINDOWS\system32\version.dll', No symbols loaded.
    'IEXPLORE.EXE': Loaded 'C:\WINDOWS\WinSxS\x86_Microsoft.Windows.Common-Controls_6595b64144ccf1df_6.0.2600.2982_x-ww_ac3f9c03\comctl32.dll', No symbols loaded.
    'IEXPLORE.EXE': Loaded 'C:\WINDOWS\system32\shell32.dll', No symbols loaded.
    'IEXPLORE.EXE': Loaded 'C:\WINDOWS\system32\comctl32.dll', No symbols loaded.
    'IEXPLORE.EXE': Loaded 'C:\WINDOWS\system32\uxtheme.dll', No symbols loaded.
    'IEXPLORE.EXE': Loaded 'C:\WINDOWS\system32\SynTPFcs.dll', Binary was not built with debug information.
    'IEXPLORE.EXE': Loaded 'C:\WINDOWS\system32\browseui.dll', No symbols loaded.
    'IEXPLORE.EXE': Loaded 'C:\WINDOWS\system32\browselc.dll', Binary was not built with debug information.
    'IEXPLORE.EXE': Loaded 'C:\WINDOWS\system32\apphelp.dll', No symbols loaded.
    'IEXPLORE.EXE': Loaded 'C:\WINDOWS\system32\clbcatq.dll', No symbols loaded.
    'IEXPLORE.EXE': Loaded 'C:\WINDOWS\system32\comres.dll', No symbols loaded.
    'IEXPLORE.EXE': Loaded 'C:\WINDOWS\system32\secur32.dll', No symbols loaded.
    'IEXPLORE.EXE': Loaded 'C:\WINDOWS\system32\cscui.dll', No symbols loaded.
    'IEXPLORE.EXE': Loaded 'C:\WINDOWS\system32\cscdll.dll', No symbols loaded.
    'IEXPLORE.EXE': Loaded 'C:\WINDOWS\system32\setupapi.dll', No symbols loaded.
    'IEXPLORE.EXE': Loaded 'C:\WINDOWS\system32\urlmon.dll', No symbols loaded.
    'IEXPLORE.EXE': Loaded 'C:\Program Files\TEXTware\QUICKfind\PlugIns\IEHelp.dll', Binary was not built with debug information.
    'IEXPLORE.EXE': Loaded 'C:\WINDOWS\system32\olepro32.dll', No symbols loaded.
    'IEXPLORE.EXE': Loaded 'C:\WINDOWS\system32\sxs.dll', No symbols loaded.
    'IEXPLORE.EXE': Loaded 'C:\WINDOWS\system32\xpsp2res.dll', Binary was not built with debug information.
    'IEXPLORE.EXE': Loaded 'C:\WINDOWS\system32\shdoclc.dll', Binary was not built with debug information.
    'IEXPLORE.EXE': Loaded 'C:\WINDOWS\system32\mlang.dll', No symbols loaded.
    'IEXPLORE.EXE': Loaded 'C:\WINDOWS\system32\wsock32.dll', No symbols loaded.
    'IEXPLORE.EXE': Loaded 'C:\WINDOWS\system32\ws2_32.dll', No symbols loaded.
    'IEXPLORE.EXE': Loaded 'C:\WINDOWS\system32\ws2help.dll', No symbols loaded.
    'IEXPLORE.EXE': Loaded 'C:\WINDOWS\system32\mswsock.dll', No symbols loaded.
    'IEXPLORE.EXE': Loaded 'C:\WINDOWS\system32\hnetcfg.dll', No symbols loaded.
    'IEXPLORE.EXE': Loaded 'C:\WINDOWS\system32\wshtcpip.dll', No symbols loaded.
    'IEXPLORE.EXE': Loaded 'C:\WINDOWS\system32\rasapi32.dll', No symbols loaded.
    'IEXPLORE.EXE': Loaded 'C:\WINDOWS\system32\rasman.dll', No symbols loaded.
    'IEXPLORE.EXE': Loaded 'C:\WINDOWS\system32\tapi32.dll', No symbols loaded.
    'IEXPLORE.EXE': Loaded 'C:\WINDOWS\system32\rtutils.dll', No symbols loaded.
    'IEXPLORE.EXE': Loaded 'C:\WINDOWS\system32\winmm.dll', No symbols loaded.
    'IEXPLORE.EXE': Loaded 'C:\WINDOWS\system32\msv1_0.dll', No symbols loaded.
    'IEXPLORE.EXE': Loaded 'C:\WINDOWS\system32\iphlpapi.dll', No symbols loaded.
    'IEXPLORE.EXE': Loaded 'C:\WINDOWS\system32\sensapi.dll', No symbols loaded.
    'IEXPLORE.EXE': Loaded 'C:\WINDOWS\system32\userenv.dll', No symbols loaded.
    'IEXPLORE.EXE': Loaded 'C:\WINDOWS\system32\dnsapi.dll', No symbols loaded.
    'IEXPLORE.EXE': Loaded 'C:\WINDOWS\system32\rasadhlp.dll', No symbols loaded.
    'IEXPLORE.EXE': Loaded 'C:\WINDOWS\system32\mshtml.dll', No symbols loaded.
    'IEXPLORE.EXE': Loaded 'C:\WINDOWS\system32\msls31.dll', No symbols loaded.
    'IEXPLORE.EXE': Loaded 'C:\WINDOWS\system32\psapi.dll', No symbols loaded.
    'IEXPLORE.EXE': Loaded 'C:\WINDOWS\system32\MSIMTF.dll', No symbols loaded.
    'IEXPLORE.EXE': Loaded 'C:\WINDOWS\system32\MSCTF.dll', No symbols loaded.
    'IEXPLORE.EXE': Loaded 'C:\WINDOWS\system32\imm32.dll', No symbols loaded.
    'IEXPLORE.EXE': Loaded 'C:\Program Files\Microsoft Office\OFFICE11\MSOHEV.DLL', No symbols loaded.
    'IEXPLORE.EXE': Loaded 'C:\WINDOWS\system32\jscript.dll', No symbols loaded.
    'IEXPLORE.EXE': Loaded 'C:\WINDOWS\system32\iepeers.dll', No symbols loaded.
    'IEXPLORE.EXE': Loaded 'C:\WINDOWS\system32\winspool.drv', No symbols loaded.
    'IEXPLORE.EXE': Loaded 'C:\WINDOWS\system32\Macromed\Flash\Flash9c.ocx', No symbols loaded.
    'IEXPLORE.EXE': Loaded 'C:\WINDOWS\system32\comdlg32.dll', No symbols loaded.
    'IEXPLORE.EXE': Loaded 'C:\WINDOWS\system32\msxml6.dll', No symbols loaded.
    'IEXPLORE.EXE': Loaded 'C:\WINDOWS\system32\mshtmled.dll', No symbols loaded.
    'IEXPLORE.EXE': Loaded 'C:\WINDOWS\system32\dxtrans.dll', No symbols loaded.
    'IEXPLORE.EXE': Loaded 'C:\WINDOWS\system32\atl.dll', No symbols loaded.
    'IEXPLORE.EXE': Loaded 'C:\WINDOWS\system32\ddrawex.dll', No symbols loaded.
    'IEXPLORE.EXE': Loaded 'C:\WINDOWS\system32\ddraw.dll', No symbols loaded.
    'IEXPLORE.EXE': Loaded 'C:\WINDOWS\system32\dciman32.dll', No symbols loaded.
    'IEXPLORE.EXE': Loaded 'C:\WINDOWS\system32\vbscript.dll', No symbols loaded.
    'IEXPLORE.EXE': Loaded 'C:\WINDOWS\system32\mfc42.dll', No symbols loaded.
    'IEXPLORE.EXE': Loaded 'C:\WINDOWS\system32\schannel.dll', No symbols loaded.
    'IEXPLORE.EXE': Loaded 'C:\WINDOWS\system32\mpr.dll', No symbols loaded.
    'IEXPLORE.EXE': Loaded 'C:\WINDOWS\system32\drprov.dll', No symbols loaded.
    'IEXPLORE.EXE': Loaded 'C:\WINDOWS\system32\ntlanman.dll', No symbols loaded.
    'IEXPLORE.EXE': Loaded 'C:\WINDOWS\system32\netui0.dll', No symbols loaded.
    'IEXPLORE.EXE': Loaded 'C:\WINDOWS\system32\netui1.dll', No symbols loaded.
    'IEXPLORE.EXE': Loaded 'C:\WINDOWS\system32\netrap.dll', No symbols loaded.
    'IEXPLORE.EXE': Loaded 'C:\WINDOWS\system32\samlib.dll', No symbols loaded.
    'IEXPLORE.EXE': Loaded 'C:\WINDOWS\system32\davclnt.dll', No symbols loaded.
    'IEXPLORE.EXE': Loaded 'C:\WINDOWS\system32\msgina.dll', No symbols loaded.
    'IEXPLORE.EXE': Loaded 'C:\WINDOWS\system32\winsta.dll', No symbols loaded.
    'IEXPLORE.EXE': Loaded 'C:\WINDOWS\system32\odbc32.dll', No symbols loaded.
    'IEXPLORE.EXE': Loaded 'C:\WINDOWS\system32\odbcint.dll', Binary was not built with debug information.
    'IEXPLORE.EXE': Loaded 'C:\WINDOWS\system32\imgutil.dll', No symbols loaded.
    'IEXPLORE.EXE': Loaded 'C:\WINDOWS\system32\pngfilt.dll', No symbols loaded.
    'IEXPLORE.EXE': Loaded 'C:\Program Files\Common Files\Microsoft Shared\OFFICE11\MSXML5.DLL', No symbols loaded.
    'IEXPLORE.EXE': Loaded 'C:\WINDOWS\system32\dxtmsft.dll', No symbols loaded.
    The thread 'Win32 Thread' (0x70c) has exited with code 0 (0x0).
    Unhandled exception at 0x7c812a5b in IEXPLORE.EXE: 0x0EEDFADE: 0xeedfade.

    Monday, May 28, 2007 12:06 AM
  • HELP ! im trying to play my NFSC but keep getting 'NFSC.exe. not working'on my new Vista computer.
    Tuesday, May 29, 2007 8:10 PM
  • I am having the same problem. In my system, both of Visual Studio 6 and Visual Studio 2005 are installed. After I performed ASP debug in Visual Studio 6, and even after detaching the processors from VS 6 and setting the advanced option in Internet Explorer not to use any script debuggers, I am getting this Just-In-Debugging pop-ups.

    I followed one of the instructions and removed both of the "Debugger" key and "DbgManagerDebbuger" key, but still I am getting the same pop-ups. It is really frustrating...

     

    Wednesday, May 30, 2007 8:45 PM
  • is this still active.

     

    can somebody share the solution.

     

    regards

    sahridhayan

    Thursday, August 02, 2007 4:28 AM
  • If you still have VS 2005, just go to Tools->Options->Debugging->Just-In-Time, then uncheck all the checkboxes.

     

    Wednesday, August 15, 2007 6:14 AM
  •  

    What if I don't have VS 2005?  I had the trial version installed, then uninstalled it when I obtained VB Express Edition.  I didn't realize all the havoc this would wreak. Anyway, how can I disable JIT debugging without VS 2005?
    Thursday, August 30, 2007 7:17 PM
  • Sorry for bringing this up again. Can someone post their values for the following registry key.
    • HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\AeDebug\Debugger

    • HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\.NETFramework\DbgManagedDebugger

    I deleted them and would like to reenter them back in.

    Friday, September 14, 2007 7:35 PM
  • HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\AeDebug\Debugger =   "C:\WINDOWS\system32\vsjitdebugger.exe" -p %ld -e %ld

     

    and

     

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\.NETFramework\DbgManagedDebugger =

    "C:\WINDOWS\system32\vsjitdebugger.exe" PID %d APPDOM %d EXTEXT "%s" EVTHDL %d
    Wednesday, September 19, 2007 7:06 PM
  • Thank You pvbntnbl
    Wednesday, September 19, 2007 7:39 PM
  • This is what finally worked for me:

    Open Microsoft Word.  Go to tools|macro|microsoft script editor.  in script editor, go to tools|options|debugging.  click "JIT Settings". Clear the checkbox for "JIT DEbugging"

    I found the above solution near the bottom of this thread:

    http://weblogs.asp.net/fmarguerie/archive/2004/08/27/221428.aspx

    HTH

       -- hugh


    Tuesday, October 30, 2007 12:37 AM
  •  

    Thanks Anthony,

    Your solution is working..

     

    Wednesday, December 19, 2007 11:35 AM
  • I have read the whole 4 pages and no solution worked for me

    *** u Micrsoft and ur Stupid Visual Studio
    Tuesday, January 01, 2008 9:27 AM
  • Believe it or not, your post got me thinking.  I recently enabled a screensaver with password protect under control panel > display.  I removed the password protect and things are back to normal.  Looks like a weird bug.  I used to get weird bugs in Visual Studio sometims when my password was close to expiring on my machine a few years back at my old job.  I changed the password and the bug went away.

     

    Wednesday, January 09, 2008 5:21 PM
  •  

    Wednesday, January 09, 2008 5:21 PM
  • Renamed to vsjitdebugger_disabled.exe and it worked like a charm.
    Wednesday, February 27, 2008 8:35 PM
  • Hi,

      

    I m tired off with same JIT debugger problem. In ASP web application, when ever some error comes, it is just blocking all users to access any application of that server, until we click YES / NO for the popup dialog of the JIT debugger.

     

     

    I tried all the 3 solutions replied in this post

     

    1.

                1) In Internet Explorer, select Tools -> Options

                2) On the Internet Options dialog, go to the Advanced tab

                3) Make sure that both of these options are checked:

     

                X Disable Script Debugging (Internet Explorer)

                X Disable Script Debugging (Other)

     

    2.

                Right click My PC / Properties.

                Click Advanced Tab

                Under Performance, click Settings

                Click Data Execution Prevention tab

                Select Turn on DEP for essential Windows programs and services only

                Restart Windows

    3.

                Delete the following registry keys:

     

                HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\AeDebug\Debugger

                HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\.NETFramework\DbgManagedDebugger

     

     

    I could not found any change in the result. I m still having same problem even after trying them. Can any one reply exact solution

    Friday, February 29, 2008 5:55 AM
  • bvdrsganesh1404,

     

    If yours is a 64 bit operating system additionally delete these registry keys

    • HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows NT\CurrentVersion\AeDebug\Debugger

    • HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\.NETFramework\DbgManagedDebugger

    http://blogs.msdn.com/shawnfa/archive/2004/07/15/184490.aspx has information about what happens when an unhadled exception occurs.

     

    Thanks

    Karthik

    Friday, February 29, 2008 8:38 AM
    Moderator
  • I THINK I FOUND A SOLUTION, see if this works.

     

    When the program has a JIT error say "Yes" to debugging. Once you get a chance select break to stop the debugging action. Then inside of the Microsoft Script editor go to "Tools" and select Debugging.

    Select "JIT Settings" just deselect "Enable JIT Setting"

     

    You can also open the generic Microsoft Script Editor

    from C:\Program Files\Microsoft Office\OFFICE11\mse7.exe

     

    Good Luck, i was working on this for two days i had a user that got a JIT error every time she opened a contact in Outlook with an attachment.

     

    Once I did this JIT ceased to exist.

    Thursday, March 06, 2008 2:13 AM

  • Hi

    You just hope this will help. you are not sure what will happened. If you have not tried yourself why you give advice to others. you know what you have done to me. i did what you said and guess what has happened to my computer. I can not play anything by Real Player of Media Player.

    Now do you have anything to say. how can i fix or you will say recover or what can you say. i dont want to install again the windows if you have said to delete the registry files then you may have solution for the consequences too.

    Please let me know as soon as possible

    tanx
    shouaib
    Wednesday, March 12, 2008 4:17 PM
  • http://forums.microsoft.com/forums/showpost.aspx?postid=2993488&siteid=1&sb=0&d=1&at=7&ft=11&tf=0&pageid=0

     

    Shaouaib,

    we do have this term "BACKUP"... We know that dealing with windows' registry is serious business specially if you are not familiar and don't know what and how does it works.  It's like, do it at your own risk...  If you are not sure about it, there's always a way to fix it up when you screwed up..  BACKUP the registry you are dealing with..

     

    For your simple problem about real player... Just uninstall and reinstall media player.. that's it.  That will renew a part of registry this software uses and reinstall codecs.  Also, I don't think the registry that need to be deleted has connection with media player.. It's registry created by .NET

     

    the original post was posted way way back to 2006.. above is the link.   Also, I tested it (32bit machines) but couldn't cnfrm for 64bit machine.  But Im sure that will work as it worked for me.  Also, im not only dealing with 1 machine, dozen of machines where fixed using the same method.. so I don't think it's just a coinsedence.

     

    cheer up.. Any problem, let us help.

    Thursday, March 13, 2008 7:11 AM
  • This is so Microsoft:

    I Handled That dumb error (PROGRAMMING ERROR NOTHING ELSE) that makes your JIT Fail after installing VS 2005. The Microsoft smelling thing about it is: WINDOWS Avoids DrWatson to Stay the JIT, so the Error occurs every half an hour. You have to drwtsn32 -i loggoff and login again. Isnt it Sick? And even the Company isnt able to help us  --- GO UBUNTU !!!!!!!!!!!!!!!!!!!!!!!!!
    Monday, June 02, 2008 6:49 PM
  • I have VS 2005 installed and I installed TOAD for Oracle.  I was having the problem of "unhandled win32 exception occurred in TOAD.exe".   I changed the performance option as you mentioned and rebooted the computer. 

    IT WORKED!!!  Thanks a lot. 

    VS 2005 probably changed this value but why should this cause errors?  It should atleast let the user know that this value is being changed and it may impact other programs.

    padam
    Monday, August 11, 2008 3:31 PM
  • Thanks to all the Microsoft patches that were downloaded to my PC this morning, I began getting errors every time I tried to open a SharePoint list:

    "Internet Explorer has encountered a problem and needs to close.  We are sorry for the inconvenience."

     Others were experiencing the problem when opening any SharePoint document.

    The fix was to go into my Microsoft Office 2007 folder on my C: drive and rename a dll.

    Steps:

    Go to   C:\Program Files\Microsoft Office\Office12

    Rename OWSSUPP.DLL   to   OWSSUPP.DLL.Latestversion

    The root problem was that my pc is running Office 2003 but has installed a 2007 program.  The OWSSUPP.dll program from the 2007 folder is registered over the one in the 2003 folder.

    If you rename the OWSSUPP.dll in the 2007 folder (C:\Program Files\Microsoft Office\Office12) then the one from the 2003 folder (C:\Program Files\Microsoft Office\Office11) will be used.

    This is the reference for the fix:
    http://geekswithblogs.net/redwards/archive/2007/06/18/113287.aspx
     

    Please let me know if you are experiencing any problems with SharePoint this week.

     

    Friday, October 31, 2008 5:44 PM
  •  
    bvdrsganesh1404 said:

    Hi,

      

    I m tired off with same JIT debugger problem. In ASP web application, when ever some error comes, it is just blocking all users to access any application of that server, until we click YES / NO for the popup dialog of the JIT debugger.


    Hello folks,

     

    I wonder if any one found a solution in response to the problem posted by bvdrsganesh1404.

     

    Here is my case:

     

    Upgraded from XP to Vista Ultimate.

    Have Visual Studio 6 and Visual Web Developer 2005 Express.

     

    Immediately after upgrade, ANY error in ASP code running on Vista IIS7 results in JIT pop-up. After closing the pop-up, error 500 displays on a page as it normally should.

     

    Now, I DO NOT wish to completely disable JIT as it comes handy for client side javascript debugging.

     

    I ONLY need to disable it in IIS7 and prevent IIS locking.

     

    I’ve been trying to fix that on and off in the past couple of month. All unsuccessful!! I just do not believe, there is no solution to this.

     

    Appreciate any response.

     

    Tuesday, January 20, 2009 9:10 PM
  • HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\.NETFramework\DbgManagedDebugger

    that isn't there to get rid of
    no one I know even know what this is
    I can no longer use most of my programs
    I am so fed up with this
    I' ve beentrying to get this remedied
    I just can't get rid of this thing
    i also cannot find any dialog box
    it doesnt exist
    Wednesday, April 29, 2009 4:18 PM
  • did this
    my programs still won't work
    Wednesday, April 29, 2009 4:19 PM
  • didn't work
    Wednesday, April 29, 2009 4:22 PM
  • HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\.NETFramework\DbgManagedDebugger

    this is not even there to delete
    Wednesday, April 29, 2009 4:23 PM
  • how do you  rename it?
    Wednesday, April 29, 2009 4:26 PM
  • how do you know its locked
    and how do you unlock it
    Wednesday, April 29, 2009 4:28 PM
  • i do not care how many times I am told to go to the dialog box
    THERE ISN'T ONE THERE
    i've been at this for weeks
    ands I am ticked and very tired
    Wednesday, April 29, 2009 4:32 PM
  • where do I find microsoft word now
    told you I was tired
    i can't find anything
    Wednesday, April 29, 2009 4:38 PM
  • I tried but I am getting following error.

    The instruction at "0x05b50068" refered memory at "0x05b50068",The memory could not be "written".
    Click OK to terminate the program
    Monday, May 25, 2009 3:08 PM
  • go to the following registry key "HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\.NETFramework" and delete key "DbgManagedDebugger"

    http://debuggingblog.com
    Saturday, May 30, 2009 8:13 AM
  • Got to Administrative tools-Services.

    disable the machine debugging (it will say it's related to visual studio).

    Selecting properties will give you the options.
    • Proposed as answer by OCG Saturday, September 11, 2010 8:50 PM
    Tuesday, August 11, 2009 2:58 PM
  • That worked. Tried all the others but the error was still popping up. Didn't even have to reboot.

    Got to Administrative tools-Services.

    disable the machine debugging (it will say it's related to visual studio).

    Selecting properties will give you the options.
    • Proposed as answer by ducati-mad Friday, November 27, 2009 12:11 PM
    Monday, September 21, 2009 4:01 AM
  • All the proposed fixes are at the front end. If we got to the back end i.e. the dialogue itself, we can easily knobble it.
    This fix is only for those who are not worried why the JIT has been called, but just want the darn dialogue to go away (as I did).
    Also if this has other implications for you, just take it on the chin and try something else.

    Fix
    Like all dialogues the JIT one also has a programme which displays it, and this programme is called vsjitdegguer.exe.

    It lives (on windows 2000) at this address  "c:\WINNT\system32\vsjitdebugger.exe".

    Simply rename it to something like "vsjitdebuggerDISABLED.exe"

    Now when the registry references to the programme are used to start it, it will not be found.

    Windows is smart enough (just it seems) not to crash or put up another dialogue telling us it can not find the resource and goes merrily about its work.

    It also works on XP

    JD   (that's "job done" as they say in the building trade)

    Friday, November 27, 2009 12:34 PM
  • I tried prety much everything mentioned in this thread and nothing helped to. Including deleting vsjitdebugger.exe, deleting registry keys etc. I'm asking myself - how is it even possible that even if I delete program that is suppose make this error messages it doesn't even change the error message! Its still absolutely the same! My error message looks like this: Is it the error message generated by visual studio or is it suppose to look diferent? I'm using Windows Vista Home Premium (32bit). Also I did have Visual studio installed, but along with trying to get rid of this error I uninstalled it.
    Thursday, February 11, 2010 3:59 PM
  • Hey its  worked thanks a lot. 
    Tuesday, June 15, 2010 9:46 AM
  • Hey its  worked thanks a lot. 
    what worked?  there's like 20 answers here.
    Friday, June 25, 2010 6:06 PM
  • Thanks.
    Wednesday, June 30, 2010 11:15 AM
  • I am also facing a similar kind of issue but it is some what different, can anybody tell what would be the cause  of this kind of error

    An unhandled exception ('System.Reflection.TargetInvocationException') occurred in w3wp.exe [3792]. Just-In-Time debugging this exception failed with the following error: Debugger could not be started because no user is logged on.

    Check the documentation index for 'Just-in-time debugging, errors' for more information.

     

    I am actually using a third party control Deaja  for viewing my images in the website and whenever I click on the link( it will load the deaja control and display the image generally by using web service call)  I am getting an error instead of images, it was working fine previously but recently i am getting some error.

    please send me a solution for this- this is the first time I am seeing this type of error.

    Thanks in Advance

    Monday, August 09, 2010 11:37 PM
  • Hi ,

    I am also facing a similar kind of issue but it is some what different, can anybody tell what would be the cause  of this kind of error

    An unhandled exception ('System.Reflection.TargetInvocationException') occurred in w3wp.exe [3792]. Just-In-Time debugging this exception failed with the following error: Debugger could not be started because no user is logged on.

    Check the documentation index for 'Just-in-time debugging, errors' for more information.

     

    I am actually using a third party control Deaja  for viewing my images in the website and whenever I click on the link( it will load the deaja control and display the image generally by using web service call)  I am getting an error instead of images, it was working fine previously but recently i am getting some error.

    please send me a solution for this- this is the first time I am seeing this type of error.

    Thanks in Advance

    Monday, August 09, 2010 11:43 PM
  • Registry deletion didn't work for me, disabling debugging in internet options didn't work either. But don't quote me on that since I did not restart my machine.

    But renaming the vsjitdebugger.exe worked right away! and i thought you were a genius!!

     

     

    Thursday, August 12, 2010 7:04 PM
  • Got to Administrative tools-Services.

    disable the machine debugging (it will say it's related to visual studio).

    Selecting properties will give you the options.

    Just in case someone gets lost, the display name is Machine Debug Manager. Stop the service and change the startup type to Disabled.
    Saturday, September 11, 2010 8:51 PM
  • Here's the direct link and instructions on how to disable Just-In-Time Debugging.

    http://msdn2.microsoft.com/en-us/library/k8kf6y2a.aspx

    To enable/disable Just-In-Time debugging

    1.   Open Visual Studio
    2. On the Tools menu, click Options .

    3. In the Options dialog box, select the Debugging folder.

    4. In the Debugging folder, select the Just-In-Time page.

    5. In the Enable Just-In-Time debugging of these types of code box, select or clear the relevant program types: Managed , Native , or Script .

      To disable Just-In-Time debugging, once it has been enabled, you must be running with Administrator privileges. Enabling Just-In-Time debugging sets a registry key, and Administrator privileges are required to change that key.

    6. Click OK .

    I used this method and time will tell if it works but it is looking good so far.

    I have an intermittent issue using Powerbuilder v10.5 and VS2005. When I am working in Powerbuilder and also with the stand alone executable for the application I create, I am getting random issues where and error executes this debugging software. Very frustrating.

    Hopefully we have solved the issue.

    • Proposed as answer by Kupersmith Thursday, October 21, 2010 3:08 PM
    Tuesday, October 12, 2010 1:21 AM
  • Here's the direct link and instructions on how to disable Just-In-Time Debugging.

    http://msdn2.microsoft.com/en-us/library/k8kf6y2a.aspx

    To enable/disable Just-In-Time debugging

    1.   Open Visual Studio
    2. On the Tools menu, click Options .

    3. In the Options dialog box, select the Debugging folder.

    4. In the Debugging folder, select the Just-In-Time page.

    5. In the Enable Just-In-Time debugging of these types of code box, select or clear the relevant program types: Managed , Native , or Script .

      To disable Just-In-Time debugging, once it has been enabled, you must be running with Administrator privileges. Enabling Just-In-Time debugging sets a registry key, and Administrator privileges are required to change that key.

    6. Click OK .

    I used this method and time will tell if it works but it is looking good so far.

    I have an intermittent issue using Powerbuilder v10.5 and VS2005. When I am working in Powerbuilder and also with the stand alone executable for the application I create, I am getting random issues where and error executes this debugging software. Very frustrating.

    Hopefully we have solved the issue.


    This works for me - the only thing I'd add is to ensure the "Show all settings" box is checked in the options window or you may not see the Debugging section.
    Thursday, October 21, 2010 3:13 PM
  • HI,

     

    I am using the Win 7 64 Bit OS. However I am not able to see this option in my registery:

     

    • HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows NT\CurrentVersion\AeDebug\Debugger

    • HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\.NETFramework\DbgManagedDebugger

    Can you help me with this?

     

    Monday, March 14, 2011 8:43 PM
  • This one has been driving me nuts. I'm running vs2008 on vista and I'm working on classic ASP. I want to debug in browser, not have the JIT debugger pop up each time. I couldn't go back to notepad as we use source control through vs 2008.

    I tried all solutions here that dealt with turning it off in VS2008 or the registry but still got the popup.

    Here's what I did (which appears to have worked)

    I called my asp page with the error on it - the pesky JIT debugger popped up.

    I opened task manager and saw the JIT debugger running, right clicked, properties and its showed me file name and path. I went and found the exe, right clicked it and ticked "run as admin".


    Now it appears to play nicely and taking account of the registry changes. so now i can debug in the browser!

     

    Hope this helps someone else!

    Friday, July 08, 2011 2:15 PM
  • It work, but now the game don't start...the JIT has been disabled but now the game don't work (Assassin's creed)
    Friday, October 14, 2011 11:29 AM
  • In Server 2008 x64, the only way I found to fix this was to delete  C:\Windows\System32\vsjitdebugger.exe      The problem went away immediately.
    Thursday, November 17, 2011 12:01 AM
  • Habib:  I also have this problem and followed your advice to no avail.

    Any options?

    caseyatbat16

    Tuesday, December 13, 2011 11:16 PM
  • I also have this problem.  How can I find MyPC?

    caseyatbat16

    Tuesday, December 13, 2011 11:25 PM
  • I have done this repeatedly! As soon as I click on another pge in IE, the check boxes in the advanced tab are removed and the most annoying pop up appears wanting to debug the script. I click on NO and DO NOT ASK ME AGAIN but it never stops! I didnot have this problen until I installed IE. Pleas help.

    So very annoyed

    Wednesday, April 11, 2012 11:20 PM
  • i cannot find the 

    • HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\.NETFramework\DbgManagedDebugger

    and also

    • HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\.NETFramework\DbgManagedDebugger

    in my laptop. my laptop is 64-bit operating system. please help me. URGENT... 

    Sunday, May 20, 2012 5:15 AM
  • Disable Server-Side Debugging property on IIS.
    Friday, May 25, 2012 8:53 PM