none
Visual Studio 2010 not loading projects correctly

    Question

  • Opening a .sln file in the following ways works with no error messages:

    - doubclick on it in Windows Explorer

    - Visual Studio->File->Open->Project/Solution..., navigate to file and doubleclick on it.

    I get "One or more projects in the solution were not loaded correctly. Please see the output window for details", with "... could not be found" messages in the output window for all of the .vcxproj files, even though the paths are valid, and there is NO source control involved if I do:

    - Visual Studio->File->Open->Project/Solution..., and type in the full file path, then type enter.

    - Or, from a cmd window, type the full .sln path (quoted)

    I'm trying to automated UI testing of a Visual Studio plug-in, so there isn't a way around selecting the solution and I don't want to have my test code navigate the Open dialog.

    Tuesday, July 05, 2011 8:46 PM

All replies

  • That's completely weird! In the Open Project dialog, it makes a difference whether you double-click the file, or type the filename?!

    There's got to be something about the filepath and the way you're typing it - maybe some weird character in the filename...?

    I'd try it with a solution in a different location. If that works, move the solution back to its old location - one folder at a time....


    - Alan -MSFT
    Wednesday, July 06, 2011 10:14 AM
    Moderator
  • Hello,

    I am writing to check the status of the issue on your side.  Would you mind letting us know the result of the suggestions? 

    In addintion, if we create a new project, do we have the problem? Sometimes corrupted project settings can cause problems. These are project specific.

    Regards,

    Yi


    Yi Feng Li [MSFT]
    MSDN Community Support | Feedback to us
    Get or Request Code Sample from Microsoft
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    Monday, July 11, 2011 4:56 AM
    Moderator