none
The .Net Framework installed on this machine does not meet the minimum required version: 4.5.50709.

    Question

  • This error message comes up when I install Visual Studio Express

    The .Net Framework installed on this machine does not meet the minimum required version: 4.5.50709.

    Saturday, August 18, 2012 4:41 PM

Answers

All replies

  • I am also facing same issue while installing VS 2012 on recently installed Windows 8.
    Saturday, August 18, 2012 9:31 PM
  • me too, instaled win8 rc x64 , and wanted to instal vs2012_winexp_enu

    pls help

    Saturday, August 18, 2012 10:32 PM
  • I hate this.. I just hate this..

    According to regs, my installed .NET version is 4.0. However it tells me "you already have it!" when I try to install 4.5

    • Proposed as answer by HazimAlraddadi Saturday, September 08, 2012 10:35 AM
    Saturday, August 18, 2012 10:39 PM
  • Dear MS I am not the only one with this issue. P.L.E.A.S.E. take responsibility and measures to correct !!!!
    Sunday, August 19, 2012 8:49 AM
  • Same issues here :(

    cheers simon

    Sunday, August 19, 2012 3:31 PM
  • I just ran into this problem - it seems the latest Visual Studio RTM versions won't install on Windows 8 Release Preview.  You can either try one of the RC versions of Visual Studio (valid until Jan 2013), or download a 90 day evaluation version of Windows 8 Enterprise RTM. 

    Microsoft Visual Studio Ultimate 2012 RC
    http://www.microsoft.com/en-us/download/details.aspx?id=29917

    Microsoft Visual Studio Professional 2012 RC
    http://www.microsoft.com/en-us/download/details.aspx?id=29931

    Microsoft Visual Studio Express 2012 RC for Windows 8
    http://www.microsoft.com/en-us/download/details.aspx?id=29915

    Microsoft Visual Studio Express 2012 RC for Web
    http://www.microsoft.com/en-us/download/details.aspx?id=29928

    Windows 8 Enterprise RTM 90 day evaluation version
    http://msdn.microsoft.com/en-US/evalcenter/jj554510.aspx

    Monday, August 20, 2012 12:28 AM
  • These don't work either... This whole Win 8 thing has been a nightmare.
    Monday, August 20, 2012 8:09 PM
  • Thanks Mark, it works with RC! :-)

    Monday, August 20, 2012 8:14 PM
  • me too... that's something really irritating!
    Sunday, August 26, 2012 10:52 AM
  • same here..., I though could find resolve here, but seam like ever1 has same issue....

    I have 8 and vs 12 RC...

    Monday, August 27, 2012 5:31 PM
  • Well! I suppose someone may come up with an "Easy" fix!

    Why should we have to download extra bits to try and get something to work when it should have in the first place? All far too time consuming and Visio is not for me - TOO tricky.....


    RLDC

    Wednesday, August 29, 2012 3:47 PM
  • It is a beta for a reason, there should not be a "nightmare scenario"  If it doesn't work the way you expect it should find a way around it, that is why they let us "play" with the software before they release it... because there are problems, we are here to help.  And if we have to download "extra bits" that is the best and quickest work around at this point, Thanks MS it worked for me now back to coding!!!

    Adam

    • Proposed as answer by JPRL Sunday, September 09, 2012 2:31 AM
    • Unproposed as answer by JPRL Sunday, September 09, 2012 2:31 AM
    Wednesday, September 05, 2012 9:04 PM
  • Here is how to get around it:

      • Download the .net 4.5 installer and run it with /x to extract it.
      • Go to the extracted folder and open ParameterInfo.xml.
      • Remove anything between <blockers> and </blockers>
      • Start setup.exe and install.

    • Proposed as answer by ModeLearner Saturday, September 08, 2012 6:07 AM
    Thursday, September 06, 2012 11:10 AM
  • MagnarJ's solution did not work for me. I've tried installing VS 2012 RC Express and I'm afraid that did not work either.
    Thursday, September 06, 2012 3:22 PM
  • Thanks Mark.

     Installation of "RC versions of Visual Studio" solved my problem. It worked for me.


    ModeLearner

    Saturday, September 08, 2012 9:28 AM
  • Magnar Thnk Problem Solved
    Sunday, September 09, 2012 1:31 PM
  • Problem Solved

    1. Go  To  Net Freworks 4.5 Final Dowload

    2. Net Freworks 4.5  Winrar Decomprese

    3. ParameterInfo.xml  Notepad Open

    4. <Blocker> and  </blocker>  Setup İf Blocke Code remove Save as ParameterInfo.xml

    Start İnstall 

    • Proposed as answer by simp513 Friday, October 26, 2012 8:26 PM
    Sunday, September 09, 2012 1:35 PM
  • I needed to remove the <blockers> </blockers> tags as well as everything between them to get this to work.

    ...

    but then a fatal error at the end of installation

    • Edited by petegreg Friday, September 14, 2012 12:35 AM spoke too soon
    Thursday, September 13, 2012 11:44 PM
  • fatal error during installation, which it useless to remove these things~
    Friday, September 14, 2012 12:29 AM
  • go to control panel, installed programs, turn windows features on and off, tick asp.net 4.5
    • Proposed as answer by JonesJunior Tuesday, September 18, 2012 5:43 PM
    Tuesday, September 18, 2012 5:41 PM
  • The .NET 4.5 installer seems to install 4.5.50501, whereas VS requires 4.5.50709. Does that make a difference? (Not that I can get the installer to work for me, either.)
    Wednesday, September 19, 2012 1:56 AM
  • .Net Framework 4.5.50709 won't be installed along with visual studio 2012 as it's requirements?

    Friday, September 21, 2012 5:45 PM
  • This works for me in Windows 8 Release Preview:

    • Run regedit.exe.
    • For 64-bit Windows users, go to the following key:HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\NET Framework Setup\NDP\v4\Full
    • For 32-bit users, it should be here: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\NET Framework Setup\NDP\v4\Full
    • You'll need to change the permissions before you can edit anything.  First, change the owner to Administrators, then assign the Administrators principal with Full Control.
    • Finally, simply change the value for "Version" to "4.5.50709".

    • Proposed as answer by Hazie1 Friday, September 28, 2012 12:45 PM
    Saturday, September 22, 2012 5:14 AM
  • Works like a charm! :)

    Thanks Archiebass

    Saturday, September 22, 2012 1:02 PM
  • Archiebass's solution works.

    to change permission for editing registry, in Regedit, select you key, right-click-->Permissions-->Advanced-->Owner, select Administrators, Apply. Then grand FC to "Administrators"

    Saturday, September 29, 2012 7:12 AM
  • Thanks so much Archiebass - your suggestion works great. 

    I did run into one more issue - I was trying to build a Windows App and when building it, got the following error...

    Error 1 Error : DEP0800 : The required framework "C:\Program Files (x86)\Microsoft SDKs\Windows\v8.0\ExtensionSDKs\Microsoft.WinJS.1.0\1.0\Microsoft.WinJS.1.0.appx" failed to install.
    Windows cannot install package Microsoft.WinJS.1.0 because this package requires a higher Windows version. The package requested Windows version 6.2 with AppModel version 1, while the current Windows version is 6.2 with AppModel version 0. VolunteerHoursTracker

    ...the error appeared on a C# and JavaScript project type - so it might be best for those trying to develop on Windows 8 to use Visual Studio 2012 RT instead of the final release; at least until Microsoft resolves most of the issues. 

    Saturday, September 29, 2012 5:05 PM
  • Best response. Worked like a charm. Thanks.
    Sunday, September 30, 2012 10:59 PM
  • Thanks a lot for everyone for providing me vital inputs. I was tired trying to install VS.Net 2012 on top of VS.Net 2011 and struggling. After following all the tips provided in this above thread, it worked.

    Abhishek

    Monday, October 01, 2012 5:45 PM
  • to: Archiebass

    ___________________________________________________________________________________________________________

    • Run regedit.exe.
    • For 64-bit Windows users, go to the following key:HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\NET Framework Setup\NDP\v4\Full
    • For 32-bit users, it should be here: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\NET Framework Setup\NDP\v4\Full
    • You'll need to change the permissions before you can edit anything.  First, change the owner to Administrators, then assign the Administrators principal with Full Control.
    • Finally, simply change the value for "Version" to "4.5.50709".

    ____________________________________________________________________________________________________________

    this not work for me ....

    i also change the permissions of registry editor before editing string but can't change the value for "Version" to "4.5.50709"..

    so. give me a appropriate solution for this.... 

    • Proposed as answer by Soyeb Malek Tuesday, October 02, 2012 1:12 PM
    • Unproposed as answer by Soyeb Malek Tuesday, October 02, 2012 1:13 PM
    Tuesday, October 02, 2012 8:03 AM
  • As weiwei2 said :

    to change permission for editing registry, in Regedit, select you key, right-click-->Permissions-->Advanced-->Owner, select Administrators, Apply. Then grand FC to "Administrators"

    • Proposed as answer by Pedro Marthon Saturday, December 22, 2012 9:53 AM
    Tuesday, October 02, 2012 1:15 PM
  • Archiebass's solution works.

    to change permission for editing registry, in Regedit, select you key, right-click-->Permissions-->Advanced-->Owner, select Administrators, Apply. Then grand FC to "Administrators"

    Thanks for expanding on this; I always get tripped up with the advanced permissions.  Regedit trick is the quickest/cleanest solution, it seems to me.
    Wednesday, October 03, 2012 4:35 AM
  • We should not have to do these hacks. None of them worked for us. Nobody has answered this thread in 7 days. Where is Microsoft on this! If the management of Microsoft knew about it, they would be furious. Microsoft is a great company but some mid-level engineer fell asleep at the switch!
    Wednesday, October 10, 2012 4:02 PM
  • Worked like a Charm !

    Thanks

    Saturday, October 13, 2012 11:25 AM
  • Worked perfectly for me..!! Thankyou Archiebass
    Avatar of Archiebass
    ...
    Sunday, October 14, 2012 7:19 AM
  • Archiebass, your fix was simple and worked just fine. Thanks.
    Sunday, October 14, 2012 8:48 PM
  • THANK YOU SOOO MUCH!! This made it work PERFECTLY! Thanks a million.
    • Proposed as answer by ShahidRahaman Saturday, October 20, 2012 2:14 PM
    Saturday, October 20, 2012 2:14 PM
  • The hackish solution that worked for me was again to changed the register Version from 0 to 1 in

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\AppModel

    It compiled and installed my app locally, great for now at least to do some JS dev, but I would suggest to backup the reg and keep track of hackish solution like this, they may break something else... 

    Saturday, October 20, 2012 3:07 PM
  • Ah, thank you so much, Archiebass! Worked great for me :)
    Monday, October 22, 2012 7:24 PM
  • I tried the same , I even changed the registry , but it gives the same error, I was able to install it on laptop with the same technique nut my desktop pc is not installing it !!
    Tuesday, October 23, 2012 3:58 PM
  • This works for me in Windows 8 Release Preview:

    • Run regedit.exe.
    • For 64-bit Windows users, go to the following key:HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\NET Framework Setup\NDP\v4\Full
    • For 32-bit users, it should be here: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\NET Framework Setup\NDP\v4\Full
    • You'll need to change the permissions before you can edit anything.  First, change the owner to Administrators, then assign the Administrators principal with Full Control.
    • Finally, simply change the value for "Version" to "4.5.50709".

    it's work, thank you.
    Tuesday, October 23, 2012 7:11 PM
  • Tried this, worked like a charm. Haven't used Visual Studio yet, so I don't know if everything will do what the .NET update allowed, but other than that, all is good.

    Thanks! :-)

    Saturday, October 27, 2012 6:51 AM
  • Guys please help... I always struggle with setting permissions.

    click-->Permissions-->Advanced-->Owner, select Administrators, Apply. Then grand FC to "Administrators"

    Can some kind soul step thru this in a little more detail.

    I right click and get Security Menu displayed, click advanced ... for me the Owner at the top is already the administrator, so I cannot click apply - its grayed out... so I double click administrators in permission entries, tick Full because only Read is checked and apply that to return to Advanced Security Settings, click apply, and get dialog error Unable to save Permission Changes on full, Access is denied...

    what am I doing wrong??

    Sunday, October 28, 2012 3:32 PM
  • I had the same issue, the problem was I took ownership as Administrator which is a user and not Administrators, the group.  Take ownership as administrators and you will be good to change the permission to FC.
    • Proposed as answer by zubogeorge Monday, October 29, 2012 8:38 AM
    Sunday, October 28, 2012 10:58 PM
  • absolutely brilliant and spot on.

    Thank you VERY much.

    george

    Monday, October 29, 2012 8:39 AM
  • Windows 8  = Windows H8

    The first time in my life I have ever hated a new version of Windows. 

    Saturday, November 10, 2012 7:36 PM
  • Guys please help... I always struggle with setting permissions.

    click-->Permissions-->Advanced-->Owner, select Administrators, Apply. Then grand FC to "Administrators"

    Can some kind soul step thru this in a little more detail.

    I right click and get Security Menu displayed, click advanced ... for me the Owner at the top is already the administrator, so I cannot click apply - its grayed out... so I double click administrators in permission entries, tick Full because only Read is checked and apply that to return to Advanced Security Settings, click apply, and get dialog error Unable to save Permission Changes on full, Access is denied...

    what am I doing wrong??

    Same issue here. 
    Saturday, November 10, 2012 8:06 PM
  • This did not work.

    Error message: "Setup encountered an unexpected error in the package contents. The package will not be installed".

    I'll have to try another way...

    Sunday, November 11, 2012 3:03 PM
  • I got it extracted, modified the XML file. Tried the install and get the same error as above.

    Error message: "Setup encountered an unexpected error in the package contents. The package will not be installed".

    Tuesday, November 13, 2012 8:39 PM
  • I can't use this method either. I'm getting permissions errors trying to change the permissions.
    Tuesday, November 13, 2012 8:52 PM
  • i couldn't change the permission 
    could you explain it with another way

    Saturday, November 24, 2012 6:22 AM
  • Thank You worked like a charm.   
    Sunday, November 25, 2012 8:45 PM
  • I have same issue as well
    Tuesday, November 27, 2012 9:43 AM
  • Same issue can not change the permission
    Friday, November 30, 2012 9:31 PM
  • Worked like a charm. As a side note, when changing the owner to "Administrators", you'll literally need to type in "Administrators" as there is no drop-down menu of users.

    Thanks Archiebass!

    Saturday, December 01, 2012 5:31 AM
  • Worked great!! Thanks!
    Saturday, December 08, 2012 2:10 AM
  • This is working fine...
    Monday, December 10, 2012 8:58 AM
  • This solve was permission installing VS12. It's worked!
    But there is new problem. I can't get developer licence when VS12 started.
    Error 0x8190190 (bad request (400))

    What's up?

    Tuesday, April 16, 2013 11:14 AM