none
Fatal error C1083: Cannot open include file: 'openssl/crypto.h': No such file or directory

    Question

  • Hello.

    I’m trying to build a C++ open source program called Magic Mail Monitor version
    2.9.4-b19.  I’m using, as recommended, VS6.0 C++ on a WIN XP Pro, SP3 computer logged into a Windows 2003 server domain as Administrator.

    When use F7 to build the EXE file, I’m getting this error:

    --------------------Configuration: Magic - Win32 Release--------------------

    Compiling resources...
    Compiling...
    StdAfx.cpp
    C:\Documents and Settings\Administrator\My Documents\Ut\MMM\B19SRC\stdafx.h(39) : fatal error C1083: Cannot open include file: 'openssl/crypto.h': No such file or directory

    Error executing cl.exe.

    Magic.exe - 1 error(s), 0 warning(s)

    I added the openssl folder to the project and added the crypto.h file to the openssl folder and it still gives the same error.

    The folder and the file are there when I view it in Windows explorer and I can see it in the project.  I tried searching here and on Google and have not been able to figure out how to resolve this issue.

    Is there a special way to add the folder and file to the project?

    Any help would be gratefully appreciated.

    Thanks,
    Tony


    Stop The World, I want To Get Off!
    Sunday, November 28, 2010 9:42 AM

Answers

  • 1. Install Win32 OpenSSL.

    2. Go Tools > Options... In Options dialog Directories tab. Select category Include files. Add "<OpenSSL installed dir>\include" here, for example "C:\OPENSSL-WIN32\INCLUDE".


    Nikita Leontiev
    • Marked as answer by Carneno Sunday, November 28, 2010 5:09 PM
    Sunday, November 28, 2010 1:04 PM
  • Now add lib folder (from OpenSSL package) path to Library files category.
    Nikita Leontiev
    • Marked as answer by Carneno Sunday, November 28, 2010 5:09 PM
    Sunday, November 28, 2010 2:28 PM

All replies

  • You try add openssl folder at Additional Include Directories in property of project.
    Sunday, November 28, 2010 9:59 AM
  • Hello Fuji.

    I just added the openssl folder to the Additional Include Directories and i still get the same error.

    Thanks,
    Tony


    Stop The World, I want To Get Off!
    Sunday, November 28, 2010 10:23 AM
  • 1. Install Win32 OpenSSL.

    2. Go Tools > Options... In Options dialog Directories tab. Select category Include files. Add "<OpenSSL installed dir>\include" here, for example "C:\OPENSSL-WIN32\INCLUDE".


    Nikita Leontiev
    • Marked as answer by Carneno Sunday, November 28, 2010 5:09 PM
    Sunday, November 28, 2010 1:04 PM
  • Hello Nikita.

    Well, that worked fine.  I'm not sure of why since i don't know that much about C++ 6.0 development.  I usually program in VB, but it did resolve that error.

    However, i am now getting a lot of warnings and a Link error.

    Should i post them here or open another thread?

    Thanks,
    Tony


    Stop The World, I want To Get Off!
    Sunday, November 28, 2010 1:34 PM
  • Now add lib folder (from OpenSSL package) path to Library files category.
    Nikita Leontiev
    • Marked as answer by Carneno Sunday, November 28, 2010 5:09 PM
    Sunday, November 28, 2010 2:28 PM
  • Well Nikita.  Now you did it again.

    That fixed the link error also.

    Thanks for all of your help, knowledage and quick replies.

    Tony


    Stop The World, I want To Get Off!
    Sunday, November 28, 2010 5:11 PM