none
Designer Icons not showing

    Question

  • I am not seeing the icons in my screen designer or on the control selection menus.  Any thoughts or am I alone in this?
    Derek
    Tuesday, July 26, 2011 7:01 PM

Answers

  • We have a theory on our side that we are currently investigating, but I wanted to post it out in case anyone wants to give it a try and help us confirm that it truly does fix the issue. We believe if you close the IDE, delete the following folders, and restart the IDE that it might fix the issue. These folders are for the MEF cache so deleting them shouldn't have a negative effect. It will just rebuild the cache the next time it is needed.

    %LOCALAPPDATA%\Microsoft\VisualStudio\10.0\ComponentModelCache
    %LOCALAPPDATA%\Microsoft\VisualStudio\10.0\ManifestCache


    Patrick Baker (Visual Studio LightSwitch Test Lead)
    Thursday, July 28, 2011 12:58 AM
  • I am glad we could narrow this down and get everyone unblocked so quickly. Enjoy LightSwitch!


    Patrick Baker (Visual Studio LightSwitch Test Lead)
    Thursday, July 28, 2011 2:58 PM

All replies

  • same here
    Tuesday, July 26, 2011 7:17 PM
  • Same problem here. Setup was straight forward. No errors.
    I don't have the Extension templates either. Any of you guys got these?
    Tuesday, July 26, 2011 7:33 PM
  • Mine too.
    Derek
    Tuesday, July 26, 2011 7:33 PM
  • Tuesday, July 26, 2011 7:33 PM
  • This isn't something that we have seen before. Is there something in common between your configurations that might help pin this down?

    What OS?

    Standalone LightSwitch, or LS with Visual Studio 2010 version?

    Did you have Beta 2 installed, and if so, did you uninstall first?

    Thanks,


    Steve Hoag Microsoft aka the V-Bee
    Tuesday, July 26, 2011 7:44 PM
  • Did you try a reboot?
    Tuesday, July 26, 2011 7:47 PM
  • Also, what resolution are you running with? DPI? High Contrast Mode? I do recall an issue with icons for labels not showing up under certain high contrast mode conditions.

    Thanks.


    Patrick Baker (Visual Studio LightSwitch Test Lead)
    Tuesday, July 26, 2011 7:55 PM
  • @Steve

    LS with VS 2010 Ultimate.

    Yes Beta 2 Uninistalled then installed RTM everthing with smooth no problems.  I have installed since the DevX Editors to play with but have not used them on anything.

    @William - Yes I have rebooted.

    @Patrick 1920X1280 normal contrast


    Derek
    Tuesday, July 26, 2011 8:05 PM
  • I see the issue too.  I was not clear on what icons.  But see same thing, even after reboot.  My contrast or rez has not changed between beta2 and rtm either.
    Tuesday, July 26, 2011 8:15 PM
  • LS with VS 2010 Professional. Did have Beta 2. Uninstalled before attempting install. Install from DVD MSDN download, not the Web Install.

    Doesn't seem to be any problems running full application (custom SL controls and such) developed in Beta 2. Had to rebuild, but runs without problem.

    Can anybody shed any light on the Extension templates. I was under the impression they would be available as a new project type.

     

    Regards

    Paul

     

    Tuesday, July 26, 2011 9:06 PM
  • VS professional SP1.

    I had uninstalled de beta 2, but not the beta 2 deployment prerequisites. Could that be the problem?

    No beta 2 deployment prerequisites is installed now. Either the beta 2 deployment prerequisites was uninstalled together with beta 2 or was uninstalled during rtm installation.


    Tuesday, July 26, 2011 9:39 PM
  • On mine, beta2 deploy prereq was uninstalled after beta2 uninstall.  When I clicked on to remove, it said was already removed.  UI update thing in AddRemove programs. 
    Strange thing is, the "Design Screen" designer works - you can see the node icons.
    Tuesday, July 26, 2011 10:08 PM
  • +1. Using LS RTM with VS 2010 Pro on Win XP Pro w/ sp3. Issue did not occur with Beta 2.


    UPDATE:

    Unistalled VS 2010 Pro and reinstalled LS RTM - still didn't fix the issue.

    Tried fresh LS RTM install on another Win XP Pro w/ sp3 machine that has never had VS 2010 Pro installed with the same result - no designer icons appearing.

    Both PC's have Intel HD graphics in case it counts.

    Wednesday, July 27, 2011 2:28 AM
  • Just a straight uninstall B2, install RTM for me here, I'm not experiencing this problem. I can see the icons at both design time & runtime.

    The prereq's did "appear" to still be in the list after uninstalling B2, but as William said, if you try to remove them manually, it says they've already been uninstalled & then removes the entry from the list. This is with the Programs & Features window still open, maybe if it was closed & opened again the entry wouldn't still show.


    Yann

    (plus ça change, plus c'est la même chose!)

    Wednesday, July 27, 2011 4:37 AM
  • @Yann, what OS are you running?

    Wednesday, July 27, 2011 5:44 AM
  • OS Name: Microsoft Windows 7 Ultimate

    Version: 6.1.7601 Service Pack 1 Build 7601
    System Type: x64-based PC
    Processor: Intel(R) Core(TM)2 Duo CPU
    T8300  @ 2.40GHz, 2401 Mhz,
    2 Core(s), 2 Logical Processor(s)
    Physical RAM: 4.00 GB


    Yann

    (plus ça change, plus c'est la même chose!)

    Wednesday, July 27, 2011 5:58 AM
  • I also have this problem - icons not showing...

    Microsoft Windows [Version 6.1.7600]

    VS 2010 Ultimate + LightSwitch I downloaded from MSDN.

    Uninstalled B2 and installed RTM - no errors.

    Any solution so far ?

    Wednesday, July 27, 2011 7:13 AM
  • Only just checked my 'Design Screen' during runtime. Same as William, can see icons there.

     

    Wednesday, July 27, 2011 8:39 AM
  • My resolution is 1280x1024 when docking connected, and 1280x800 when working directly with the laptop.

    High contrast mode is not enabled and DPI is default - 100%.

    Any suggestions? Thanks.

    Wednesday, July 27, 2011 1:05 PM
  • I've the same behavior: Missing icons

     

     

    Beta 1 was never installed. I've removed Beta2 previously and installed the final release of LS without errors.

     

    My System/Configuration

    Windows 7 Pro SP1

    Microsoft Visual Studio 2010 Version 10.0.40219.1 SP1Rel Installed Version: Professional
    Microsoft .NET Framework Version 4.0.30319 SP1Rel  

    Andreas




    Wednesday, July 27, 2011 1:54 PM
  • Working fine for me in a 32-bit VM.  Could this be a 64-bit problem?
    Wednesday, July 27, 2011 2:50 PM
  • I use Windows 7 32Bit

    Wednesday, July 27, 2011 2:56 PM
  • I see the same problem in the Designer in V1 and I use Window 7 Pro 64-bit.  The icons appeared in Beta 2.
    Wednesday, July 27, 2011 3:05 PM
  • I'm in this boat as well.

    Windows 7 Pro SP1 64-bit
    i3 M380 2.53GHz
    3 GB RAM 

    Wednesday, July 27, 2011 3:24 PM
  • Seems to be a wide-spread issue.

    I have the same problem. I've started with Beta 2. I've uninstalled it before installing V1

    My system is a German Windows 7 Pro SP1 64-bit 6GB RAM standard Dell notebook. Nothing special. I've installed the English version of LightSwitch V1. This problem didn't exist in Beta 2

    By the way. I've installed V1 on the system where VS 2010 Premium already exists

     

     


    Wednesday, July 27, 2011 9:21 PM
  • Sorry to here so many of you are having difficulties. We haven't been able to reproduce this yet on our end. Can you give me some more information. I am going to try and loop some people in to see if we can't figure out what is going on.

    • Are these new projects or are you opening projects created in Beta 2? If they are not new projects, does new projects work?
    • Did you do a clean install or did you previously have an older version of LightSwitch installed? (It seems like most of you all did an uninstall then re-install so I just want to confirm).
    • Is this only in the screen designer or are there other places where this happens (query designer, solution explorer, etc)
    • Is it just with certain controls or all of them? Specifically do you see this with Money, PhoneNumber, or any other Third Party business type of control?
    • Does anybody have a simple project/solution that repros this behavior that they would be willing to share with us for debugging purposes.

    Thanks.

     


    Patrick Baker (Visual Studio LightSwitch Test Lead)
    Wednesday, July 27, 2011 10:27 PM
  • I'm using Windows 7 64-bit. I thought I mentioned that in my previous post, but I see now that it just said "x64-based PC", which of course doesn't guarantee I'm using a 64-bit OS, but I am.

    Yann

    (plus ça change, plus c'est la même chose!)

    Thursday, July 28, 2011 12:34 AM
  • I was able to resolve this issue by doing the following, however I am in no way suggesting this as a viable solution (my company laptop is encyripted, so a reformat was out of the question):

    (Also note that I have no idea which step I performed that actually solved the problem.)

    1. Uninstalled VS 2010 Pro and LS Beta 2 by first uninstalling the LS Deployment Prerequisites, then LS Beta 2 followed by a reboot.
    2. Uninstalled .NET Framework 4 Client, Extended and Multi Targeting packs.
    3. Uninstalled all other components installed with VS 2010 pro or LS such as ASP.NET MVC, C++ Runtimes, F# Runtime et. al. (also uninstalled VS 2010 sp1)
    4. Uninstalled SQL Server 2008 R2.
    5. Uninstalled Dev Express reporting extensions.
    6. Deleted all files from C:\Documents and Settings\<user>\Local Settings\Temp (or equivalent).
    7. Deleted all registry keys containing the phrase 'lightswitch' including branches\keys:

      ...\Software\Microsoft\VisualStudio\10.0_Config\CSLID\
      ...\Software\Microsoft\VisualStudio\10.0_Config\Editors\
      ...\Software\Microsoft\VisualStudio\10.0_Config\InstalledProducts\
      ...\Software\Microsoft\VisualStudio\10.0_Config\Lightswitch\
      ...\Software\Microsoft\VisualStudio\10.0_Config\MSBuild\SafeImports\
      ...\Software\Microsoft\VisualStudio\10.0_Config\Packages\
      ...\Software\Microsoft\VisualStudio\10.0_Config\Projects\
      ...\Software\Microsoft\VisualStudio\10.0_Config\Services\
      ...\Software\Microsoft\VisualStudio\10.0_Config\Setup\
    8. Rebooted, re-installed LS RTM. Design time icons now appeared correctly.
    9. Re-installed VS 2010 Pro and sp1.

    Again I would like to reiterate that and I am providing this information as 'part of the puzzle' and not the solution.

    Thursday, July 28, 2011 12:38 AM
  • We have a theory on our side that we are currently investigating, but I wanted to post it out in case anyone wants to give it a try and help us confirm that it truly does fix the issue. We believe if you close the IDE, delete the following folders, and restart the IDE that it might fix the issue. These folders are for the MEF cache so deleting them shouldn't have a negative effect. It will just rebuild the cache the next time it is needed.

    %LOCALAPPDATA%\Microsoft\VisualStudio\10.0\ComponentModelCache
    %LOCALAPPDATA%\Microsoft\VisualStudio\10.0\ManifestCache


    Patrick Baker (Visual Studio LightSwitch Test Lead)
    Thursday, July 28, 2011 12:58 AM
  • Sorry I forgot to mention that I also deleted %LOCALAPPDATA%\Microsoft\VisualStudio\10.0\ as part of trying to resolve the issue which aligns with this theory.
    Thursday, July 28, 2011 1:04 AM
  • Patrick deleting those folders worked for me!
    Thursday, July 28, 2011 1:23 AM
  • Works like a charm. Thanks for your support. Yesterday before going to bed I wrote the post and in the morning the problem is solved.

    Marvelous

    Have a nice day

    Uwe

    Thursday, July 28, 2011 5:48 AM
  • %LOCALAPPDATA%\Microsoft\VisualStudio\10.0\ComponentModelCache
    %LOCALAPPDATA%\Microsoft\VisualStudio\10.0\ManifestCache


    Yes! Thats it! Deleting the folders fixed the problem on my maschine!

    • Are these new projects or are you opening projects created in Beta 2? If they are not new projects, does new projects work?
    • Did you do a clean install or did you previously have an older version of LightSwitch installed? (It seems like most of you all did an uninstall then re-install so I just want to confirm).
    • Is this only in the screen designer or are there other places where this happens (query designer, solution explorer, etc)
    • Is it just with certain controls or all of them? Specifically do you see this with Money, PhoneNumber, or any other Third Party business type of control?
    • Does anybody have a simple project/solution that repros this behavior that they would be willing to share with us for debugging purposes.
    • It was projects build with Beta2
    • Yes it was a clean install, but without reboot (there was now msg about that)
    • I only now about the screen designer
    • all controls that i used
    • maybe if you still need one

    Andreas


    Thursday, July 28, 2011 5:54 AM
  • Hi,

    Where are these folders located exactly ?

    I can't seem to find any trace of them on my development box ?

    Clearly I am doing something wrong...

    Thanks,

    Nick

    Thursday, July 28, 2011 5:54 AM
  • Nick, you won't find "%LocalAppData%" anywhere by looking for it, but if you paste that whole line into the address bar of a windows explorer (or My Computer) window, it get expanded to the correct value for your account.

    So:

    %LOCALAPPDATA%\Microsoft\VisualStudio\10.0\ComponentModelCache

    becomes:

    C:\Users\account_name\AppData\Local\Microsoft\VisualStudio\10.0\ComponentModelCache

    Same for any line with %something% in it.

     


    Yann

    (plus ça change, plus c'est la même chose!)


    Thursday, July 28, 2011 6:11 AM
  • Worked for me guys.

    Cheers.

     

    Paul

    Thursday, July 28, 2011 6:14 AM
  • That worked fine, thanks a lot! :)
    Thursday, July 28, 2011 6:24 AM
  • Thanks Yann, I see what you mean now.

    I am however working on an XP machine so they where sitting in a different folder.

    This has now fixed the icons problem.

    As always, many thanks...

    Nick

    Thursday, July 28, 2011 8:32 AM
  • You're welcome.

    That's actually the "advantage" of using the replaceable parameters, they'll always resolve to the correct folder, according to the OS, whereas a hard-coded path will be wrong for some people, as it was for you.


    Yann

    (plus ça change, plus c'est la même chose!)

    Thursday, July 28, 2011 8:57 AM
  • Worked for me.
    Thursday, July 28, 2011 1:21 PM
  • We have a theory on our side that we are currently investigating, but I wanted to post it out in case anyone wants to give it a try and help us confirm that it truly does fix the issue. We believe if you close the IDE, delete the following folders, and restart the IDE that it might fix the issue. These folders are for the MEF cache so deleting them shouldn't have a negative effect. It will just rebuild the cache the next time it is needed.

    %LOCALAPPDATA%\Microsoft\VisualStudio\10.0\ComponentModelCache
    %LOCALAPPDATA%\Microsoft\VisualStudio\10.0\ManifestCache


    Patrick Baker (Visual Studio LightSwitch Test Lead)

    Another confirm here, deleting this folder got icons back. Thanks!

    Mine icons disappeared sometime after I did Repair installation of Lightswitch (Visual Studio 2010 Ultimate SP1, Windows 7 64-bit, uninstall beta2 before first installation, had some SQL Server Express issues on my side). 

    Thursday, July 28, 2011 2:21 PM
  • I am glad we could narrow this down and get everyone unblocked so quickly. Enjoy LightSwitch!


    Patrick Baker (Visual Studio LightSwitch Test Lead)
    Thursday, July 28, 2011 2:58 PM
  • Another confirm here


    Mike Hurley MillStream Designs Limited
    Saturday, July 30, 2011 3:40 PM
  • We have a theory on our side that we are currently investigating, but I wanted to post it out in case anyone wants to give it a try and help us confirm that it truly does fix the issue. We believe if you close the IDE, delete the following folders, and restart the IDE that it might fix the issue. These folders are for the MEF cache so deleting them shouldn't have a negative effect. It will just rebuild the cache the next time it is needed.

    %LOCALAPPDATA%\Microsoft\VisualStudio\10.0\ComponentModelCache
    %LOCALAPPDATA%\Microsoft\VisualStudio\10.0\ManifestCache


    Patrick Baker (Visual Studio LightSwitch Test Lead)

    This worked great for me. Thank you for the fix!
    Tuesday, August 02, 2011 2:47 PM
  • Worked for me too ..... marvelous
    There's no right way ... but there may be a better way
    Friday, August 05, 2011 1:02 PM
  • I cut and paste the lines in Windows XP, Windows Explorer and got this error message "The parameter is incorrect" any idea where I can find these folders under Windows XP?  Thanks.

     

    %LOCALAPPDATA%\Microsoft\VisualStudio\10.0\ComponentModelCache
    %LOCALAPPDATA%\Microsoft\VisualStudio\10.0\ManifestCache


     

     

     

    Monday, August 08, 2011 12:47 PM
  • Never mind I found the folders using Windows Search feature

    In my Winodws XP they are in C:\Documents and Settings\you account\LocalSettings\Application Data\Microsoft\VisualStudio\10.0...

    Delete the two folders and my icons are back in the designer.

    Monday, August 08, 2011 12:54 PM
  • The fix you suggested worked perfectly!  As soon as I did it, everything worked fine.  Thanks for the post!

     

    Bill

    Wednesday, August 17, 2011 1:14 AM
  • Confirmed here too. Thanks!
    Wednesday, August 17, 2011 8:27 PM