none
MSBuild Errors with DSL Tool

    Question

  • Hi,

    I am trying to build my DSL solution with MSBuild, and I am having the following errors:

    C:\Program Files (x86)\MSBuild\Microsoft\VisualStudio\TextTemplating\v10.0\Microsoft.TextTemplating.targets(468,5): error MSB4067: The element <ParameterGroup> beneath element <UsingTask> is unrecognized.

    C:\Program Files (x86)\MSBuild\Microsoft\VisualStudio\v10.0\VSSDK\Microsoft.VsSDK.Common.targets(102,9): error MSB4066: The attribute "AfterTargets" in element <Target> is unrecognized.

    I really don't know why these errors happen, my solution build correctly with VS.

    Thanks for any help,

    Regards

    Tuesday, January 25, 2011 10:52 AM

Answers

  • Hello Nicolas.

    I've just tried running MsBuild from A Visual Studio Command Prompt for VS2010 on a DSL and that worked fine.

    Did you use a Visual Studio Command Prompt?

    Thanks

    Best regards


    Jean-Marc
    • Marked as answer by Nicolas Roux Tuesday, January 25, 2011 1:20 PM
    Tuesday, January 25, 2011 12:33 PM

All replies

  • Hello Nicolas.

    I've just tried running MsBuild from A Visual Studio Command Prompt for VS2010 on a DSL and that worked fine.

    Did you use a Visual Studio Command Prompt?

    Thanks

    Best regards


    Jean-Marc
    • Marked as answer by Nicolas Roux Tuesday, January 25, 2011 1:20 PM
    Tuesday, January 25, 2011 12:33 PM
  • Hello Jean-Marc,

    The VS path was correct but I was using a bad MSBuild path, wich was still in 3.5 (my mistake with a copy-paste from my VS2008 Build process).

    Thanks for your help !

    Tuesday, January 25, 2011 1:20 PM