none
Cannot upgrade - Microsoft .NET Framework 3.5 Service Pack 1 and .NET Framework 3.5 Family Update for .NET versions 2.0 through 3.5 (KB951847) x86

    Question

  • Cannot upgrade - Microsoft .NET Framework 3.5 Service Pack 1 and .NET Framework 3.5 Family Update for .NET versions 2.0 through 3.5 (KB951847) x86. Error Code: 0x645
    Tuesday, May 03, 2011 1:46 AM

Answers

  • Hi punsch,

     

    Welcome to the MSDN forum.

     

    According to the information you provided, could you please tell me which version of OS you are using? Different version of OS contains different version of .NET Framework. After I know which version your OS have, I could give you the better way to upgrade.

     

    Now if your OS is not Windows 7 or Windows Server 2008 R2 and want to upgrade from .NET Framework 2.0 to .NET Framework 3.5 sp1, I suggest you firstly uninstall the all .NET Framework components which you fail to install. Secondly I advise you to download the .NET Framework 3.5 Service Pack 1(Full Package) from here: http://www.microsoft.com/downloads/en/details.aspx?FamilyID=d0e5dea7-ac26-4ad7-b68c-fe5076bba986

     

    I have searched an article applied to KB951847 in Microsoft Support which maybe will help you ( http://support.microsoft.com/kb/951847).

     

    If I have any misunderstood anything, please feel free to let me know.

     

    Best Regards,

    Thursday, May 05, 2011 2:19 AM

All replies

  • Hi,

      I think you applying the update on .NET framework 2.0. If so please download and install .NET Framework 3.5 and install. After that you can try SP1. Or else you can directly install the .NET framework 3.5 SP1 from here...


    -- Thanks Ajith R [MCTS:ASP.NET&Win Forms]
    Tuesday, May 03, 2011 6:20 AM
  • Hi punsch,

     

    Welcome to the MSDN forum.

     

    According to the information you provided, could you please tell me which version of OS you are using? Different version of OS contains different version of .NET Framework. After I know which version your OS have, I could give you the better way to upgrade.

     

    Now if your OS is not Windows 7 or Windows Server 2008 R2 and want to upgrade from .NET Framework 2.0 to .NET Framework 3.5 sp1, I suggest you firstly uninstall the all .NET Framework components which you fail to install. Secondly I advise you to download the .NET Framework 3.5 Service Pack 1(Full Package) from here: http://www.microsoft.com/downloads/en/details.aspx?FamilyID=d0e5dea7-ac26-4ad7-b68c-fe5076bba986

     

    I have searched an article applied to KB951847 in Microsoft Support which maybe will help you ( http://support.microsoft.com/kb/951847).

     

    If I have any misunderstood anything, please feel free to let me know.

     

    Best Regards,

    Thursday, May 05, 2011 2:19 AM