none
"unable to connect to Microsoft Visual Studio Remote Debugging monitor" with two computers on the Internet

    Question

  • I need to remote debug an asp.net app on a Windows 2003 from a Windows XP Pro running VS 2008 SP1. Both machines are stand alone on the Internet. Xp can see and ping the server. I haven't tried the other way round. The XP is my home machine behind a home router.
    I went through this KB: http://support.microsoft.com/kb/908099

    When I tried the Remote transport, VS was able to get a list of the remote processes. However I need to use the default transport to debug managed app but I keep getting the error mentioned.

    I am using the same username and password of both machines. Both are admins. I disabled both firewalls. DCom is enabled. Network security is Classic for local users.

    I am running out of ideas on why VS can't connect to the remote debugger. Does default transport use port 4015? Because I can telnet to it in Remote transport mode but not in default mode.

    Are there other settings need to be enabled? Does file and print sharing need to be enabled? Which services need to be running? dcom/dcom settings? I feel this is a network or communication issue.

    Tuesday, December 23, 2008 9:19 AM

Answers

  • Hi

    I'm sorry for the delay follow up, based on our test, IP address could be used, so, please try to use: Tony@<IP address> to connect to the other machine.

    Besides, if you've already got a resolution on this, please share it with other community members who might have the same issue.
    If you encounter any other problems, please don't hesitate and tell us.

    Thanks in advance!
    Best regards,
    Roahn
    • Marked as answer by Roahn Luo Friday, January 02, 2009 3:41 AM
    Monday, December 29, 2008 5:40 AM

All replies

  • Hello,

    Firstly, I would like to clarify a couple of things on those two modes:
    1. Default mode only works when Remote Debug Monitor uses Windows Authentication.
    2. Usually, Default and Remote Transport modes are using different names:
        Remote mode: <Machine Name>
        Default mode: <UserName@MachineName>
        Please double check the name you input.
    3. Default transpost don't have to use port 4015 but we must use port 4015 for Remote Mode.

    Based on the error message, we would like you to:
    1. make sure that the Remote Debugging Monitor is properly installed and running when you debugging.
    2. make sure that the Remote Server Name is correctly input.
    3. make sure the Remote machine is accessible on the network.

    Hoping that could help you, if you have any questions, please don't hesitate and tell us!
    Best regards,
    Roahn
    Wednesday, December 24, 2008 9:59 AM
  • Hi

    Thanks for your reply.

    In the remote debugger, authentication is set to Windows.

    The server is on the Internet so what would be the qualifier? Something like: domainname.com\Tony@MachineName?
    Can an ip address be used? The two machines are not part of a domain. They are completely independent of each other. They are not part of any domains.
    Wednesday, December 24, 2008 5:51 PM
  • Hi

    I'm sorry for the delay follow up, based on our test, IP address could be used, so, please try to use: Tony@<IP address> to connect to the other machine.

    Besides, if you've already got a resolution on this, please share it with other community members who might have the same issue.
    If you encounter any other problems, please don't hesitate and tell us.

    Thanks in advance!
    Best regards,
    Roahn
    • Marked as answer by Roahn Luo Friday, January 02, 2009 3:41 AM
    Monday, December 29, 2008 5:40 AM
  • It's not working. I get an error message "Unable to connect to Microsoft Visual Studio Remote Debugging Monitor named 'Tony@xx.xx.xx.xx'. There is no server by the specified name running on the remote computer. I disabled the firewall on the remote server. I can ping the server from the VS machine. I am logged in as Tony on the VS machine and as Tony on the remote server and they are both admins and use the same password.

    Are there any methods to troubleshoot this?

    Saturday, January 03, 2009 5:49 PM
  • What is the "server name"exactly and does it need to be a in certain format?

    Because in VS the qualifier field is in the format of username@ipaddress while on the remote server, the server name is username@machinename. It doesn't like to use ipaddress.

    The firewall on the remote server doesn't prompt an authorization message when I connection is received.
    Usually I have to manually grant permission but the absence of such a message implies that there isn't a request coming from the VS machine.
    Monday, January 05, 2009 6:58 AM
  • "There is no server by the specified name running on the remote computer" --> that's the name of the remote debugger's named pipes server. You'll get the message if you mismatch Visual Studio and msvsmon versions (for instance, using the VS2005 remote debugger with VS2008). The message means that you passed smb/msrpc authentication (that's half the battle right there) but Visual Studio couldn't find the right named pipe. It would be nice if VS listed the VisualStudio pipes it did find so you'd know what happened, but that would be too easy. I don't remember how you enumerate pipes natively offhand, but if you happen to have Python, you can:

    import os
    os.listdir('//./pipe')

    • Proposed as answer by Roger Tranchez Monday, August 27, 2012 3:52 PM
    Monday, January 12, 2009 11:17 PM
  • Named pipes doesn't work across the Internet.. right? How do I make VS and the debugger both use TCP/IP? Why is it working when using anonymous users... is it using tcp/ip?
    Thursday, January 15, 2009 6:30 PM
  • Wow!  You're a lifesaver Tim, not sure if this fixed abdu's problem but it sure fixed mine when I arrived here on google.

    Yet another instance of "a clear error message would be too easy"...

    Tuesday, December 28, 2010 4:39 AM
  • Y-E-S ! Thanks, Tim.

    In my case the problem was that I was trying to connect from Visual Studio 2010, but the remote debugger I had installed on the server was still for Visual Studio 2008.

    How did you know that the message was related to this solution ? the remote debugger does not tell us nothing about it, as usual !

    Best regards,

    Roger

    Monday, August 27, 2012 3:56 PM
  • I've found alot of ppl bump into this scenario. Tried to cup the solution in my blog post:
    http://livshitz.wordpress.com/2013/02/26/remote-debugging-visual-studio-unable-to-connect-to-the-microsoft-visual-studio-remote-debugging-monitor/#more-144


    Here is the snippet of the solution:

    Make sure firewall is not blocking your request
    Make sure the installed version of Visual Studio Remote Debugging Monitor is supported by the running Visual Sutdio
    Create local user on remote target, with the exact user name and password as the debugging user (that runs VS process)
    If dns resolving is unavailable (source and target on different domains) open this file
    "c:\Windows\system32\drivers\etc\hosts"
    and add a new line at the bottom:
    "xxx.xxx.xxx.xxx TargetHostName" (without quotes)
    This will map the target host name with an IP.
    Tuesday, February 26, 2013 9:23 AM