none
Error while trying to run project: unable to start debugging

    Question

  • Hello all,

    i'm currently working on an add-in for microsoft Excel and i have many
    problem to debug my code.
    I checked the 'properties - configuration debugging - start external
    program' it's correctly filled with my Excel.exe path

    But when i run a debug there is an error message :

    Error while trying to run project: unable to start debugging
    Unable to start program 'C:\Program Files\Microsoft Office\OFFICE11\EXCEL.EXE'


    Please help me.

     

    Regards

    Prakash

    Tuesday, November 21, 2006 6:47 AM

All replies

  • What configuration settings you are doing in config file .Can you please give the details of those settings .
    • Proposed as answer by Diaz Loya Saturday, October 13, 2012 7:19 PM
    Tuesday, November 21, 2006 10:02 AM
  • Hi,

    I have the same problem.  Everything was fine until VS 2003 service pack 1.
    Friday, December 22, 2006 7:53 PM
  • Hi,

    I have the same problem.  I got this error after installing VS2003 SP1.
    Tuesday, December 26, 2006 9:39 AM
  • Same here, I was able to debug before installing VS 2003 SP1. Now I get this error

    "Error while trying to run project: unable to start debugging. Unable to start the program "c:\...myprogram.exe"
    I am able to debug using Windows Task Manager right click on the exe and attach the process to the visual studio environment.

    Can anybody tell me how to uninstall SP1 for Visual Studio ?

     

     

     

     

    Monday, May 14, 2007 6:54 PM
  • Hi,

     

    I am seeing a similar problem.

    • Using Visual Studio 2003 Professional
    • I had some projects on a hard drive that worked fine (debugger and everything).
    • My machine was upgraded and all VS2003 project information was copied to the new hard drive.
    • Visual Studio 2003 was reinstalled.
    • The projects compile, but the debugger does not work when started from VS.  Error message being seen is:
      "Error while trying to run project: Unable to start debugging.   Unable to start program 'CStick out tonguerogram Files\Microsoft Office\Office11\EXCEL.EXE'."
    • I can execute the Excel application and attach to the existing process id from VS, but that does not help when trying to debug initialization issues.
    • I have tried many of the suggested solutions (mdm registration, unmanaged debugging flag change, etc.).

    Any help would be appreciated.

    Monday, July 09, 2007 5:25 PM
  • The solution at this link solved my problem.

     

    http://blogs.technet.com/monicaboris/archive/2006/09/06/454421.aspx

     

     

     

     CxConrad wrote:

    Hi,

     

    I am seeing a similar problem.

    • Using Visual Studio 2003 Professional
    • I had some projects on a hard drive that worked fine (debugger and everything).
    • My machine was upgraded and all VS2003 project information was copied to the new hard drive.
    • Visual Studio 2003 was reinstalled.
    • The projects compile, but the debugger does not work when started from VS.  Error message being seen is:
      "Error while trying to run project: Unable to start debugging.   Unable to start program 'Crogram Files\Microsoft Office\Office11\EXCEL.EXE'."
    • I can execute the Excel application and attach to the existing process id from VS, but that does not help when trying to debug initialization issues.
    • I have tried many of the suggested solutions (mdm registration, unmanaged debugging flag change, etc.).

    Any help would be appreciated.

    Monday, July 09, 2007 5:45 PM
  •  

    Hi, CxConrad,

     

    I have exactly same problem with you. Would you please tell how the configure file was specified? My application generate a dll file (ex. myapp.dll). Should the configure file be named as myapp.dll.config and put the bin directory?

     

    Thanks

    Thursday, December 27, 2007 9:23 PM
  • I resolved this problem by setting Framework 1.1 for this particular website from IIS manager. As installing Asp.net 2.0 overrides all the website settings.
    Tuesday, July 01, 2008 4:51 AM