none
VS2008 SP1 - Install failed on product (Microsoft Office Visual Web Developer 2007).

    Question

  • Hi

    I am getting the following error:

    C:\Users\morb\AppData\Local\Temp\Microsoft Visual Studio 2008 SP1\VC_IA64Runtime.exe - Exe installer's log file/hint (%temp%\dd_VC_IA64Runtime*.txt|%temp%\..\dd_VC_IA64Runtime*.txt) does not exist or is invalid.

    Exe (C:\Users\morb\AppData\Local\Temp\Microsoft Visual Studio 2008 SP1\VC_IA64Runtime.exe) succeeded.
    Patch (C:\Users\morb\AppData\Local\Temp\Microsoft Visual Studio 2008 SP1\WebDesignerCore_KB950278.msp) install succeeded on product (Microsoft Office Enterprise 2007).
    Patch (C:\Users\morb\AppData\Local\Temp\Microsoft Visual Studio 2008 SP1\WebDesignerCore_KB950278.msp) install succeeded on product (Microsoft Office Visio Professional 2007).
    Patch (C:\Users\morb\AppData\Local\Temp\Microsoft Visual Studio 2008 SP1\WebDesignerCore_KB950278.msp) install failed on product (Microsoft Office Visual Web Developer 2007).
    Final Result: Installation failed with error code: (0x80070643), Fatal error during installation.

    Any help will be much appreciated.

    /morten
    Saturday, August 16, 2008 10:39 AM

Answers

  • error code 0x80070643 is a failure with Windows Update not completing a file download and not with the service pack setup itself. 
    If this problem occurs repeatedly then please clear the Windows Update temporary downloads cache: (clear the content of C:\Program Files\WindowsUpdate, and %temp%)

    If you still see this problem, please follow What to do when you go to post a setup and deployment issue on the MSDN forums?
    http://blogs.msdn.com/aaronru/archive/2007/12/10/what-to-do-when-you-go-to-post-a-setup-and-deployment-issue-on-the-msdn-forums.aspx for more information.

    Thanks.

    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    • Marked as answer by Figo Fei Monday, August 25, 2008 4:19 AM
    Monday, August 18, 2008 8:03 AM
  • I have been facing similar issue with WebDesignerCore_KB950278.msp patch while installing VS2008_SP1 setup.  Thanks to Microsoft support, I was able to resolve this issue by doing the following steps:

    1-Get the Installation source of Visual Web Developer product.

    Run RegEdit and get the InstallSource value from following key:

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall\{90120000-0021-0000-0000-0000000FF1CE}


    2-Rename or Delete all Visual Web Developer related keys.

    Open RegEdit  and Rename or Delete all the following keys:

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall\{90120000-0021-0000-0000-0000000FF1CE}

    HKEY_CLASSES_ROOT\Installer\Products\00002109120000000000000000F01FEC

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Installer\UserData\S-1-5-18\Products\00002109120000000000000000F01FEC


    3-Re-Install Visual We Developer.

    Run setup.exe  from Office cache folder location (from step#1).  For example on my PC it was something like this:
    C:\MSOCache\All Users\{90120000-0021-0000-0000-0000000FF1CE}-C\

    4-Run VS2008_SP1 setup again



    • Marked as answer by Figo Fei Thursday, July 02, 2009 2:57 AM
    Wednesday, July 01, 2009 10:47 PM

All replies

  • error code 0x80070643 is a failure with Windows Update not completing a file download and not with the service pack setup itself. 
    If this problem occurs repeatedly then please clear the Windows Update temporary downloads cache: (clear the content of C:\Program Files\WindowsUpdate, and %temp%)

    If you still see this problem, please follow What to do when you go to post a setup and deployment issue on the MSDN forums?
    http://blogs.msdn.com/aaronru/archive/2007/12/10/what-to-do-when-you-go-to-post-a-setup-and-deployment-issue-on-the-msdn-forums.aspx for more information.

    Thanks.

    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    • Marked as answer by Figo Fei Monday, August 25, 2008 4:19 AM
    Monday, August 18, 2008 8:03 AM
  • I have been facing similar issue with WebDesignerCore_KB950278.msp patch while installing VS2008_SP1 setup.  Thanks to Microsoft support, I was able to resolve this issue by doing the following steps:

    1-Get the Installation source of Visual Web Developer product.

    Run RegEdit and get the InstallSource value from following key:

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall\{90120000-0021-0000-0000-0000000FF1CE}


    2-Rename or Delete all Visual Web Developer related keys.

    Open RegEdit  and Rename or Delete all the following keys:

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall\{90120000-0021-0000-0000-0000000FF1CE}

    HKEY_CLASSES_ROOT\Installer\Products\00002109120000000000000000F01FEC

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Installer\UserData\S-1-5-18\Products\00002109120000000000000000F01FEC


    3-Re-Install Visual We Developer.

    Run setup.exe  from Office cache folder location (from step#1).  For example on my PC it was something like this:
    C:\MSOCache\All Users\{90120000-0021-0000-0000-0000000FF1CE}-C\

    4-Run VS2008_SP1 setup again



    • Marked as answer by Figo Fei Thursday, July 02, 2009 2:57 AM
    Wednesday, July 01, 2009 10:47 PM
  • Hi there,


    I am running into the same problem with 'WebDesignerCore_KB950278.msp' when installing VS2008 SP1. I have tried the steps in Tom's post and it did not work for me.

    is there a way to bypass the update to visual Web Developer 2007?

    This is the error log file: (I would have attached it instead of pasting it here but did not know how)

    Thank you very much for your help.

    Charles Li

    === Verbose logging started: 7/6/2009  12:37:41  Build type: SHIP UNICODE 3.01.4001.5512  Calling process: D:\vs90sp1\SPInstaller.exe ===
    MSI (c) (60:1C) [12:37:41:358]: Resetting cached policy values
    MSI (c) (60:1C) [12:37:41:358]: Machine policy value 'Debug' is 0
    MSI (c) (60:1C) [12:37:41:358]: ******* RunEngine:
               ******* Product: {90120000-0030-0000-0000-0000000FF1CE}
               ******* Action:
               ******* CommandLine: **********
    MSI (c) (60:1C) [12:37:41:358]: Client-side and UI is none or basic: Running entire install on the server.
    MSI (c) (60:1C) [12:37:41:358]: Grabbed execution mutex.
    MSI (c) (60:1C) [12:37:41:389]: Cloaking enabled.
    MSI (c) (60:1C) [12:37:41:389]: Attempting to enable all disabled priveleges before calling Install on Server
    MSI (c) (60:1C) [12:37:41:421]: Incrementing counter to disable shutdown. Counter after increment: 0
    MSI (s) (D8:00) [12:37:41:421]: Grabbed execution mutex.
    MSI (s) (D8:C4) [12:37:41:421]: Resetting cached policy values
    MSI (s) (D8:C4) [12:37:41:421]: Machine policy value 'Debug' is 0
    MSI (s) (D8:C4) [12:37:41:421]: ******* RunEngine:
               ******* Product: {90120000-0030-0000-0000-0000000FF1CE}
               ******* Action:
               ******* CommandLine: **********
    MSI (s) (D8:C4) [12:37:41:436]: Machine policy value 'DisableUserInstalls' is 0
    MSI (s) (D8:C4) [12:37:41:436]: End dialog not enabled
    MSI (s) (D8:C4) [12:37:41:436]: Original package ==> C:\WINDOWS\Installer\4c285.msi
    MSI (s) (D8:C4) [12:37:41:436]: Package we're running from ==> C:\WINDOWS\Installer\4c285.msi
    MSI (s) (D8:C4) [12:37:41:686]: APPCOMPAT: looking for appcompat database entry with ProductCode '{90120000-0030-0000-0000-0000000FF1CE}'.
    MSI (s) (D8:C4) [12:37:41:686]: APPCOMPAT: no matching ProductCode found in database.
    MSI (s) (D8:C4) [12:37:41:686]: MSCOREE not loaded loading copy from system32
    MSI (s) (D8:C4) [12:37:41:702]: Opening existing patch 'C:\WINDOWS\Installer\16c31b.msp'.
    MSI (s) (D8:C4) [12:37:41:702]: Note: 1: 2203 2: C:\WINDOWS\Installer\16c31b.msp 3: -2147287038
    MSI (s) (D8:C4) [12:37:41:702]: Couldn't find local patch 'C:\WINDOWS\Installer\16c31b.msp'. Looking for it at its source.
    MSI (s) (D8:C4) [12:37:41:702]: Resolving Patch source.
    MSI (s) (D8:C4) [12:37:41:702]: User policy value 'SearchOrder' is 'nmu'
    MSI (s) (D8:C4) [12:37:41:702]: User policy value 'DisableMedia' is 0
    MSI (s) (D8:C4) [12:37:41:702]: Machine policy value 'AllowLockdownMedia' is 0
    MSI (s) (D8:C4) [12:37:41:702]: SOURCEMGMT: Media enabled only if package is safe.
    MSI (s) (D8:C4) [12:37:41:702]: SOURCEMGMT: Looking for sourcelist for product {0B36C6D6-F5D8-4EAF-BF94-4376A230AD5B}
    MSI (s) (D8:C4) [12:37:41:702]: SOURCEMGMT: Adding {0B36C6D6-F5D8-4EAF-BF94-4376A230AD5B}; to potential sourcelist list (pcode;disk;relpath).
    MSI (s) (D8:C4) [12:37:41:702]: SOURCEMGMT: Now checking product {0B36C6D6-F5D8-4EAF-BF94-4376A230AD5B}
    MSI (s) (D8:C4) [12:37:41:702]: SOURCEMGMT: Media is enabled for product.
    MSI (s) (D8:C4) [12:37:41:702]: SOURCEMGMT: Attempting to use LastUsedSource from source list.
    MSI (s) (D8:C4) [12:37:41:702]: SOURCEMGMT: Processing net source list.
    MSI (s) (D8:C4) [12:37:41:702]: Note: 1: 1402 2: UNKNOWN\Net 3: 2
    MSI (s) (D8:C4) [12:37:41:702]: Note: 1: 1706 2: -2147483647 3: mainwwsp2.MSP
    MSI (s) (D8:C4) [12:37:41:702]: SOURCEMGMT: Processing media source list.
    MSI (s) (D8:C4) [12:37:41:702]: SOURCEMGMT: Resolved source to: 'mainwwsp2.MSP'
    MSI (s) (D8:C4) [12:38:11:858]: Note: 1: 1314 2: mainwwsp2.MSP
    MSI (s) (D8:C4) [12:38:11:858]: Unable to create a temp copy of patch 'mainwwsp2.MSP'.
    MSI (s) (D8:C4) [12:38:11:858]: Note: 1: 1708
    MSI (s) (D8:C4) [12:38:11:858]: Note: 1: 2729
    MSI (s) (D8:C4) [12:38:11:874]: Note: 1: 2729
    MSI (s) (D8:C4) [12:38:11:874]: Product: Microsoft Office Enterprise 2007 -- Installation failed.

    MSI (s) (D8:C4) [12:38:11:952]: MainEngineThread is returning 1635
    This patch package could not be opened.  Verify that the patch package exists and that you can access it, or contact the application vendor to verify that this is a valid Windows Installer patch package.
    C:\WINDOWS\Installer\4c285.msi
    MSI (c) (60:1C) [12:38:11:952]: Decrementing counter to disable shutdown. If counter >= 0, shutdown will be denied.  Counter after decrement: -1
    MSI (c) (60:1C) [12:38:11:952]: MainEngineThread is returning 1635
    === Verbose logging stopped: 7/6/2009  12:38:11 ===


    cli
    Monday, July 06, 2009 5:47 PM