none
ADO.NET Entity Model

    Question

  • Im having an error

    "The underlying provider failed on Open." when accessing a ADO.NET Entity Model when I set the datasource to "data source=10.200.9.46\sqlexpress" from "data source=.\sqlexpress".

    Im sure that the sqlexpress server instance is located at 10.200.9.46 but im not recieving the error when referring it locally by using the ".\sqlexpress"


    The more I study, the more I realize how little I know.

    Tuesday, March 13, 2012 8:48 PM

Answers

  • Hi,

    Can you access it from SQL ? maybe it is on a different port ? or remote connection is not enabled..

    http://www.linglom.com/2009/03/28/enable-remote-connection-on-sql-server-2008-express/

    Hope it helps :)


    If some code doesn't work, don't worry help is on the way.. don't forget to mark your thread as solved when done...

    Tuesday, March 13, 2012 8:58 PM
  • Hi Sheen Ismhael Lim,

      In additional to add the TCP/IP port access setting,I recommand you edit the  file context which name is hosts.  This file locates in Windows folder when you are running Windows98 system.If you are running under the Windows 2000/XP/Vista/Seven system,you can find this file located at %Systemroot%\System32\Drivers\Etc.Because hosts file has system attribute,you need to open my computer,and enter in tools menu to show all the files and folders.You only add the following line such as 127.0.0.1 localhost to the end of this file.

      I hope you will solve your problem.

    Sincerely,

    Jason Wang


    orichisonic http://blog.csdn.net/orichisonic If a post answers your question, please click "Mark As Answer" on that post and "Mark as Helpful".

    Wednesday, March 14, 2012 3:44 AM

All replies

  • Hi,

    Can you access it from SQL ? maybe it is on a different port ? or remote connection is not enabled..

    http://www.linglom.com/2009/03/28/enable-remote-connection-on-sql-server-2008-express/

    Hope it helps :)


    If some code doesn't work, don't worry help is on the way.. don't forget to mark your thread as solved when done...

    Tuesday, March 13, 2012 8:58 PM
  • Hi Sheen Ismhael Lim,

      In additional to add the TCP/IP port access setting,I recommand you edit the  file context which name is hosts.  This file locates in Windows folder when you are running Windows98 system.If you are running under the Windows 2000/XP/Vista/Seven system,you can find this file located at %Systemroot%\System32\Drivers\Etc.Because hosts file has system attribute,you need to open my computer,and enter in tools menu to show all the files and folders.You only add the following line such as 127.0.0.1 localhost to the end of this file.

      I hope you will solve your problem.

    Sincerely,

    Jason Wang


    orichisonic http://blog.csdn.net/orichisonic If a post answers your question, please click "Mark As Answer" on that post and "Mark as Helpful".

    Wednesday, March 14, 2012 3:44 AM
  • Is this an ASP.NET application?  Then probably the following link can help you:

    http://www.codeproject.com/Tips/126919/Solution-for-The-underlying-provider-failed-on-Ope


    Resolving n Evolving in C# (http://jeanpaulva.com)


    Wednesday, March 14, 2012 5:22 AM