locked
Automatic outlining (collapsible sections) does not start for .ASPX files in Visual Studio 2010 SP1

    Question

  • In Visual Studio 2010 SP1, automatic outlining is not enabled for ASPX files when I open them.  For each file opened, I need to click Edit / Outlining / Start automatic outlining, which is extremely annoying.  This step is not necessary when code-only (non-ASPX) files are opened.


    I use a few extensions, all of them from MS, including Power Tools, the JavaScript tools, etc., and I thought that maybe they were causing the problem, so I disabled all of them and restarted VS, but the problem still exists.


    I did not have this problem with VS2010 (no SP) on Win XP Pro, which I used for about 18 months, but I recently did a clean install of Win 7 x64, VS2010, and VS2010 SP1, and now I have this issue.


    Any ideas?

     

    Wednesday, August 31, 2011 2:42 PM

All replies

  • Hi BrianJFinkel,

    Please try to create two new project (one is the same type project as your previous project, one is another type project.) see whether this issue still exists.

    If this issue still exists, you can try the following solutions:

     1. If we reboot the operating system to safe mode, do we have the problem? This can help to isolate whether any other applications are interfering with Visual Studio. Note that some features (like IIS) are not available under safe mode. Please check whether this can apply or not. In addition to safe mode, we can also suggest “clean boot”: http://support.microsoft.com/kb/310353 .

    2. If we create a new user account, do we have the problem? This can help to isolate user profile corruption related causes.

    3. If we use “devenv.exe /resetsettings”, does it solve the problem? It restores Visual Studio default settings.

    4. If the problem remains, we can use Visual Studio Setup Wizard (via Control Panel) to repair Visual Studio. It can restore the Visual Studio Installation into its original state.

     

    Best regards,

    Lucy


    Lucy Liu [MSFT]
    MSDN Community Support | Feedback to us
    Get or Request Code Sample from Microsoft
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    • Marked as answer by lucy-liuModerator Wednesday, September 07, 2011 6:07 AM
    • Unmarked as answer by BrianJFinkel Wednesday, September 07, 2011 2:22 PM
    Friday, September 02, 2011 3:42 AM
  • I was kind of hoping that someone would be familiar with this problem or have some insight into its cause.  I will try some of these suggestions as soon as I have time... some of them will take a while.

    Also, know that I have an extremely clean, fresh install of Win 7 and VS.

    P.S. Why is this marked as the "answer" when I have not yet tried any of these suggestions?

    Wednesday, September 07, 2011 2:22 PM
  • Hi BrianJFinkel,

    I cannot reproduce this issue in my computer ( windows 7, VS2010 SP1). So I recommend you to try the above solutions.

    The following are what I have done:

    1.       Start VS2010;

    2.       Open an asp.net application;

    3.       Open an .aspx file;

    4.       Go to Edit->Outlining->Stop Outlining, we will find the Outlining is disable in the .aspx file;

    5.       Go to Edit->Outlining->Start Automatic Outlining, we will find the Outlining is re-enable in the .aspx file;

     

    Best regards,

    Lucy


    Lucy Liu [MSFT]
    MSDN Community Support | Feedback to us
    Get or Request Code Sample from Microsoft
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    Friday, September 09, 2011 5:55 AM
  • So, when you open the ASPX file, is outlining enabled or disabled?
    Friday, September 09, 2011 1:26 PM
  • Hi BrianJFinkek,

    When i open the ASPX file, the outlining is enabled.

     

     


    Lucy Liu [MSFT]
    MSDN Community Support | Feedback to us
    Get or Request Code Sample from Microsoft
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    Monday, September 12, 2011 3:18 AM
  • I am having this problem also. It started after doing a clean install of Windows 7 Pro and VS Express. I also tried VS Pro trial and got the same result. When I open any ASPX page, it always has outlining turned off. Selecting Edit->Outlining->Start Automatic Outlining does turn it on.
    Thursday, January 05, 2012 9:12 PM
  • I'm glad that I'm not the only one.  I have not had time to troubleshoot the issue further, but it is very annoying!  If you make any progress, please let me know...

     

    Brian

    Friday, January 06, 2012 2:49 PM
  • Exactly the same problem only I'm running Windows XP but it has been doing so since this PC was reloaded and VS2010 Sp1 installed.
    Tuesday, February 07, 2012 12:40 PM
  • I also have this (very annoying) problem. If anyone has a solution for this, please let us know...

    Thys Brits - MCSD/MCSD.Net

    Wednesday, May 09, 2012 10:20 AM
  • Found a solution on stackoverflow.com (which worked for me) - close your VS, then go to your registry and open HKEY_CURRENT_USER\Software\Microsoft\VisualStudio\10.0\HTML Editor

    There is a value in there OutlineHTMLOnFileOpen. Change the value of this to 1. If this value is set to -1 when you open it, it might mean that some other setting is overwriting this, though...


    Thys Brits - MCSD/MCSD.Net

    • Proposed as answer by ThysBrits Wednesday, May 09, 2012 10:28 AM
    Wednesday, May 09, 2012 10:28 AM
  • IT WORKS!!!

    However, it will change back to -1 by itself after a few days.


    - brian

    Wednesday, May 23, 2012 5:51 AM