none
CreateInstance failed for package [Microsoft.Data.Entity.Design.Package.MicrosoftDataEntityDesignPackage,

    Question

  • After some installs that were problematic (vs 2010 sp1), I'm unable to open my solutions with EntityFramework in the solution:

    The activity log outputs the following:

     

    364
    Begin package load [Microsoft.Data.Entity.Design.BootstrapPackage.BootstrapPackage, Microsoft.Data.Entity.Design.BootstrapPackage, Version=10.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a] {7A4E8D96-5D5B-4415-9FAB-D6DCC56F47FB}
    VisualStudio 2011/05/23 04:39:05.405
    365 ERROR CreateInstance failed for package [Microsoft.Data.Entity.Design.BootstrapPackage.BootstrapPackage, Microsoft.Data.Entity.Design.BootstrapPackage, Version=10.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a] {7A4E8D96-5D5B-4415-9FAB-D6DCC56F47FB} 80070002 VisualStudio 2011/05/23 04:39:05.409
    366 ERROR End package load [Microsoft.Data.Entity.Design.BootstrapPackage.BootstrapPackage, Microsoft.Data.Entity.Design.BootstrapPackage, Version=10.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a] {7A4E8D96-5D5B-4415-9FAB-D6DCC56F47FB} 80004005 - E_FAIL VisualStudio
    386
    Begin package load [Microsoft.Data.Entity.Design.Package.MicrosoftDataEntityDesignPackage, Microsoft.Data.Entity.Design.Package, Version=10.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a] {8889E051-B7F9-4781-BB33-2A36A9BDB3A5}
    VisualStudio 2011/05/23 04:39:12.225
    387 ERROR CreateInstance failed for package [Microsoft.Data.Entity.Design.Package.MicrosoftDataEntityDesignPackage, Microsoft.Data.Entity.Design.Package, Version=10.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a] {8889E051-B7F9-4781-BB33-2A36A9BDB3A5} 80070002 VisualStudio 2011/05/23 04:39:12.234
    388 ERROR End package load [Microsoft.Data.Entity.Design.Package.MicrosoftDataEntityDesignPackage, Microsoft.Data.Entity.Design.Package, Version=10.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a] {8889E051-B7F9-4781-BB33-2A36A9BDB3A5} 80004005 - E_FAIL VisualStudio

     

    Any ideas what I need to do to recover?

    Monday, May 23, 2011 4:47 AM

Answers

  • Hi JAldons,

    Thanks for your post.

    There are several things I would like to clarify with you:

    • Did the installation of Visual Studio 2010 SP1 return successful? Are there any problem occurs during the installation?
    • When open a project referenced Entity Framework, what is the error message you received?
    • If create a new project, add reference Microsoft.Data.Entity.Design.Extensibility, are there any error occurs?

    According to the error message, it appears that some Entity Framework related package fail to load while starting Visual Studio IDE. Would you please help to send the entire activity log file to me for further diagnose? (E-mail: v-anwu_at_microsoft_dot_com) Note: Please attach the link of this post in the mail.

    Would you please try to run devenv /ResetSkipPkgs in Command Prompt to load default VSPackages? You can also try devenv /Resetsettings and devenv /Safemode to see if you can apply it correctly.

    Also, please check if the Microsoft.Data.Entity.Design.BootstrapPackage.dll and Microsoft.Data.Entity.Design.Package.dll exists in the <Visual Studio installation path>\Common7\IDE\ folder.

    If still avail, you can try to repair Visual Studio 2010 SP1 via Control Panel >> Program and features to see it works.

    Waiting to hear from you.

    Best Regards,


    Andrew Wu [MSFT]
    MSDN Community Support | Feedback to us
    Get or Request Code Sample from Microsoft
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    Wednesday, May 25, 2011 7:21 AM

All replies

  • Hi JAldons,

    Thanks for your post.

    There are several things I would like to clarify with you:

    • Did the installation of Visual Studio 2010 SP1 return successful? Are there any problem occurs during the installation?
    • When open a project referenced Entity Framework, what is the error message you received?
    • If create a new project, add reference Microsoft.Data.Entity.Design.Extensibility, are there any error occurs?

    According to the error message, it appears that some Entity Framework related package fail to load while starting Visual Studio IDE. Would you please help to send the entire activity log file to me for further diagnose? (E-mail: v-anwu_at_microsoft_dot_com) Note: Please attach the link of this post in the mail.

    Would you please try to run devenv /ResetSkipPkgs in Command Prompt to load default VSPackages? You can also try devenv /Resetsettings and devenv /Safemode to see if you can apply it correctly.

    Also, please check if the Microsoft.Data.Entity.Design.BootstrapPackage.dll and Microsoft.Data.Entity.Design.Package.dll exists in the <Visual Studio installation path>\Common7\IDE\ folder.

    If still avail, you can try to repair Visual Studio 2010 SP1 via Control Panel >> Program and features to see it works.

    Waiting to hear from you.

    Best Regards,


    Andrew Wu [MSFT]
    MSDN Community Support | Feedback to us
    Get or Request Code Sample from Microsoft
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    Wednesday, May 25, 2011 7:21 AM
  • Hi JAldons,

    We have not heard from you in a couple of days. Would you mind letting me know the result of the suggestions?

    If you need further assistance, feel free to let me know. I will be more than happy to be of assistance.

    Best Regards,


    Andrew Wu [MSFT]
    MSDN Community Support | Feedback to us
    Get or Request Code Sample from Microsoft
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    Friday, May 27, 2011 10:00 AM
  • Hi Andrew,

     

    I'm having the same issue and have emailed you the activity log.  I have tried all the solutions you mentioned but none have worked for me.  Repairing SP1 fails.

     

    Thanks

    Phil

    Tuesday, June 07, 2011 9:58 PM
  • Don't know if this will help you, Phil, but I tried everything that Andrew suggested and still got the error message.  I was able to reapply SP1 successfully (twice)  but that didn't help either. In the end I just registered the Microsoft.Data.Entity.Design.Package.dll  with regasm   and the error went away.

     

    Keith

    Friday, June 10, 2011 10:37 PM
  • Hi Keith,

     

    It's well worth a try... thanks for letting me know about this solution.

    Do you know where I can retrieve the dll ?  I've not been able to locate it on my computer.  Is it on the VS 2010 disk or in the new release?

     

    Cheers

    Phil

    Tuesday, June 14, 2011 3:17 AM
  • My activity log shows:

    317 ERROR CreateInstance failed for package [Microsoft.Data.Entity.Design.Package.MicrosoftDataEntityDesignPackage, Microsoft.Data.Entity.Design.Package, Version=10.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a] {8889E051-B7F9-4781-BB33-2A36A9BDB3A5} 8007000e - E_OUTOFMEMORY VisualStudio 2011/07/05 23:10:19.557
    318 ERROR End package load [Microsoft.Data.Entity.Design.Package.MicrosoftDataEntityDesignPackage, Microsoft.Data.Entity.Design.Package, Version=10.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a] {8889E051-B7F9-4781-BB33-2A36A9BDB3A5} 80004005 - E_FAIL VisualStudio

     

    I have tried to install EF4.1, but it never finishes.  I tried RegAsm as described above, but that failed.


    jon b
    Wednesday, July 06, 2011 2:44 PM
  • Uninstalled EF4.1, then reinstalled. Seems ok.
    jon b
    Wednesday, July 06, 2011 10:39 PM
  • EF4.1 not working. Uninstalled it. Tried reapplying VS2010 SP1. Now get this when launching VS:

     

    312 ERROR CreateInstance failed for package [Microsoft.Data.Entity.Design.Package.MicrosoftDataEntityDesignPackage, Microsoft.Data.Entity.Design.Package, Version=10.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a] {8889E051-B7F9-4781-BB33-2A36A9BDB3A5} 80131018 VisualStudio 2011/07/22 15:19:22.734
    313 ERROR End package load [Microsoft.Data.Entity.Design.Package.MicrosoftDataEntityDesignPackage, Microsoft.Data.Entity.Design.Package, Version=10.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a] {8889E051-B7F9-4781-BB33-2A36A9BDB3A5} 80004005 - E_FAIL VisualStudio

     


    jon b
    Friday, July 22, 2011 3:26 PM
  • Mr Wu, a email have sent to you mailbox. Check it please, I beg for you help...THANKS.
    Sunday, January 29, 2012 5:59 PM
  • Monday, March 04, 2013 4:15 PM