none
Only option under "File" is "New Team Project"

    Question

  • Hello,

    When I try to create a new project under "File"  the only option I get is:
    - New Team Project
    - Connect to Team Project

    - New File
    - Open File

    Any idea why I don't see the normal new project options?

    I have installed, removed and reinstalled VS 2010 Premium 3 times in an attempt to fix this problem I cannot seem to get it to work correctly.  I'm stumped.

    Bob

    Monday, July 12, 2010 1:05 AM

Answers

  • Hi Bob,

    Thank you for your post.

    Based on your description, it looks like that you have installed Team Explorer 2010 instead of Visual Studio 2010.

    Team Explorer 2010 is a simplified Visual Studio Team System 2010 environment used solely to access Team Foundation Server services. It applies the similar shell as Visual Studio. However, we cannot create new projects via Team Explorer.
    Thus, you can find only two options related to Team project when you go to File menu.

    You can check Help Menu >> About Microsoft Visual Studio >> Installed products. You might find the following component:

    Microsoft Visual Studio 2010 Team Explorer

    Hope this helps! If you have any concern, please feel free to let me know.

    Best regards,
    Yichun Chen


    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    Welcome to the All-In-One Code Framework! If you have any feedback, please tell us.
    • Proposed as answer by Steff24 Saturday, July 17, 2010 3:07 PM
    • Marked as answer by YiChun Chen Monday, July 19, 2010 9:00 AM
    Tuesday, July 13, 2010 10:21 AM

All replies

  • Hi Bob,

    Thank you for your post.

    Based on your description, it looks like that you have installed Team Explorer 2010 instead of Visual Studio 2010.

    Team Explorer 2010 is a simplified Visual Studio Team System 2010 environment used solely to access Team Foundation Server services. It applies the similar shell as Visual Studio. However, we cannot create new projects via Team Explorer.
    Thus, you can find only two options related to Team project when you go to File menu.

    You can check Help Menu >> About Microsoft Visual Studio >> Installed products. You might find the following component:

    Microsoft Visual Studio 2010 Team Explorer

    Hope this helps! If you have any concern, please feel free to let me know.

    Best regards,
    Yichun Chen


    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    Welcome to the All-In-One Code Framework! If you have any feedback, please tell us.
    • Proposed as answer by Steff24 Saturday, July 17, 2010 3:07 PM
    • Marked as answer by YiChun Chen Monday, July 19, 2010 9:00 AM
    Tuesday, July 13, 2010 10:21 AM
  • How do i can from Microsoft Visual Studio 2010 Team Explorer 

    to VB view?

    Saturday, July 17, 2010 3:09 PM
  • I had the same problem, it defaults to Team Explorer view.

    To change it go Tools > Import/Export settings > Import. Follow the on screen prompts.

    Monday, October 04, 2010 12:25 PM
  • Hi,

    I have the same problem. I downloaded the VS2010 Professional and all I get is the New Team Project.  I just want "New Project" I do not mind theteam option, but I dont want all my little games to be on the server. Best is both. But not just the Team.

    What do I need to change in my confogiration or installation to have the dual option or just the NewProject?

     

    Thanks,

    Mickey

    Wednesday, November 03, 2010 2:15 AM
  • Wow, great!!! I solve my problem jus

    To change it go Tools > Import/Export settings > Import. Follow the on screen prompts. THanks

    Wednesday, January 05, 2011 1:15 PM
  • Hey,

    Indeed this did the trick. Curious because we have full visual studio installed with team explorer and suddenly the menu's where changed.

    Thanks !

    Kind regards


    it's all very nice when it works

    Thursday, June 14, 2012 8:56 AM
  • Go to Tools---- Import and Exporting --- Reset All Items ---- Click on Next-- Select 'Visual C# Development Settings'--- Click on Next - Finish. Check Now.

    Monday, November 12, 2012 7:45 PM
  • Thank you solution i useful i love you thanksssssss
    Wednesday, March 12, 2014 2:07 PM