none
The application-specific permission settings do not grant Local Activation permission for the COM Server application with CLSID {61738644-F196-11D0-9953-00C04FD919C1}

    Question

  • TFS 2010 on Windows Server 2008 R2 Enterprise. Every few hours we are getting the following error in event log:

    The application-specific permission settings do not grant Local Activation permission for the COM Server application with CLSID 
    {61738644-F196-11D0-9953-00C04FD919C1}
     and APPID 
    {61738644-F196-11D0-9953-00C04FD919C1}
     to the user ... from address LocalHost (Using LRPC). This security permission can be modified using the Component Services administrative tool.

    The CLSID is of IIS WAMREG admin Service. And if we go to Component Services to configure security permissions all controls on security page of IIS WAMREG admin Service are disabled.

    How do we fix this error?

    Wednesday, May 05, 2010 6:33 PM

Answers

  • Hi Alex,

    Please perform the following steps:

    1.       Start ->Run-> regedit

    2.       Copy the GUID following the CLSID above

    3.       In the registry editor, ensure that your cursor is on the computer at the beginning of the tree

    4.   From the menu, Edit->Find, paste in the GUID. It'll stop at the application entry - and you will want to note the application name on the right side pane. In this example, it was the IIS WAMREG admin service that popped up.

    5.       Start-->Administrative Tools-->Component Services

    6.       Expand Component Services, Computers, My Computer, DCOM Config. Scroll down and find the application (IIS WAMREG in this case)

    7.       Right-click on IIS WAMREG Server, select Properties and select the Security tab

    8.       Launch and Activation Permissions, ensure that the Customize radio button is selected, and click Edit

    9.       Add your service account, giving it launch and activate and in some requirements - remote launch / activate permission

    10.   Restart IIS and continue on

    You can refer here to solve the disabled controls on security page of IIS WAMEG admin Serice.

    Hope it helps!

    If you have any concern, please feel free to let me know!

    Best Regards,

    Cathy Kong

     

    Tuesday, May 11, 2010 7:24 AM
    Moderator

All replies

  • Hi Alex,

    Please perform the following steps:

    1.       Start ->Run-> regedit

    2.       Copy the GUID following the CLSID above

    3.       In the registry editor, ensure that your cursor is on the computer at the beginning of the tree

    4.   From the menu, Edit->Find, paste in the GUID. It'll stop at the application entry - and you will want to note the application name on the right side pane. In this example, it was the IIS WAMREG admin service that popped up.

    5.       Start-->Administrative Tools-->Component Services

    6.       Expand Component Services, Computers, My Computer, DCOM Config. Scroll down and find the application (IIS WAMREG in this case)

    7.       Right-click on IIS WAMREG Server, select Properties and select the Security tab

    8.       Launch and Activation Permissions, ensure that the Customize radio button is selected, and click Edit

    9.       Add your service account, giving it launch and activate and in some requirements - remote launch / activate permission

    10.   Restart IIS and continue on

    You can refer here to solve the disabled controls on security page of IIS WAMEG admin Serice.

    Hope it helps!

    If you have any concern, please feel free to let me know!

    Best Regards,

    Cathy Kong

     

    Tuesday, May 11, 2010 7:24 AM
    Moderator
  • This doesn't work on Windows 2008 R2... the properties on the service are greyed out.  Any thoughts on how it might work on W2k8?
    Friday, August 06, 2010 3:46 PM
  • Thank you!
    Thursday, October 28, 2010 5:04 PM
  • I have done the above, but the Launch and Activation Permissions is still greyed out.
    Wednesday, April 27, 2011 10:50 AM
  • Reopen the component services and it should be updated.
    YSobhdel
    Wednesday, July 13, 2011 6:12 AM
  • This worked for me too thanks

    Cyndy

    Monday, February 04, 2013 1:50 PM