none
The SQLBrowser service was unable to establish Analysis Services discovery.

    Question

  • Hello

    When I was restoring the TFS database to a virtual server for testing purposes the real server crashed since the commands mentioned in the msdn guide: How to: Move Your Team Foundation Server from One Hardware Configuration to Another made changes to the original database on the old machine.

    I've got the old one working again, except for the reports which gives me the following error:
    • An error has occurred during report processing. (rsProcessingAborted)
      • Cannot create a connection to data source 'TfsOlapReportDS'. (rsErrorOpeningConnection)
        • A connection cannot be made to redirector. Ensure that 'SQL Browser' service is running.
          • No such host is known
    When looking at the event log I found the following warning: The SQLBrowser service was unable to establish Analysis Services discovery.

    I believe it tries to connect to the virtual machine instead of the real local server. Any ideas how to change this?

    Thanks
    // Lasse





    Tuesday, November 13, 2007 12:40 PM

Answers

  • Uninstalling the Beta 2 and installing the RTM did the trick.

    The reports are working properly now.

    Thanks everyone for the help!

    /Markus

    Monday, January 14, 2008 1:15 PM

All replies

  • Hello Lasse,

     

     Could you please try the following steps? Thanks. 

     

      Step one.

     

      If the SQL Server Browser service is running and you are receiving these error messages, verify that the SQL Server Browser service is running under an account with administrator rights on the local computer—such as the local system account.

     

      To accomplish this, use either SQL Server Configuration Manager or Computer Management or Services. If it is not, change this service to run under an appropriate account and then restart this service before attempting to reconnect.

     

     

     Could you please check the virtual machine's ports and the real local server's ports?

     

      A default instance of SQL Server 2005 Analysis Services listens on TCP port 2383. The SQL Server Browser service listens on TCP port 2382.

     

      Please check if these ports are blocked.

     

     Did you setup the virtual machine on the local server?

     

      Good luck..

     

     

    Thursday, November 15, 2007 7:12 AM
  • Hello

    Sorry if I was a bit unclear, but it's the real server I got troubles with not i virtual one. I believe the commands mentioned in the restoration guide on msdn changed the server names in the configuration making the original server trying to connect to the virtual servers' database. I've managed to fix this problem except for in the report server.

    Thanks
    // Lasse
    Thursday, November 15, 2007 7:49 AM
  • Hello,

     

      Sorry could you please tell more about the scenario?

     

      Is the original TFS a single server?

     

      Did you move the whole TFS server including Data - Tier and App - Tier?

     

     

      in the restoration guide on msdn changed the server names in the configuration making the original server trying to connect to the virtual servers' database.

     

       Could you please tell which step (changed the server names in the configuration) in the guide?

     

       How to: Move Your Team Foundation Server from One Hardware Configuration to Another

     

      

      

     

       Thanks

     

          

    Thursday, November 15, 2007 9:32 AM
  • Both of the servers, original and virtual, is a single server setup.

    I believe it's one of these commands which made the original server to start failing:

    TfsAdminUtil RenameDT newTeamFoundationDataTierServerName


    TfsAdminUtil ActivateAT newTeamFoundationApplicationTierServerName




    We wanted to "copy" our original server to a virtual machine and make it look like the original to test some stuff we don't want to test on our live server. We started a virtual server on the same network as the original and just followed the guide How to: Move Your Team Foundation Server from One Hardware Configuration to Another
    Thursday, November 15, 2007 9:58 AM
  • Hello LasseJ,

      TfsAdminUtil RenameDT newTeamFoundationDataTierServerName


      TfsAdminUtil ActivateAT newTeamFoundationApplicationTierServerName

      

      These commands execute in the new App - Tier (in your case virtual server box.)

     

     

      I will test my working TFS server to a virtual server to check it later.

     

      Sorry for the inconvenience.

    Monday, November 19, 2007 3:38 AM
  • I ran them on the virtual machine, I think that the problem was that the RenameDT command failed and I ran the ActivateAT command anyway which made the virtual machine to connect to the original data tier and make the changes there.

    Do you have any idea about how to solve the error with the reporting servers? Can't find any solutions for it, the connection string are correct in TfsOlapReportDS & TfsReportDS, it's also correct in the report server configuration. Still it seems that the original server tries to connect to the virtual server for the reports.

    Thanks for your help
    // Lasse
    Monday, November 19, 2007 7:41 AM
  • When running the Team Foundation Server Best Practices Analyzer on the original(old) server it shows me the following error on the report server:

    Detailed Message: TF53007: The application tier name <virtual server> recorded in the database does not match the local machine name <original server>. Please contact your Team Foundation Server administrator.

    Now I just need to know how to solve this. It seems that the ActivateAT command have missed this out when setting I was running it the second time.
    Monday, November 19, 2007 11:50 AM
  • Hello LasseJ,

     

     

      Could you please try the TfsAdminUtil ActivateAT command in the original server.

     

      Have you tried it?

     

       

     

    1. On the Team Foundation application-tier server, open a Command Prompt window.

    2. Change directories to drive:\%ProgramFiles%\Microsoft Visual Studio 2005 Team Foundation Server\Tools.

    3. At the command prompt, type the following command:

      TfsAdminUtil ActivateAT newTeamFoundationApplicationTierServerName

     

     

       Recommend that you back up the databases in the Team Foundation Server data tier server.

     

       Please close the virtual server for safe.

      

      

    Monday, November 19, 2007 12:05 PM
  • I ran ActivateAT on the original server to fix it to work at all but I will try it again later when the developers isn't using the server.
    Monday, November 19, 2007 12:16 PM
  • Just ran the ActivateAT command, but with no luck, still getting the same error in the reports.
    Monday, November 19, 2007 4:06 PM
  • To fix the reporting issue try checking the TFSIntegration.dbo.tbl_databases table for the correct servers and fix accordingly.  It could be the BISANALYSIS DB server is set incorrectly.

     

    Thanks,

    -Larry

     

     

    Monday, November 19, 2007 11:27 PM
  • All servernames are correct in the table, this seems very strange. Any other ideas?

    Thanks
    // Lasse
    Tuesday, November 20, 2007 8:44 AM
  • Lasse

     

    i know there have been some steps taken here but just to make sure, can you confirm the following:

     

     

    1) Change the SQL server Browser service running Account to Local System Account

    2) Double click on the data source (TfsOlapReports....) (From Solution Explorer). and in Impersonation Information Select the Use the Service Account.

     

    Also, just to check basics, can you connect to the AS server using managment studio or excel ?

     

    thanks

     

    --Markus

     

     

    Monday, November 26, 2007 4:22 AM
  • Hello

    Feel free to post steps for me to take, anything that can solve this problem is appreciated.

    About the steps above, by Solution Explorer do you mean the Object Explorer in SQL Server Management Studio or am I looking at the wrong place?

    It's possible to connect to all the services and I know this isn't the problem since it clearly stated that the reporting services is trying to connect to the virtual machine when I was running the Visual Studio Team System Best Practices Analyzer.

    Thanks for all of you help
    // Lasse
    Monday, November 26, 2007 7:27 AM
  • It may help to recreate the data sources using these steps:

    1. Open Internet Explorer and connect to http://localhost/reports. In Contents, click TfsReportDS.

    2. In Connection string, update the Data source parameter with the new Team Foundation data-tier server name. In Connect using, select Credentials stored securely in the report,update the user name and password to reflect the new reporting services service account, and then click Apply.
    3. Under SQL Server Reporting Services, click Home.

    4. In Contents, click TfsOlapReportsDS.

    5. In Connection string, update the Data source parameter with the new Team Foundation data-tier server name. In Connect using, select Credentials stored securely in the report, update the user name and password to reflect the new reporting services service account, and then click Apply.

    In your case, "new" refers to the original.

    Tuesday, November 27, 2007 5:48 AM
  • These parameters are correct and I've tried this before but it wont work.

    Thanks
    // Lasse
    Tuesday, November 27, 2007 7:42 AM
  • Lasse, I did some checking around to see about the BPA error you are getting and what it means.  Basically, the error is an ATStampMisMatchError from TFS, not something generated by the TFS BPA tool.  The TFS BPA tool may have also complained since this indicates that the NetBIOS name of the TFS AT (tfsadminutil activateat) does not match the host name of the TFS AT system.

     

    You should be able to fix this with TfsAdminUtil ActivateAT; however, the trick may be to ensure your DT name used by the tfsadminutil command is correct in the services web.config (drive:\%ProgramFiles%\Microsoft Visual Studio 2005 Team Foundation Server\Web Services\Services).  Please check this file to ensure you have the correct servers being used.  Once that is fixed, try running the TfsAdminUtil ActivateAT command again.

     

    if that doesn't fix the problem, then check the ATNetBiosName in the TfsIntegration.dbo.tbl_registration_extended_attributes table.  The error is caused by this not matching it's NetBIOS name.

     

    Also check the warehouse web.config file for any server mismatches - drive:\%ProgramFiles%\Microsoft Visual Studio 2005 Team Foundation Server\Web Services\Warehouse\

     

    Hopefully one of these ideas helps fix your issue.

     

    Thanks,

    -Larry

     

     

     

    Wednesday, November 28, 2007 8:47 PM
  • Hello

    Thanks for your reply, I've tried to use the TfsAdminUtil ActivateAT command and I've checked that the server specified in the web.config is correct. When looking in TfsIntegration.dbo.tbl_registration_extended_attributes all server settings seems to be correct.

    Ive attached the web.config files from the Services and Warehouse folder below:

    Services:
    <?xml version="1.0" encoding="utf-8" ?>
    <configuration>

      <appSettings>
        <add key="ConnectionString" value="Application Name=TeamFoundation;Persist Security Info=False;Initial Catalog=TfsIntegration;Data Source=<Correct Server Name>;Integrated Security=SSPI"/>   
        <add key="eventingEnabled" value="true" />
        <add key="DetailedExceptions" value="false" />
        <add key="emailNotificationFromAddress" value="" />
        <add key="smtpServer" value="" />

        <!-- Optional Alert Settings
             AlertUseReplyTo: True, False (default: True). Specifies that the ReplyTo property of the
                         email alert should be set. When false, the From property is set.
        <add key="AlertUseReplyTo" value="True" />
        -->
      </appSettings>
       
      <runtime>
         <assemblyBinding xmlns="urnTongue Tiedchemas-microsoft-com:asm.v1">
          <probing privatePath="bin\Plugins;bin\Plugins\zh-chs;bin\Plugins\zh-cht;bin\Plugins\de;bin\Plugins\es;bin\Plugins\fr;bin\Plugins\it;bin\Plugins\ja;bin\Plugins\ko"/>
        </assemblyBinding>
      </runtime>

      <system.web>

       <!-- Enable the HttpHandlers for file upload and download -->
       <httpHandlers>
           <add verb="*" path="methodology.asmx" type="Microsoft.TeamFoundation.Client.MethodologyDownloadHandler" />
           <add verb="*" path="methodologyUpload.asmx" type="Microsoft.TeamFoundation.Client.MethodologyUploadHandler" />
       </httpHandlers>
      
     </system.web>

    </configuration>


    Warehouse:
    <?xml version="1.0" encoding="utf-8" ?>
    <configuration>

      <appSettings>
      </appSettings>
       
      <runtime>
         <assemblyBinding xmlns="urnTongue Tiedchemas-microsoft-com:asm.v1">
          <probing privatePath="bin\Plugins;bin\Plugins\zh-chs;bin\Plugins\zh-cht;bin\Plugins\de;bin\Plugins\es;bin\Plugins\fr;bin\Plugins\it;bin\Plugins\ja;bin\Plugins\ko"/>
        </assemblyBinding>
      </runtime>
    </configuration>

    Thanks for all the help, this seems to be a very tricky problem
    // Lasse

    Thursday, November 29, 2007 8:18 AM
  •  

    Hi Lasse,

    Can you please run the Reporting Services Configuration tool on your production RS server and make sure that all elements are green? If they arent, let us know what isnt green, and what the message is.

    Mauli

    Thursday, November 29, 2007 10:53 PM
  • Everything is green except:

     

    SharePoint integration which is a blue !

    Encryption Keys which is a blue !

    Initialization which is greyed out

    Email Settings which is a yellow !

     

    Thanks

    // Lasse

    Monday, December 03, 2007 9:45 AM
  • Since I'm going away for a while I have to put a colleague in charge of it, his forum name is: Markus Erlandsson.

    Thanks for all the help
    // Lasse
    Monday, December 03, 2007 4:05 PM
  • A grayed-out status icon appears if the database connection is not set or if you are using an edition that does not support scale-out deployment. Are you sure you installed the correct edition?

     

    --Markus

     

    Tuesday, December 04, 2007 7:43 AM
  • Hi Markus

    Sorry for the delay, it seems that I did not have this thread as Alert as I thought that I had.

    It seems not probably since this problem occurred first when we tried to backup the current database to a virtual machine for testing, before that the database hade no problems.

    As I am not used SQL Server but I think that the version is SQL Server 9.0.3042, Microsoft SQL Server Standard Edition.

    //Markus

    Tuesday, December 11, 2007 9:52 AM
  • Hi Markus

     

    Ok let's start a new approach Smile. Have you tried accessing report manager from outside the team explorer ? I'm assuming we're trying to open report explorer from the vsts team explorer right ? Can you open report manager by browsing on that machine to http://<servername>/reports ? Also try running http://<servername>/reportserver, that will test if the reporting services webservice is started. let's take it from there.

     

    --Markus

    Wednesday, December 19, 2007 6:14 PM
  • Hi Markus

     

    Thanks for your reply.

     

    I have been trying to access it from both within vsts Team Explorer and outside.

     

    This is the result so far:

     http://<servername>/reports

     http://<servername>/reportserver

    Is accessable and 'seems' to have the correct settings however I cannot access any 'real' report.

     

    Accesing any report from within Team Explorer genereates the following error.

    • An error has occurred during report processing. (rsProcessingAborted)
      • Cannot create a connection to data source 'TfsOlapReportDS'. (rsErrorOpeningConnection)
        • For more information about this error navigate to the report server on the local server machine, or enable remote errors

    Browsing to the Team Site is possible, but where the 'first' report used to be are the same error.


    • An error has occurred during report processing. (rsProcessingAborted) Get Online Help
      • Cannot create a connection to data source 'TfsOlapReportDS'. (rsErrorOpeningConnection) Get Online Help
        • For more information about this error navigate to the report server on the local server machine, or enable remote errors

    Thanks

    //Markus

    Friday, December 21, 2007 7:02 AM
  •  

    ok,can you see the TfsOlapReportDS data source ? If yes, navigate to it and under properties verify that the connection type is "Microsoft SQL Server Analysis Services" with the connection string like this "data source=%yourservername%;initial catalog=TfsWarehouse"

     

    The user account credentials provided to this data source needs to be a part of the TfsWarehouseDataReader role on the cube.  To check what user accounts are part of the TfsWarehouseDataReader role:

    1. Connect to Analysis Services on the data tier using SQL Server Management Studio.
    2. Click on "Databases" to expand that node. -- TfsWarehouse should be a child.
    3. Click on "Roles" - TfsWarehouseDataReader should be a child.
    4. Right click on TfsWarehouseDataReader and select Properties.
    5. Click "Membership" -- you should see the members of this role.

    try that and let me know.

     

    --Markus

    Thursday, December 27, 2007 7:52 PM
  • Hi Markus

     

    Thanks again.

    I browsed the report server, the TfsOlapReportDS and the connect String looks fine to me.

      <ConnectString>Data Source=wmdata\wmsi003023;Initial Catalog=TfsWarehouse</ConnectString>

     

    The user is apart of the TfsWarehouseDataReader.

     

    /Markus

    Saturday, December 29, 2007 11:57 AM
  • ok can you confirm that you have Analysis Services installed as an instance ? So wmsi003023 seems to be your instance name. Try modifying the string to just point to <ConnectString>Data Source=wmdata;Initial Catalog=TfsWarehouse</ConnectString>

     

    I don't think we support instances in TFS warehouse. try that and let me know.

     

    --Markus

     

    Friday, January 04, 2008 8:04 PM
  • Thanks once again Markus!

     

    This is what I did, I browsed

    http:\\wmsi003023\reports -> TfsOlapReportDS

    to change the connection string. Then the I use

     

    “Credentials stored securely in the report server ”

    And the password seems to not be stored allright. If I change anything in the connection string I have to retype the password.

     

    When I retype the password it reduces the length by one character and now I get a different error message. I browsed the teamsite and got the following error message.

     

    Reporting Services Error


    • An error has occurred during report processing. (rsProcessingAborted) Get Online Help
      • Cannot impersonate user for data source 'TfsOlapReportDS'. (rsErrorImpersonatingUser) Get Online Help
        • Logon failed. (rsLogonFailed) Get Online Help
          • For more information about this error navigate to the report server on the local server machine, or enable remote errors

    SQL Server Reporting Services

    It did’t make any difference whether I changed the connection string to the servername wmsi003023, or with domain and server name wmdata\wmsi003023.

     

    I tried to change the password on the reports -> TfsOlapReportsDS many times but it always made it one character shorter.

     

    How do I change the password to the reports?

    /Markus

    Monday, January 07, 2008 12:35 PM
  • Uninstalling the Beta 2 and installing the RTM did the trick.

    The reports are working properly now.

    Thanks everyone for the help!

    /Markus

    Monday, January 14, 2008 1:15 PM
  •  

    Thanks for the update Markus!  This is great!
    Tuesday, January 15, 2008 1:50 AM