none
'Microsoft.VisualStudio.Editor.Implementation.EditorPackage' package did not load correctly

    Question

  • After the 07/10/2013 Microsoft update, I tried to open Microsoft Visual Studio, then this error showed up

    No exports were found that match the constraint: ContractName

    Microsoft.VisualStudio.Utilities.IContentTypeRegistryService RequiredTypeIdentity

    Microsoft.VisualStudio.Utilities.IContentTypeRegistryService  

    This error happened to every member's of our group.

    The Microsoft Visual Studio Professional 2012:

    Version 11.0.50727.1 RTMREL

    Appreciate any help on this issue.

    Tuesday, July 16, 2013 7:41 PM

Answers

  • Removing %LOCALAPPDATA%\Microsoft\VisualStudio\11.0\ComponentModelCache and restarting VS2012 fixed the problem for me.
    • Marked as answer by AirLee Wednesday, July 17, 2013 2:45 PM
    Wednesday, July 17, 2013 9:21 AM

All replies

  • Removing %LOCALAPPDATA%\Microsoft\VisualStudio\11.0\ComponentModelCache and restarting VS2012 fixed the problem for me.
    • Marked as answer by AirLee Wednesday, July 17, 2013 2:45 PM
    Wednesday, July 17, 2013 9:21 AM
  • Thanks, that fixed this issue.
    Wednesday, July 17, 2013 2:46 PM
  • Thanks ...Removing %LOCALAPPDATA%\Microsoft\VisualStudio\11.0\ComponentModelCache and restarting VS2012 fixed the problem for me.
    Thursday, July 18, 2013 4:33 AM
  • This worked for me. The problem arose straight after activating InstallShield Limited Edition.
    Monday, September 02, 2013 9:43 AM
  • It's Fixed to me Thanks!!!

    Marcelo Gomes

    Tuesday, September 10, 2013 5:11 PM
  • Worked for me too. I was about to uninstall VS 2012.
    Wednesday, October 23, 2013 11:04 AM
  • This worked for me as well.

    Visual Studio 2013

    Trying to open a VS2010 project.

    Monday, December 30, 2013 4:30 PM
  • Thanks, and removing %LOCALAPPDATA%\Microsoft\VisualStudio\12.0\ComponentModelCache fixes it in Visual Studio 2013 too...
    Saturday, February 01, 2014 1:15 PM
  • I agree, I wasn't getting this problem until I installed Installshield Limited Edition this morning.
    Monday, March 31, 2014 2:19 PM