none
Address already in use: NET_BIND error

    Question

  • Hi,

    I am integrating TFS 2010 with IBM RAD 7.0 for my customer. While trying to connect to the TFS server from IBM RAD, I am getting error of the form:

    Address already in use: NET_BIND. I do not know how to get verbose logging for the same.

    Platform: Windows 7, IBM RAD 7.0, Team Foundation Server 2010, Team Explorer Everywhere 2010

    Any help much appreciated.

     

    Thanks

    Tuhin

     


    Thanks Tuhin
    Wednesday, February 16, 2011 8:15 AM

Answers

  • Hi, We have not seen this error before and RAD7 is supported, you can get more logging information, if you go to Help\Team Explorer Support, you will find all the logs there. You can export them and send them if you like to this mail so that we can take a look:mirehann@microsoft.com Thanks Mireille
    Wednesday, February 16, 2011 2:57 PM
    Moderator
  • You cannot vote on your own post
    0

    Hi,

    This exception is coming from Java.net.Socket.bind which is part of the Java SDK. There is Java SDK1.5 update that solves this issue. So the problem is that there is a websphere patch that needs a JVM patch to work fine and this JVM patch is not bundled with the websphere patch so you have to go and install it yourself. Here is the link to the JVM update http://www-01.ibm.com/support/docview.wss?rs=180&uid=swg24026453

     

    could you please try to isntall it or make sure that you have at least "Java SDK1.5 SR11 FP1". please let me know if that does not fix your problem.

     

     

     

     

    Thanks

    Mireille 

    .

    • Marked as answer by TuhinKanti Wednesday, March 02, 2011 11:21 AM
    Tuesday, March 01, 2011 3:21 PM

All replies

  • Hi, We have not seen this error before and RAD7 is supported, you can get more logging information, if you go to Help\Team Explorer Support, you will find all the logs there. You can export them and send them if you like to this mail so that we can take a look:mirehann@microsoft.com Thanks Mireille
    Wednesday, February 16, 2011 2:57 PM
    Moderator
  • Hi,

    I have tried a lot of things and have been unsuccessful. This is reproducing on multiple clients. The network is consistent though and has strict access control. 

    Correction: IBM RAD 7.0 is the version for IDE

    I updated the TFS default site to use port 9090 instead of 8080. http:\\ServerName:9090\tfs as well as updated the eclipse.ini file to look like the following.

    Logging is attached at the end.

    Please look into this since this will greatly help us portray Microsoft platform as a reliable solution provider

    ----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------

     

    -vm

    C:\Program Files\IBM\SDP70\jdk\jre\bin\javaw.exe

    -Dorg.osgi.service.http.port=999

    -vmargs

    -Xquickstart

    -Xms40m

    -Xmx768m

    -Xgcpolicy:gencon

    -Xscmx96m

    -Xshareclasses:singleJVM,keep

    -Xnolinenumbers

    -XX:MaxPermSize=512M

     

    ----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------


     

     

    _________________________________________________________________________________________________________________________________

     

    2011-02-21 08:28:22,715 INFO  [main] (com.microsoft.tfs.jni.natives.NativeLoader) Loaded native_auth-9 with System.loadLibrary()

    2011-02-21 08:28:22,718 INFO  [main] (com.microsoft.tfs.jni.internal.proxy.PlatformUtilsProxy) Proxy 'NegotiateEngine.negotiateProxy' chose implementation class com.microsoft.tfs.jni.internal.negotiate.NativeNegotiate

    2011-02-21 08:28:22,768 INFO  [main] (com.microsoft.tfs.jni.internal.proxy.PlatformUtilsProxy) Proxy 'NTLMEngine.ntlmProxy' chose implementation class com.microsoft.tfs.jni.internal.ntlm.NativeNTLM

    2011-02-21 08:28:22,781 INFO  [main] (com.microsoft.tfs.jni.natives.NativeLoader) Loaded native_misc-9 with System.loadLibrary()

    2011-02-21 08:28:22,781 INFO  [main] (com.microsoft.tfs.jni.internal.proxy.PlatformUtilsProxy) Proxy 'PlatformMisc.defaultProxy' chose implementation class com.microsoft.tfs.jni.internal.platformmisc.NativePlatformMisc

    2011-02-21 08:33:20,465 INFO  [ThreadedCancellableCommand thread for command [Connecting to server]] (org.apache.commons.httpclient.HttpMethodDirector) I/O exception (java.net.BindException) caught when processing request: Address already in use: NET_Bind

    2011-02-21 08:33:20,465 INFO  [ThreadedCancellableCommand thread for command [Connecting to server]] (org.apache.commons.httpclient.HttpMethodDirector) Retrying request

    2011-02-21 08:33:20,466 INFO  [ThreadedCancellableCommand thread for command [Connecting to server]] (org.apache.commons.httpclient.HttpMethodDirector) I/O exception (java.net.BindException) caught when processing request: Address already in use: NET_Bind

    2011-02-21 08:33:20,466 INFO  [ThreadedCancellableCommand thread for command [Connecting to server]] (org.apache.commons.httpclient.HttpMethodDirector) Retrying request

    2011-02-21 08:33:20,467 INFO  [ThreadedCancellableCommand thread for command [Connecting to server]] (org.apache.commons.httpclient.HttpMethodDirector) I/O exception (java.net.BindException) caught when processing request: Address already in use: NET_Bind

    2011-02-21 08:33:20,467 INFO  [ThreadedCancellableCommand thread for command [Connecting to server]] (org.apache.commons.httpclient.HttpMethodDirector) Retrying request

    2011-02-21 08:33:20,493 ERROR [main] (com.microsoft.tfs.client.common.framework.command.ThreadedCancellableCommand) Address already in use: NET_Bind

    2011-02-21 08:33:47,234 INFO  [ThreadedCancellableCommand thread for command [Connecting to server]] (org.apache.commons.httpclient.HttpMethodDirector) I/O exception (java.net.BindException) caught when processing request: Address already in use: NET_Bind

    2011-02-21 08:33:47,234 INFO  [ThreadedCancellableCommand thread for command [Connecting to server]] (org.apache.commons.httpclient.HttpMethodDirector) Retrying request

    2011-02-21 08:33:47,235 INFO  [ThreadedCancellableCommand thread for command [Connecting to server]] (org.apache.commons.httpclient.HttpMethodDirector) I/O exception (java.net.BindException) caught when processing request: Address already in use: NET_Bind

    2011-02-21 08:33:47,235 INFO  [ThreadedCancellableCommand thread for command [Connecting to server]] (org.apache.commons.httpclient.HttpMethodDirector) Retrying request

    2011-02-21 08:33:47,236 INFO  [ThreadedCancellableCommand thread for command [Connecting to server]] (org.apache.commons.httpclient.HttpMethodDirector) I/O exception (java.net.BindException) caught when processing request: Address already in use: NET_Bind

    2011-02-21 08:33:47,236 INFO  [ThreadedCancellableCommand thread for command [Connecting to server]] (org.apache.commons.httpclient.HttpMethodDirector) Retrying request

    2011-02-21 08:33:47,255 ERROR [main] (com.microsoft.tfs.client.common.framework.command.ThreadedCancellableCommand) Address already in use: NET_Bind

    _______________________________________________________________________________________________________________________________
    Thanks, 
    Tuhin 

     


    Thanks Tuhin
    Thursday, February 24, 2011 4:28 AM
  • Hi,

    This exception is coming from Java.net.Socket.bind which is part of the Java SDK. There is Java SDK1.5 update that solves this issue. So the problem is that there is a websphere patch that needs a JVM patch to work fine and this JVM patch is not bundled with the websphere patch so you have to go and install it yourself. Here is the link to the JVM update http://www-01.ibm.com/support/docview.wss?rs=180&uid=swg24026453

    .

    could you please try to isntall it or make sure that you have at least "Java SDK1.5 SR11 FP1". please let me know if that does not fix your problem.

     

     

     

    Thanks

    Mireille 

    Tuesday, March 01, 2011 2:56 PM
  • You cannot vote on your own post
    0

    Hi,

    This exception is coming from Java.net.Socket.bind which is part of the Java SDK. There is Java SDK1.5 update that solves this issue. So the problem is that there is a websphere patch that needs a JVM patch to work fine and this JVM patch is not bundled with the websphere patch so you have to go and install it yourself. Here is the link to the JVM update http://www-01.ibm.com/support/docview.wss?rs=180&uid=swg24026453

     

    could you please try to isntall it or make sure that you have at least "Java SDK1.5 SR11 FP1". please let me know if that does not fix your problem.

     

     

     

     

    Thanks

    Mireille 

    .

    • Marked as answer by TuhinKanti Wednesday, March 02, 2011 11:21 AM
    Tuesday, March 01, 2011 3:21 PM
  • Hi Mireille,

    The patch mentioned is for IBM Websphere Application Server while I am only using IBM RAD. I did update the IBM RAD online though and the issue is not occurring again. Thanks for your help.

     

    Thanks

    Tuhin


    Thanks Tuhin
    Wednesday, March 02, 2011 11:21 AM