none
Application attempted to perform an operation not allowed...

    Question

  • Very frustrating though I know it comes out of my own ignorance.

     

    I have created a small program that is designed to do a few specific tasks to save the users the repeated trouble. This program is designed to be in every Project folder on our server.

     

    It works great  on my computer that I coded it. Heck, I can even run it from the network from my computer.

    This is not a program that I want INSTALLED on any computers but just a small self-contained EXE that sits in everyone of our project folders that the user can double-click on and then have it do it's work. (I copy the exe from the RELEASE folder).

     

    But when anyone else runs the app from the network, they are confronted by the dreaded:

    "Application attempted to perform an operation not allowed by the security policy. Blah BLAH BLAH!"

     

    I've done:

    1. Using the SN.exe, created a strong name key for my project. Included the .snk file in my project files and the project properties, set that key file under siging.

     

    2. On the server tried, though it's very confusing, the .net 2.0 coniguration MMC (I don't understand it so, I've basically, and foolishly set everything I can find to FULLTRUST). Thanks MS for that nice piece of work. Clients still get that error.

     

    3. Jumped up and down on one foot while singing Kumbya mixed with a bunch of Hail Mary's while flogging myself for my own ignorance. Still, I get the error msg.

     

    What, for the love of Bill Gates, must I do to get this tiny piece of work that does simple every day computing tasks that I created on my network, for my network to run without throwing up all over the people it's intended to help?

     

    Jeez - I hope this is the right place to post this Smile

     

    Thanks!

     

    Tuesday, April 29, 2008 7:25 PM

Answers

  • Each individual user will have to configure their PC to say they trust programs stored on the server.  You can't configure the server to tell the PCs they should trust it.  That would be equivalent to a pr0n site telling your browser "trust me".  The quick way: Control Panel + Internet Options, Security, select Local Intranet (your LAN), set Level to Low.
    Wednesday, April 30, 2008 1:24 AM
  • Friday, May 02, 2008 12:27 AM

All replies

  • Each individual user will have to configure their PC to say they trust programs stored on the server.  You can't configure the server to tell the PCs they should trust it.  That would be equivalent to a pr0n site telling your browser "trust me".  The quick way: Control Panel + Internet Options, Security, select Local Intranet (your LAN), set Level to Low.
    Wednesday, April 30, 2008 1:24 AM
  • Thanks for the reply, Nobugz,

    However, that didn't work at least on my Vista computer (which I hate, this is just another place I can tell it to MS).

    Maybe it's a vista thing. All other clients are on XP pro so I'll try it on one them and see how it goes.

    I'll post back.

    Wednesday, April 30, 2008 6:51 PM
  • hmmpff. XP doesn't like it either. From JIT, it  says:

     

    The action that failed was:

    LinkDemand

    The type of the first permission that failed was:

    system.security.PermissionSet

    The Zone of the assembly that failed was:

    Intranet

     

    So, I made sure that INTRANET was set to low (which it was).

    Is there a hidden "lower" or "lowest" setting? j/k

     

    Any other things that I might check?

     

    You said that was the easiest way, what's the harder method?

     

    How would a commercial app overcome something like this?
    You can't tell the consumer to lower their security level, right?

     

    thanks thanks thanks
    Thursday, May 01, 2008 9:41 PM
  • Friday, May 02, 2008 12:27 AM