none
Installing Net.Framework on a 32-bit Vista (Home Premium)

    Question

  • Hello...

    I have a Vista Home Premium 32-bit OS

    I am trying to install Net.Framework 3.1 or the 3.5 Service pack. It will not install....

    I have service pack 1.1, and I thought that you would have to install 2.0 before you install 3.1 or 3.5. But I'm hearing that 2.0 is not available for Vista and that you can get what you need in 2.0 SP1 from 3.5 or Vista SP1.

    I have Windows installer 4.5.6001.22392, which I'm assuming to be Windows Installer 4.5.

    I've been working on this via forums, tech support, etc. for atleast 30 hours. Please, please help me. I am unable to work on other programs because of this problem.

    PS... I'm also receiving a error of 0xC00CE556 parsar every time the computer starts. I also bought this computer with Vista already pre-installed, therefore I do not have the disk.

    Please let me know if you need any other information.

    Wednesday, May 02, 2012 8:24 PM

All replies

  • Hi TLW32,

    I'm not sure your status now but let me clarify something first.

    .Net Framework 2.0 and 3.0 are installed as OS components on Windows Vista. .NET Framework 2.0 service pack 1 and .NET Framework 3.0 service pack 1 are also included in .Net Framework 3.5.

    Then .NET Framework 2.0 service pack 2and .NET Framework 3.0 service pack 2 are included in .Net Framework 3.5 service pack 1.

    Please use Verification Tool to verify .Net Framework 2.0 and 3.0. If .Net Framework 2.0 and 3.0 cannot be verified on your computer, you can try to follow the steps mentioned in the following blog to repair the .NET Framework 2.0 and 3.0 on Windows Vista.
    See: http://blogs.msdn.com/astebner/archive/2007/03/26/how-to-repair-the-net-framework-2-0-and-3-0-on-windows-vista.aspx

    From your description, I'm not sure which product do you really want to install. Could you please show us the link of your installation package and the verification result of .NET Framewrok.

    Also,please use the collect tool to collect your logs for more information.

    See: http://blogs.msdn.com/heaths/archive/2008/05/09/visual-studio-and-net-log-collection-utility.aspx


    Thanks


    Barry Wang [MSFT]
    MSDN Community Support | Feedback to us

    Friday, May 04, 2012 6:22 AM
    Moderator
  • Thank you ....

    I will try this once I return home this evening and I will immediately reply with my results.

    Thanks again:-)

    Tuesday, May 08, 2012 3:43 PM
  •  Hello Again,

    Ok, so I downloaded the verification tool and ran the program... I can not conclude for the results what was actually verified.

    Here's what the notes read:

    [05/08/12,18:52:05] Beginning of new SetupVerifier activity logging session
    [05/08/12,18:52:05] Activity log file location: C:\Users\TL0167~1\AppData\Local\Temp\setupverifier_main_05-08-12_18.52.05.txt
    [05/08/12,18:52:05] Error log file location: C:\Users\TL0167~1\AppData\Local\Temp\setupverifier_errors_05-08-12_18.52.05.txt
    [05/08/12,18:52:05] Build created on December 29, 2011
    [05/08/12,18:52:05] Detected operating system: Windows Vista (x86)
    [05/08/12,18:52:05] Install state for .NET Framework 1.0: not installed.
    [05/08/12,18:52:05] Install state for .NET Framework 1.1: installed with service pack 1.
    [05/08/12,18:52:05] Install state for .NET Framework 2.0: installed with service pack 2.
    [05/08/12,18:52:05] Install state for .NET Framework 3.0: installed with service pack 2.
    [05/08/12,18:52:05] Install state for .NET Framework 3.5: not installed.
    [05/08/12,18:52:05] Install state for .NET Framework 4 Client: not installed.
    [05/08/12,18:52:05] Install state for .NET Framework 4 Full: not installed.
    [05/08/12,18:52:05] Not adding product '.NET Framework 1.0' because it is not currently installed
    [05/08/12,18:52:05] Not adding product '.NET Framework 1.1' because it is not currently installed
    [05/08/12,18:52:05] Not adding product '.NET Framework 2.0' because it is not currently installed
    [05/08/12,18:52:05] Not adding product '.NET Framework 2.0 SP1' because it is not currently installed
    [05/08/12,18:52:05] Not adding product '.NET Framework 3.0' because it is not currently installed
    [05/08/12,18:52:05] Not adding product '.NET Framework 3.0 SP1' because it is not currently installed
    [05/08/12,18:52:05] Not adding product '.NET Framework 3.5' because it is not currently installed
    [05/08/12,18:52:05] Not adding product '.NET Framework 3.5 SP1' because it is not currently installed
    [05/08/12,18:52:05] Not adding product '.NET Framework 4 Client' because it is not currently installed
    [05/08/12,18:52:05] Not adding product '.NET Framework 4 Full' because it is not currently installed
    [05/08/12,18:52:14] Starting verification for product .NET Framework 1.1 SP1

    and so on:

    I'm not quite certain what this is telling me..  Please advise.

    Thank you so very much with your help on this matter.

    Tuesday, May 08, 2012 11:00 PM
  • Hi TLW32,

    The first 15 lines and the last 15 lines of the notes will show us your veritification infor. Please choose .NET 2.0 and .NET 3.0 to verify and show me the result.

    If you have tried to install .NET 3.5 on your OS and it failed. Have you received any error messages?

    If you have no idea, try to use this tool to collect logs:

    http://www.microsoft.com/downloads/details.aspx?FamilyID=E0DA314F-6216-4A18-BC6B-7D29CF83AF20&displaylang=e&displaylang=en 

    After you run Collect.exe, you'll find vslogs.cab in your %temp% directory. Please upload vslogs.cab to a public site, like SkyDrive, and post the link here.

    Best regards,


    Barry Wang [MSFT]
    MSDN Community Support | Feedback to us

    Wednesday, May 09, 2012 7:55 AM
    Moderator
  •  

    Hi Barry,

    I sent you a message yesterday and for some reason it didn't go through :-(...

    Here's the update: Since I was unsure about verifying .Net 2.0 and .Net 3.0, I used the tool to collect the logs. After I ran Collect.exe, I found the vslogs in the temp folder and posted them here:

    https://skydrive.live.com/#cid=7924177E32CA3653&id=7924177E32CA3653%21106

    The file is titled "CollectInfo"

    Just some other information:

    I'm trying to install .Net Framework 3.5 sp1. It's trying to download via updates, but it keeps failing. After the failed installation occurs, there is no error. However, when my computer starts, there's a parser error reading: C:\Windows\Microsoft.NET\Framework\v2.0.50727\config\machine.config  Parser returned error 0xC00CE556.

    Please let me know any other information that you may need... and thanks again for all that you are doing to fix this problem!!!!!!!!!!!

    Thursday, May 10, 2012 4:23 PM
  • Hi TLW32,

    I cannot download the file because it shows the file has been deleted.

    But from your desription, you are facing .NET Framework 2.0 installation error.

    Since .NET 2.0 and .NET 3.0 were embedded into the OS, if you want to repair them, you need to have a look at this article:

    http://blogs.msdn.com/b/astebner/archive/2007/03/26/how-to-repair-the-net-framework-2-0-and-3-0-on-windows-vista.aspx

    "How to repair the .NET Framework 2.0 and 3.0 on Windows Vista"

    It was the tool SFC /scannow to check system files on your OS and you can use that to fix.

    If the tool cannot overcome the issue. I suggest you consider a OS reinstall. The system files are missing or corrupt.

    If you have any updates, please feel free to show me.

    Best regards,


    Barry Wang [MSFT]
    MSDN Community Support | Feedback to us

    Friday, May 11, 2012 7:39 AM
    Moderator
  •  Hi again,

    Sorry that you were not able to look at the file... Here's what it reads:

    [Collect]
    OptionsFile=
    CommandLine="C:\Users\T L\Desktop\Collect.exe"
    Version=11.0.30712.0
    Variant=External
    LocalTime=2012.05.09 16:12:32

    [OSInfo]
    Version=6.0.6001
    Major=0x00000006  ;6
    Minor=0x00000000  ;0
    Build=0x00001771  ;6001
    PlatformId=0x00000002  ;2
    CSDVer=Service Pack 1
    SPMajor=0x0001  ;1
    SPMinor=0x0000  ;0
    SuiteMask=0x0300  ;768
    ProductType=0x01  ;1
    ProductInfo=3
    ProductInfoName=Home Premium

    [MachineMsiPolicy]
    ;Reg Key: HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\Installer

    [UserMsiPolicy]
    ;Reg Key: HKEY_CURRENT_USER\SOFTWARE\Policies\Microsoft\Windows\Installer

    [CLR]
    mscoreeVersion=4.0.31106.0

    [CPU]
    Branding=Pentium(R) Dual-Core CPU       T4200  @ 2.00GHz
    String=GenuineIntel
    Stepping=10
    Model=7
    Family=6
    ExtendedModel=1
    CacheLineSize=64
    CacheSize=1024K
    Cores=2

    [Directories]
    Temp=C:\Users\T L\AppData\Local\Temp\
    WindowsDirectory=C:\Windows
    CSIDL_PROGRAM_FILES=C:\Program Files
    CSIDL_COMMON_APPDATA=C:\ProgramData
    CSIDL_WINDOWS=C:\Windows
    CSIDL_SYSTEM=C:\Windows\system32
    CSIDL_PROGRAM_FILES=C:\Program Files
    CSIDL_SYSTEMX86=C:\Windows\system32
    CSIDL_PROGRAM_FILESX86=C:\Program Files
    CSIDL_PROGRAM_FILES_COMMON=C:\Program Files\Common Files
    CSIDL_PROGRAM_FILES_COMMONX86=C:\Program Files\Common Files


    [C:\]
    Type=Fixed
    Total=294057 MB
    TotalFree=196875 MB
    CallerFree=196875 MB

    [D:\]
    Type=Fixed
    Total=11182 MB
    TotalFree=1865 MB
    CallerFree=1865 MB

    [E:\]
    Type=CD

    [FileList]
    0=C:\Users\T L\AppData\Local\Temp\VSSetupEvents.txt
    1=C:\Users\T L\AppData\Local\Temp\cbs.log
    2=C:\Users\T L\AppData\Local\Temp\WindowsUpdate.log
    3=C:\Users\T L\AppData\Local\Temp\ReportingEvents.log
    4=C:\Windows\Microsoft.NET\Framework\v2.0.50727\ngen.log
    5=C:\Windows\Microsoft.NET\Framework\v2.0.50727\ngen_service.log
    6=C:\Windows\Microsoft.NET\Framework\v2.0.50727\ngen_service.old.log
    7=C:\Users\T L\AppData\Local\Temp\dd_clwireg.txt
    8=C:\Users\T L\AppData\Local\Temp\dd_depcheck_NETFX20_EXP_35.txt
    9=C:\Users\T L\AppData\Local\Temp\dd_dotnetfx20error.txt
    10=C:\Users\T L\AppData\Local\Temp\dd_dotnetfx20install.txt
    11=C:\Users\T L\AppData\Local\Temp\MSI2b7aa.LOG
    12=C:\Users\T L\AppData\Local\Temp\MSI49ae3.LOG
    13=C:\Users\T L\AppData\Local\Temp\MSI59210.LOG
    14=C:\Users\T L\AppData\Local\Temp\ASPNETSetup.log
    15=C:\Windows\temp\dd_clwireg.txt
    16=C:\Windows\temp\KB2478663_20120425_112831188.html
    17=C:\Windows\temp\KB2518870_20120425_112014500.html
    18=C:\Windows\temp\KB2478663_20120425_112831188-Microsoft .NET Framework 4 Client Profile-MSP0.txt
    19=C:\Windows\temp\KB2518870_20120425_112014500-Microsoft .NET Framework 4 Client Profile-MSP0.txt
    20=C:\Users\T L\AppData\Local\Temp\MsiInv.txt

     I previously tried the SFC/scannow to fix the problem, however, it did not work. So I'll try the article that you suggested above. Let me know if there's anything else you find after reviewing the "CollectInfo" file above. And I will definitely send you the results after using the article above.

    Thanks again :-)

    Friday, May 11, 2012 1:54 PM