none
How to connect the source control server (TFS) outside of firewall?

    Question

  • As the title. Searching internet returns all things with Proxy Server, a total different thing. I don't see anywhere I can specify the proxy.

     

    • Moved by Edwer Fang Monday, August 23, 2010 5:11 AM (From:Getting Started With Visual Studio Team System)
    Friday, August 20, 2010 4:19 PM

All replies

  • See http://msdn.microsoft.com/en-us/library/bb668967.aspx
    Ewald - Please remember to mark the replies as answers if they help.

    Ewald Hofman
    Blog: www.ewaldhofman.nl
    Friday, August 20, 2010 6:39 PM
  • I didn't get it. I have no control for the TFS server. It is outside of the firewall. I'm behind the firewall. I need to see where I can set the proxy server and port for my client (Visual Studio 2010) so it can go out to get the data from the TFS server.  Thanks for your attention.
    Friday, August 20, 2010 7:13 PM
  • Now I get the question.

    See http://stackoverflow.com/questions/1005955/connecting-to-team-foundation-server-tfs-with-proxy-authentication


    Ewald - Please remember to mark the replies as answers if they help.

    Ewald Hofman
    Blog: www.ewaldhofman.nl
    Friday, August 20, 2010 7:55 PM
  • thanks. The link looks like exactly the problem I'm having. I tried some suggestions in the link, but it didn't work.
    Friday, August 20, 2010 8:23 PM
  • Hello,

    I am moving this post to Team Foundation Server - General Forum so you can get better and quicker response as there are more experts on this kind of issues.

    Thanks for your understanding.


    Edwer Fang [MSFT]
    MSDN Subscriber Support in Forum
    If you have any feedback on our support, please contact msdnmg @ microsoft.com

    Please remember to mark the replies as answers if they help and unmark them if they provide no help
    Monday, August 23, 2010 5:11 AM
  • Smart,

    In order to connect to any TF 2010 server over the Internet you will need to know the full URL, path, and port being used so you can enter them when prompted by Team Explorer (TE). For example, if I open TE and add a server named TFS.MyDomain.com that uses path 'tfs' and listens on port 8081 over SSL I'd fill out my TE 2010 "Add Team Foundation Server" dialog like this:

    Name or URL of Team Foundation Server: TFS.MyDomain.com
    Path: tfs
    Port number: 8081
    Protocol: HTTPS

    Assuming you have permissions and can get *out* through your firewall, that should let you connect.

    Now you also mentioned proxy. There is actually a source control proxy in TFS which is what you may mean. This is usually a dedicate machine that lives at the same site as developers when the TF server is at another, distant site. The machine has TFS proxy installed from the TFS DVD and is itself configured to connect to the off-site TF server. Then, developers configure their Team Explorer\VS to access TFS source code control *through* that machine (after they have established connectivity with it). This is accomplished via the Tools>Options>Source Control>Visual Studio Team Foundation Server dialog inside Visual Studio. You would check the "Use proxy server for file downloads" box and configure the proxy server and port accordingly. These values will have to come from your TFS admin. As I mentioned, this TFS proxy machine is most useful when located at a developer site when the TF server is at another location, and is only for source control - it does not enhance the performance of any of the other parts of TFS like work item tracking, documents, reporting, etc.

    I hope this helps. If not, please reply and try to explain more fully the problem you are facing, complete with any error message(s) you may see.


    --Trevor H.
    Send files to Hotmail.com: "MS_TREVORH"
    Check out the Microsoft CTS TFS BLOG: blogs.msdn.com/b/dstfs
    Friday, August 27, 2010 8:53 PM
  • Do you still need help?
    --Trevor H.
    Send files to Hotmail.com: "MS_TREVORH"
    Check out the Microsoft CTS TFS BLOG: blogs.msdn.com/b/dstfs
    Wednesday, September 01, 2010 8:54 PM