none
Application icon missing

    Question

  • I have built an application in VS Lightswitch 2011 trial version and added a 32x32 png application icon in the application general properties. When I deploy it as a 2-tier desktop application the icon is missing from the start menu. A generic "Application Reference" icon is there in its place. The proper icon shows up in "Add/Remove Programs" as well as the task bar. I have tried uninstalling the application, clearing the icon cache and re-installing the application with the same result. Installing on another computer also has the same result.

    Anybody have any ideas?

    Friday, August 19, 2011 9:14 PM

Answers

  • Unfortunately, this is a known problem, with no know solution.

    It appears to either be a bug in the Silverlight launcher, or a problem with LS only allowing a 32x32 icon  to be specified.

    The team are aware of the problem, & have it listed internally as a something to fix if possible.


    Yann

    (plus ça change, plus c'est la même chose!)

    • Marked as answer by tkeen Friday, August 19, 2011 9:43 PM
    Friday, August 19, 2011 9:38 PM
    Moderator

All replies

  • Unfortunately, this is a known problem, with no know solution.

    It appears to either be a bug in the Silverlight launcher, or a problem with LS only allowing a 32x32 icon  to be specified.

    The team are aware of the problem, & have it listed internally as a something to fix if possible.


    Yann

    (plus ça change, plus c'est la même chose!)

    • Marked as answer by tkeen Friday, August 19, 2011 9:43 PM
    Friday, August 19, 2011 9:38 PM
    Moderator
  • Thank you for such a quick response.

    Now that I know its a know problem I can stop pulling my hair out trying to figure out what I'm doing wrong! Time to move on.

    Cheers,

    Friday, August 19, 2011 9:43 PM
  • You're welcome!

    Yann

    (plus ça change, plus c'est la même chose!)

    Friday, August 19, 2011 9:54 PM
    Moderator
  • I added an icon (png, 32x32) to my project and published desktop applicaton. I can't see icon in Start Menu.

    Can you help me?

     


    • Edited by Marcin Sulecki Tuesday, October 25, 2011 12:14 PM more specified
    Tuesday, October 25, 2011 12:11 PM
  • It's very fun that Microsoft have problem with easy icon :)

     

    I found an article about this:

    http://thedatafarm.com/blog/dotnet/after-three-years-i-discover-how-to-choose-a-clickonce-icon-in-mageui/

    I opened manifest file in MageUI, but I can't see Files folder.

     

    Tuesday, October 25, 2011 1:05 PM
  • Unfortunately, this is a known problem, with no know solution.

    It appears to either be a bug in the Silverlight launcher, or a problem with LS only allowing a 32x32 icon  to be specified.

    The team are aware of the problem, & have it listed internally as a something to fix if possible.


    Yann

    (plus ça change, plus c'est la même chose!)

    Hi Yann,

    This issue is more than a year old, any news on the matter for VS2013? I've just published a desktop LS App built with VS2012 Update 4 RC and still the same. It's a shame.

    Regards.

    Saturday, August 24, 2013 6:08 AM