none
dtip

    Question

  • what .NET framework version is compatable with windows 7 64 bit when I download 2.0  and install it says it's not compatable
    Tuesday, October 27, 2009 7:22 PM

Answers

  • Hi Dtip,

    Welcome to MSDN forums. And thank you for your post.

    For Windows 7, .NET Framework 3.5 with SP1 is shipped with it as one of OS component.
    For .NET Framework 3.5 with SP1, it includes .NET 2.0 with SP2 and .NET 3.0 with SP2 as prerequisite.
    This means, you have the .NET Framework 2.0 SP2, 3.0 SP2 and 3.5 SP1 plus a few post 3.5 SP1 bug fixes on Windows 7. They are OS components. .NET 3.0 SP2 and 3.5 SP1 can be added or removed via the Programs and Features control panel.Thus, we don't need to manually install them. That's why you received the error message when you tried to install .NET 2.0 on Windows 7.
    For more information, please check: http://blogs.msdn.com/astebner/archive/2007/03/14/mailbag-what-version-of-the-net-framework-is-included-in-what-version-of-the-os.aspx

    Hope this helps! If you have any concern, please feel free to let me know.

    Best regards,
    Yichun Chen
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    Welcome to the All-In-One Code Framework! If you have any feedback, please tell us.
    • Marked as answer by YiChun Chen Tuesday, November 03, 2009 2:51 AM
    Thursday, October 29, 2009 3:41 AM