none
Error with Microsoft.CppCommon.targets file

    Question

  • Error 84 error MSB6006: "cmd.exe" exited with code 1. C:\Program Files (x86)\MSBuild\Microsoft.Cpp\v4.0\Microsoft.CppCommon.targets

     

    I have a solution with a lot of projects and sometimes this error appears. I have been reinstalling once and it resolved the problem but now even if i reinstall i always get this error and i don't know why.

     

    YanGd

    Tuesday, July 26, 2011 8:58 AM

All replies

  • Hi,

     

    Thank you for your question, we're doing research on this case, it might take some time before we get back to you.


    Eric Yang [MSFT]
    MSDN Community Support | Feedback to us
    Get or Request Code Sample from Microsoft
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    Thursday, July 28, 2011 2:33 AM
  • Generally it means that there is something wrong when execute the batch command in Microsoft.CppCommon.targets. Could you please post your the whole compile output related to this error?

     

    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Regards,
    Han Xia
    Microsoft Online Community Support

    Thursday, August 04, 2011 1:58 AM
  • I resolve my problem by removing VSCommand 2010 tools that i had previously installed.
    YanGd
    • Marked as answer by YanGd Thursday, August 04, 2011 7:12 AM
    • Unmarked as answer by YanGd Monday, August 08, 2011 4:08 AM
    Thursday, August 04, 2011 7:11 AM
  • Finally at home, i have the same message without VSCommand 2010 tools installed, so i copy the message for you :

    1>------ Build started: Project: ZERO_CHECK, Configuration: Debug x64 ------

    1>  Checking Build System

    1>  The system cannot find the path specified.

    1>  The system cannot find the batch label specified - VCReportError

    1>C:\Program Files (x86)\MSBuild\Microsoft.Cpp\v4.0\Microsoft.CppCommon.targets(151,5): error MSB6006: "cmd.exe" exited with code 1.

    2>------ Build started: Project: 13.8.Blinker, Configuration: Debug x64 ------

    2>C:\Windows\Microsoft.NET\Framework\v4.0.30319\Microsoft.Common.Targets(1200,9): warning : The referenced project 'C:/Users/.../.../.../ZERO_CHECK.vcxproj' does not exist.

    2>  Building Custom Rule C:/Program Files/.../.../.../.../.../.../Cxx/CMakeLists.txt

    2>  The system cannot find the path specified.

    2>  The system cannot find the batch label specified - VCReportError

    2>C:\Program Files (x86)\MSBuild\Microsoft.Cpp\v4.0\Microsoft.CppCommon.targets(151,5): error MSB6006: "cmd.exe" exited with code 1.

    ========== Build: 0 succeeded, 2 failed, 0 up-to-date, 0 skipped ==========


    YanGd
    Monday, August 08, 2011 5:03 AM
  • it's likely that you projects use a custom build. You can openMicrosoft.CppCommon.targets by notepad and check which line it report that error.  I think it's because " The system cannot find the path specified." Maybe your custom build srcipt want to access a path which doesn't exist.

     

    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Regards,
    Han Xia
    Microsoft Online Community Support

     

     

    Tuesday, August 09, 2011 2:48 AM