none
Visual C++ 2005 Redistributable Package (x86) sp1 install problem

    Question

  • i have win xp.
    I am trying to install Visual C++ 2005 Redistributable Package (x86) sp1.  i am going to http://www.microsoft.com/downloads/details.aspx?familyid=200B2FD9-AE1A-4A14-984D-389C36F85647&displaylang=en to download vcredist_x86.exe

    when i run this the license agreement indicates that it is SP1.  After I accept the license agreement it starts to install.  However while it is installing the title of that window doesn't say SP1.  When the process is complete and I goto add/remove programs it doesn't say SP1, it says "Microsoft Visual C++ 2005 Redistributable".  When I try to install turbo tax 2009 I get "The application failed to initialize properly (0xc0150004).  Click on OK to terminate the application."  I googled that problem and found this http://turbotax.intuit.com/support/kb/installing/errors/5320.html which specifies that the reason I get this error when trying to install turbo tax is b/c I need vc++ 2005 redist sp1 but for some reason I can only install the non-sp1 version.

    Anyone have any ideas why i can't get sp1?
    Friday, February 12, 2010 12:35 AM

Answers

  • What it says during installation and what shows up in add/remove has always had that problem, I'm annoyed by it too.  It says Microsoft Visual C++ 2005 redistributable and the version column says 8.0.56336.  Pretty meaningless info.  But if you check the Windows Installer logs you can see what is installed into WinSxs, and it is the correct version.  I say that what ever problem you're having, it's not related to installing the wrong version.  The correct version is getting installed.
    • Marked as answer by Nancy Shao Wednesday, February 17, 2010 8:26 AM
    Sunday, February 14, 2010 5:20 AM

All replies

  • That actually is the SP1 installer.  I'm guessing that maybe the security update needs to be installed.  Try the vcredist_x86.exe from here:

    http://www.microsoft.com/downloads/details.aspx?familyid=766a6af7-ec73-40ff-b072-9112bab119c2&displaylang=en
    Friday, February 12, 2010 4:35 AM
  • same result.....license agreement says sp1 but when installation starts it no longer says sp1.   upon completion going to add/remove software yields the ms visual c++ 2005 redistributable with the "sp1" missing.
    Friday, February 12, 2010 11:11 PM
  • What it says during installation and what shows up in add/remove has always had that problem, I'm annoyed by it too.  It says Microsoft Visual C++ 2005 redistributable and the version column says 8.0.56336.  Pretty meaningless info.  But if you check the Windows Installer logs you can see what is installed into WinSxs, and it is the correct version.  I say that what ever problem you're having, it's not related to installing the wrong version.  The correct version is getting installed.
    • Marked as answer by Nancy Shao Wednesday, February 17, 2010 8:26 AM
    Sunday, February 14, 2010 5:20 AM
  • As Ted_ said, regardless of what the installer says it installs the correct version. Under the winsxs directory it installs 8.0.50727.4027 which is the latest version and everything would be routed to using this.

    The thing here is that 0xc0150004 means that the program failed to initialise, that is all. It doesn't point to one specific problem. I would suggest doing a general cleanup and then ask at their support service. They would be better qualified to help you.
    Visit my (not very good) blog at http://c2kblog.blogspot.com/
    Sunday, February 14, 2010 8:57 AM