none
How to enable multisample Anti-aliasing in WPF?

    Question

  • Hi guys,i want to display 3d models in  a wpf application. i used zam 3d to convert .3ds to xaml,but when i run the application the output is not smooth, that is i can see a lot of sharp edges. is there any option that i can set to increase the MSAA? If so can anybody tell me how?

    Thanks and regards,

    Prashanth MP


    Thanks and Regards, Prashanth MP.

    Monday, April 30, 2012 4:57 AM

Answers

  • Hi Prashanth,

    Have you tried to set the attached property  RenderOptions.EdgeMode = "Aliased" inViewport3D?

    By default, 3D antialiasing is disabled on Microsoft Windows XP and enabled on Windows Vista with 4 samples per pixel.

    Please let me know if this works for you.

    Have a nice day.


    Annabella Luo[MSFT]
    MSDN Community Support | Feedback to us

    Wednesday, May 02, 2012 3:44 AM
    Moderator

All replies

  • Hi Prashanth,

    Have you tried to set the attached property  RenderOptions.EdgeMode = "Aliased" inViewport3D?

    By default, 3D antialiasing is disabled on Microsoft Windows XP and enabled on Windows Vista with 4 samples per pixel.

    Please let me know if this works for you.

    Have a nice day.


    Annabella Luo[MSFT]
    MSDN Community Support | Feedback to us

    Wednesday, May 02, 2012 3:44 AM
    Moderator
  • Hi Prashanth,

    We haven't heard from you for almost a week, so we are temporarily marking this as "Answer", if you have any concerns or new findings; please feel free to let me know.
    Best regards.


    Annabella Luo[MSFT]
    MSDN Community Support | Feedback to us

    Tuesday, May 08, 2012 9:35 AM
    Moderator