none
"project type is not supported by this installation"

    Question

  • Just installed VS2010 and trying to do some REST web services.  When I try to create a new project of type "WCF Rest service Application" (which I downloaded from the online template gallery), I get "the project type is not supported by this installation".  Interestingly enough, same error is generated when I try to create a project of type "WCF Service Application" (template which ships with VS 2010).

    Also came across an EXCELLENT tutorial @ "http://blogs.msdn.com/b/endpoint/archive/2010/01/07/getting-started-with-wcf-webhttp-services-in-net-4.aspx", which has downloadable code.  Guess what, same error.

    I am using VS2010 on Win7 x64.  IIS is not installed on the machine - could that be an issue?  I assumed it would use Cassini while in VS.

    Thanks for any help,

    Joe

    My apologies if this is not in the correct forum.  I dont think its related to the WCF, but hey, if I was an expert, I wouldnt be asking all of you, right?  :-)

    • Moved by Alan_chen Thursday, August 26, 2010 2:45 AM (From:Visual C# IDE)
    • Moved by Larcolais Gong Thursday, August 26, 2010 5:13 AM (From:.NET Framework Setup)
    Tuesday, August 24, 2010 9:37 AM

All replies

  • What edition of VS2010 are you running?

    Michael Taylor - 8/24/2010
    http://msmvps.com/blogs/p3net

    • Marked as answer by Mog Liang Friday, August 27, 2010 3:49 AM
    • Unmarked as answer by Mog Liang Friday, August 27, 2010 3:50 AM
    Tuesday, August 24, 2010 1:33 PM
    Moderator
  • I have the same problem. I got "the project type is not supported by this installation" when I tried to create a new "WCF service" project.

    I don't have problems when I create a "WCF library" project.

     

    My configuration is:

    - Visual Studio 2010 Professional (c#, c++, vb.net)

    - Windows 7 Home Edition

     

    I installed Visual Web Developer 2010 express and I was able to create the WCF service project.

     

    Please help me!

    Thursday, November 25, 2010 2:04 PM
  • Try repairing the installation and/or running in safemode to ensure nothing is conflicting with it.

    Michael Taylor - 11/26/2010
    http://msmvps.com/blogs/p3net

    Friday, November 26, 2010 2:12 PM
    Moderator
  • Try opening your Visual Studio project files in notepad, Remove the ProjectTypeGuids, save and open again. It helped us resolve our issue, though our scenario was different. We were trying to open VS 2005 project file in VS 2010.

    http://vinaybhatia.blogspot.com/2010/12/opening-visual-studio-2005-projects-in.html

    Monday, December 06, 2010 6:13 PM