none
Using Visual Studio 2008 with Team Foundation Server 2010?

    Question

  • Hi,

    I am a student-developer working with a small team, I am running:

    Win 7 32 bit with 2 GB RAM

    Visual Studio 2008 Team System

    Team Foundation Server 2010

    For my project, I wanted to do the following:

    Maintain versioning of my code ...

    Control the check-ins to the central code repository

    Take notes for each day's build ...

    Can you please suggest how I can get VS 2008 to connect to my TFS ...

    Will Team Explorer Everywhere 2010 do the trick?

    Thursday, April 15, 2010 6:49 PM

Answers

  • Thank you for  Joe's kindly help.

    Hi Manish.kungwani,

    Thank you for your reply.

    As Joe mentioned, we should pay attention on the steps to apply Team Explorer and SP1 in order.

    Firstly, Team Explorer 2008 SP1 is part of Visual Studio 2008 SP1. There is no separate SP1 for Team Explorer 2008.

    Secondly, I noticed that you have applied VS2008 SP1 after you had installed VSTS2008 on your machine. However, after installing Team Explorer 2008, we still need to re-apply VS2008 SP1 to upgrade Team Explorer 2008 to SP1.

    Generally, if we want to install VS2008, VS2008 SP1, Team Explorer 2008 and VSTS 2008 Forward Compatibility Update, we should follow these steps:

    - Install Visual Studio 2008
    - Install Team Explorer 2008
    - Install Visual Studio 2008 SP1 (This will upgrade both VS2008 and Team Explorer 2008 to SP1)
    - Install VSTS 2008 Forward Compatibility Update

    Hope this helps! If you have any concern, please feel free to let me know.

    Best regards,
    Yichun Chen
    MSDN Subscriber Support in Forum
    If you have any feedback on our support, please contact msdnmg@microsoft.com
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    Welcome to the All-In-One Code Framework! If you have any feedback, please tell us.
    Tuesday, April 20, 2010 3:30 AM
  • Team Explorer 2008 is patched as part of the VS 2008 SP1 install process.  You should re-apply VS 2008 SP1 and the forward compatibility update, as described above.

     

    Regards,

    Joe

     

    Monday, April 19, 2010 7:16 PM
  • Hi, although the team explorer 08 now connects to the TFS 2010, yet it doesn't allow me to create a team project despite having all pemissions :(

    I get the following error:

    and following error when i press OK:

    Please Help!

    Tuesday, April 20, 2010 9:27 AM

All replies

  • You need to install the forward compatibility Update: http://www.microsoft.com/downloads/details.aspx?FamilyID=CF13EA45-D17B-4EDC-8E6C-6C5B208EC54D&displaylang=en
    Ewald - Please remember to mark the replies as answers if they help.

    Ewald Hofman
    Blog: www.ewaldhofman.nl
    • Proposed as answer by BenJoe Thursday, April 15, 2010 8:28 PM
    • Unproposed as answer by Manish.kungwani Sunday, April 18, 2010 5:25 AM
    Thursday, April 15, 2010 6:58 PM
  • Yes, but you also need to install Team Explorer 2010 because you can't create new build definitions from within Visual Studio 2008. You can only start a build from there.
    Friday, April 16, 2010 5:36 AM
  • Hi Manish.kungwani,

    To make Visual Studio 2008 Team Explorer to work with TFS2010, we should install VS2008 SP1 and then VSTS 2008 Forward Compatibility Update. The update will allow teams to move forward and use the 2010 server even if part of a team that uses the 2008 client.

    TFS2010 introduces the notion of Team Project Collections.
    After the installation is completed successfully, we should provide the entire URL to connect TFS2010 server.
    We can express the connection string as follows:

    http://<serverName>:<port>/<vdir>/<collectionName> (e.g. http://TfsName:8080/Tfs/ProjectCollectionName)

    The <vdir> is an optional path for the TFS web sites specified by the administrator during setup. By default it is “tfs”.

    By providing the name of the project collection, events can be scoped for that collection only.

    For more information, please check: http://blogs.msdn.com/teams_wit_tools/archive/2009/10/19/compatibility-matrix-for-2010-beta-2-team-foundation-server-to-team-explorer-2008-and-2005.aspx#_Toc243567874

    Hope this helps! If you have any concern, please feel free to let me know.

    Best regards,
    Yichun Chen
    MSDN Subscriber Support in Forum
    If you have any feedback on our support, please contact msdnmg@microsoft.com
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    Welcome to the All-In-One Code Framework! If you have any feedback, please tell us.
    Friday, April 16, 2010 9:08 AM
  • Hi,
    When connecting VS 2008 SP1 with Team Explorer 2008 with Fwd compatibility pach installed, I am not able to input the complete URL when adding a server!!!
    I have uploaded the image at: http://manishkungwani.com/blog/wp-content/uploads/2010/04/tfs-err.png

    Also, when I try to give the name of my pc as the server name, I get the following error:http://manishkungwani.com/blog/wp-content/uploads/2010/04/tfs-err-2.png


    Please guide me!!

    Friday, April 16, 2010 7:31 PM
  • Just put the full url in the TFS name text box: http://myserver:8080/tfs/defaultcollection
    Ewald - Please remember to mark the replies as answers if they help.

    Ewald Hofman
    Blog: www.ewaldhofman.nl
    Friday, April 16, 2010 7:47 PM
  • Tried that, it shows the following error(with the fwd compatibility update!) :

    >Database Tables

    I tried installing Team Explorer 2010 but that doesnt work with VS 08.

    No I am at square 1:

    VS 08 SP1

    With TFS 2010

    Wat shall I do?

    Saturday, April 17, 2010 6:03 PM
  • Please help!!!!

    No replies????

    Sunday, April 18, 2010 6:07 PM
  • Hi,

    You can try below steps, it might help to resolve your issue.

    Close the Visual Studio, Go to the registry  and Edit registry value: HKEY_CURRENT_USER/Software/Microsoft/VisualStudio/9.0/TeamFoundation/Servers.

    Add a new String Value in there and make the name of it to the name that you want to call your server connection, Make the Value “http://manish-pc:8080/tfs/TraffenCollection “.

     Then reopen the visual studio and try to connect again.


     

    Sunday, April 18, 2010 7:43 PM
  • Hi Manish.kungwani,

    Thank you for your reply.

    Please make sure that you have upgraded Team Explorer 2008 to SP1.

    If it still doesn't work, you can try the following steps to reinstall Team Explorer 2008.

    - Install Team Explorer 2008
    - Install Visual Studio 2008 SP1
    - Install VSTS 2008 Forward Compatibility Update

    Hope this helps! If you have any concern, please feel free to let me know.

    Best regards,
    Yichun Chen
    MSDN Subscriber Support in Forum
    If you have any feedback on our support, please contact msdnmg@microsoft.com
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    Welcome to the All-In-One Code Framework! If you have any feedback, please tell us.
    Monday, April 19, 2010 7:07 AM
  • Hi YiChun,

    The following was the order in which I installed the software:

    1. VS Team System 2008

    2. VS 08 SP1

    3. TFS 2010

    4. Team Explorer 2008

    5. Forward Compatibility Update

    Yet the solution doesn't work!

    Could you please suggest what shall I do ..?

    Is there a service pack only for Team Explorer 2008?

    Monday, April 19, 2010 3:02 PM
  • Team Explorer 2008 is patched as part of the VS 2008 SP1 install process.  You should re-apply VS 2008 SP1 and the forward compatibility update, as described above.

     

    Regards,

    Joe

     

    Monday, April 19, 2010 7:16 PM
  • Thank you for  Joe's kindly help.

    Hi Manish.kungwani,

    Thank you for your reply.

    As Joe mentioned, we should pay attention on the steps to apply Team Explorer and SP1 in order.

    Firstly, Team Explorer 2008 SP1 is part of Visual Studio 2008 SP1. There is no separate SP1 for Team Explorer 2008.

    Secondly, I noticed that you have applied VS2008 SP1 after you had installed VSTS2008 on your machine. However, after installing Team Explorer 2008, we still need to re-apply VS2008 SP1 to upgrade Team Explorer 2008 to SP1.

    Generally, if we want to install VS2008, VS2008 SP1, Team Explorer 2008 and VSTS 2008 Forward Compatibility Update, we should follow these steps:

    - Install Visual Studio 2008
    - Install Team Explorer 2008
    - Install Visual Studio 2008 SP1 (This will upgrade both VS2008 and Team Explorer 2008 to SP1)
    - Install VSTS 2008 Forward Compatibility Update

    Hope this helps! If you have any concern, please feel free to let me know.

    Best regards,
    Yichun Chen
    MSDN Subscriber Support in Forum
    If you have any feedback on our support, please contact msdnmg@microsoft.com
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    Welcome to the All-In-One Code Framework! If you have any feedback, please tell us.
    Tuesday, April 20, 2010 3:30 AM
  • Hi, although the team explorer 08 now connects to the TFS 2010, yet it doesn't allow me to create a team project despite having all pemissions :(

    I get the following error:

    and following error when i press OK:

    Please Help!

    Tuesday, April 20, 2010 9:27 AM
  • Hi Manish.kungwani,

    Thank you for your reply.

    I've looked through your new problem and it's not directly related to the original issue. Thus it would be best if you open up a new thread for the new question. In this way, our discussion here will not deviate too much from the original issue. This will make answer searching in the forum easier and be beneficial to other community members as well. Our engineers are willing to help you on that.

    Thank you for your understanding.

    Best regards,
    Yichun Chen
    MSDN Subscriber Support in Forum
    If you have any feedback on our support, please contact msdnmg@microsoft.com
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    Welcome to the All-In-One Code Framework! If you have any feedback, please tell us.
    Tuesday, April 20, 2010 9:40 AM
  • Hi,

    Every think is fine , but when you connect TFS repository you required Team Explorer.

    it means check your OS(client machine have Team Explorer are not) if not install. after install

    steps:

    1. Open VS 2008

    2. Add TFS server into Team Explorer ex: tfsserver(TFS servername) and port number by default 8080 if any other port you need to mention  

    3.  in Main menu Tools>Options>Source control> plun-in slection there you choose VS team foundtation server. after that automatically connected.

    Note: Each client machine requre Tem explorer.

    Regards
    Kedarnath Mundluru

    Tuesday, April 20, 2010 9:45 AM
  • hi Manish,

    dont use http://manish-pc:8080/tfs/trefferncollection/

    Just type Teamfoundation server name like example : Server name if not understand go to command prompt type hostname you will get servername and copy and past above box. port number you keep same.
    if you have any problem please send me again. i dont think you will problem.

     

    Regards
    Kedarnath

     

    Tuesday, April 20, 2010 9:52 AM
  • Hi YiChun,

    I will ask the question in  another thread :)

    @Mr Kedaranath

    Sir,

    the solutions you have provided worked on TFS 08, not tfs 2010...

    Tuesday, April 20, 2010 1:21 PM
  • Hi Manish,

    Instead of using  http://manish-pc:8080/tfs/trefferncollection/  you can replace with below path for TFS 2010 below one not work in TFS 2008

    http://manish-pc:8080/tfs

    And one question from my side i have checked your screen shot its clearly mention should not use any : or special character in servername. please let me know you are using TFS 2008 or TFS 2010

    if TFS 2010 also not required any port number in the url only servername is enough

     

    Regards
    Kedarnath

    Wednesday, April 21, 2010 4:48 AM
  • Hi Kedaranath,

    Again, that works with Team Explorer 2010 and not Team Explorer 2008  ...

    Wednesday, April 21, 2010 5:19 AM
  • Hi Manish,

    Please let me know what Team Explorer are you working with.

    if you use Team explorer 2008 below one it wont support.

    http://manish-pc:8080/tfs

    For Team Explorer 2008

    servername only ex: manish-pc

    port number by default it will give.

    Regards
    Kedarnath

     

    Friday, April 23, 2010 5:56 AM
  • You don’t need to upgrade your code from .Net 3.5 to .Net 4.0 (So that you can open it in VS 2010) just because your project is moved to TFS 2010. VS 2008 with SP1 supports connecting TFS 2010. While adding a project from TFS 2010, Team foundation server name should include full path of the project collection.

    i.e. http://<Server name>:<port number>/<virtual directory name>/<project collection name>

    You can refer the link below

    http://ravendra.wordpress.com/2010/06/01/connect-to-tfs-2010-from-visual-studio-2008/

    Tuesday, June 01, 2010 4:19 PM
  • The reason you get the Special Characters are not permitted when entering the URL of the TFS Project Collection is due to the order of installation SP1 should be run last and you will not have this issue

    1. VS2008

    2. VS2008 Team Explorer

    3. VS2008 SP1

    4. VS2008 Forward Compatability Update with SP1

    If you were using the The VS2008 Forward Cmpatability Update without SP1 you would need to run SP1 last

     

     

    -Ivan


    Ivan Sanders My LinkedIn Profile, My Blog, @iasanders.
    Thursday, March 17, 2011 7:30 PM
  • Hi All, Please check out the following link. This will surely helps you...

    http://marknic.net/2010/04/28/accessing-tfs-2010-from-visual-studio-2008-2005-ide/

    Thanks and Regards,
    Mahesh O A
    Monday, February 13, 2012 6:43 AM
  • Yes. It fixed my issue.
    Friday, March 02, 2012 3:35 AM