none
Error 404 when trying to upload file

    Question

  •  

    Hello dear colleagues,

     

     

     

    Im getting following error when I try to upload a file (exe-file ~65MB):

     

    from Team Explorer: "The remote server returned an error (404) not found"

     

    from the team portal site after I hit the upload button: "The webpage cannot be found"

     

    Uploading is working for other files. I think TFS has a Problem with the size of the file.

     

     

    I tried to set the max filesize in the Configuration Settings Service:

     

    http://TFSSERVER:8080/WorkItemTracking/v1.0/ConfigurationSettingsService.asmx?op=SetMaxAttachmentSize

     

    I entered 2147483648 (bytes) for a max filesize of 2GB. After I hit the "invoke button" it says "the website cannot display the page" (HTTP500 - internal server error).

     

    What's the Problem here?

     

    regards,

     

     

    Pete

    Wednesday, October 01, 2008 11:38 AM

Answers

  • hello colleagues,


    After a extensive and nerve-wracking search for the error that lastet at least 4 weeks, I found out that my problem is a bug of WSS3.0 when working in combination with IIS7.0 (Internet information services). Regardless wether you edited the max filesize in your sharepoint central administration you simpy couldn't upload files bigger than 28MB.

    By chance I found an article on Microsoft's support site that pretty described my problem. To correct this error you simply have to enter the following xml section (under the <configurations> node) in the web.config
    of your sharepoint site (found in \inetpub\wwwroot\wss\VirtualDirectories\):

    <system.webServer>
        <security>
            <requestFiltering>
                <requestLimits maxAllowedContentLength="52428800"/>
            </requestFiltering>
        </security>
    </system.webServer>

    In this example the filesize was set to 50MB.
    After I editet my web.config everything worked fine.

    The corresponding link to the MS support article is:

    http://support.microsoft.com/kb/925083/EN-US/

    I hope that anyone else who has the same problem that I had will fix it faster than me.


    regards,


    Pete

    "veritas vos liberabit"
    • Marked as answer by Lunatikk Thursday, October 23, 2008 3:25 PM
    Thursday, October 23, 2008 3:25 PM

All replies

  • could it be, because I'm accessing the TFS via remote desktop?

     

     

    I'm grateful for any answer.

     

     

    regards,

     

     

    Pete

     

    Wednesday, October 01, 2008 1:40 PM
  • It is more likley that you are running into the Sharepoint file upload limit of 50MB... You can change this in the config.

     

    If you are uploading to Source control, I nam not sure what the problem may be... I upload 5 GB files with no problems Smile only time...

     

    Wednesday, October 01, 2008 3:57 PM
  • thanks for your reply.

     

     

    where can I change it? In which config?

     

     

    regards,

     

     

    Pete

     

    Wednesday, October 01, 2008 4:10 PM
  • Hi Pete

     

    Look here: http://social.technet.microsoft.com/Forums/en-US/sharepointgeneral/thread/6a54a584-3420-4e14-a36e-4d4567d7c6a7/

     

    If it isn't helping you, it could be possible that your IIS connection time-out needs to be increased.

     

    Regards

    Nicolas

     

    Wednesday, October 01, 2008 7:32 PM
  •  

    IIS connection timeout is 120 seconds in both the default-and sharepoint central administration site.

    Team Foundation Server has 3600 seconds typed in as connection timeout. But I don't get the error message after 120 seconds - I'm getting it "directly", max. 2 seconds after I try to upload the file (e.g. after I drag and drop the file in Team Explorer).

    So timouts aren't the problem, at least no timeouts > 5 secs, I guess.

    I have set the maximum upload filesize in Sharepoint central-administration to 500MB. The file I'm trying to upload is a txt file and has about 30MB. Still doesn't work. But thank you for your suggestion.

     

    Has anyone else an idea?

     

     

    ragards,

     

    Pete

     

    Thursday, October 02, 2008 7:40 AM
  • I found something out:

     

    The txt (log-) file I was trying to upload had 30.969.673 bytes. I deleted some content of the file so that it shrinked to

    29.818.700 bytes. Now I can upload it without Problems.

    It looks to me that if I hit the upload button, the filesize gets "first" checked and if it is (larger or equal?) than 30MB I'm getting the error message.

    Can I change the max filesize somewhere else?

     

     

     

    regards,

     

     

    Pete

    Thursday, October 02, 2008 7:58 AM
  • Hello Pete,

     

      Did you restart the WSS SIte?

     

      If not , could you please try to stop and restart WSS site from IIS management to see if it works.

     

      Good luck.

    Thursday, October 02, 2008 9:27 AM
  •  

    I restarted the whole server but nothing changed.

     

    regards,

     

     

    Pete

     

     

    ---edit---

     

    when I go to a documents folder (from my client machine) in the team portal site and then click on "actions" / "open with windows explorer", I can drag and drop any file there and it uploads it with no problems. However, if I try to open the folder in windows explorer on the server, nothing happens...

     

     This is very odd and I'm getting really frustrated right now :-(

     

     

    regards,

     

     

    Pete

     

    ---/edit---

    Thursday, October 02, 2008 9:42 AM
  • hello,
     

    I'm still having the same problems with the uploading of files larger than about 30MB.
    Does anyone here have a clue?


    regards,


    Pete
    "veritas vos liberabit"
    Monday, October 20, 2008 10:36 AM
  • hello colleagues,


    After a extensive and nerve-wracking search for the error that lastet at least 4 weeks, I found out that my problem is a bug of WSS3.0 when working in combination with IIS7.0 (Internet information services). Regardless wether you edited the max filesize in your sharepoint central administration you simpy couldn't upload files bigger than 28MB.

    By chance I found an article on Microsoft's support site that pretty described my problem. To correct this error you simply have to enter the following xml section (under the <configurations> node) in the web.config
    of your sharepoint site (found in \inetpub\wwwroot\wss\VirtualDirectories\):

    <system.webServer>
        <security>
            <requestFiltering>
                <requestLimits maxAllowedContentLength="52428800"/>
            </requestFiltering>
        </security>
    </system.webServer>

    In this example the filesize was set to 50MB.
    After I editet my web.config everything worked fine.

    The corresponding link to the MS support article is:

    http://support.microsoft.com/kb/925083/EN-US/

    I hope that anyone else who has the same problem that I had will fix it faster than me.


    regards,


    Pete

    "veritas vos liberabit"
    • Marked as answer by Lunatikk Thursday, October 23, 2008 3:25 PM
    Thursday, October 23, 2008 3:25 PM
  • Would You be so kind and post the fragment of the web.config file? Where exactly did You put the code. I tried the same, no luck

    Greg
    Friday, December 26, 2008 5:48 PM
  • Hello Greg,

    I put the code pretty much at the beginning. Have a look:
     

     

    1 <?xml version="1.0" encoding="UTF-8" standalone="yes"?>  
    2  
    3 <configuration> 
    4  
    5 <configSections> 
    6  
    7 <sectionGroup name="SharePoint">  
    8  
    9 <section name="SafeControls" type="Microsoft.SharePoint.ApplicationRuntime.SafeControlsConfigurationHandler, Microsoft.SharePoint, Version=12.0.0.0, Culture=neutral, PublicKeyToken=71e9bce111e9429c" /> 
    10  
    11 <section name="RuntimeFilter" type="System.Configuration.SingleTagSectionHandler, System, Version=1.0.5000.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" /> 
    12  
    13 <section name="WebPartLimits" type="System.Configuration.SingleTagSectionHandler, System, Version=1.0.5000.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" /> 
    14  
    15 <section name="WebPartCache" type="System.Configuration.SingleTagSectionHandler, System, Version=1.0.5000.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" /> 
    16  
    17 <section name="WebPartWorkItem" type="System.Configuration.SingleTagSectionHandler, System, Version=1.0.5000.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" /> 
    18  
    19 <section name="WebPartControls" type="System.Configuration.SingleTagSectionHandler, System, Version=1.0.5000.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" /> 
    20  
    21 <section name="SafeMode" type="Microsoft.SharePoint.ApplicationRuntime.SafeModeConfigurationHandler, Microsoft.SharePoint, Version=12.0.0.0, Culture=neutral, PublicKeyToken=71e9bce111e9429c" /> 
    22  
    23 <section name="MergedActions" type="System.Configuration.SingleTagSectionHandler, System, Version=1.0.5000.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" /> 
    24  
    25 <section name="PeoplePickerWildcards" type="System.Configuration.NameValueSectionHandler, System, Version=1.0.5000.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" /> 
    26  
    27 </sectionGroup> 
    28  
    29 <sectionGroup name="System.Workflow.ComponentModel.WorkflowCompiler" type="System.Workflow.ComponentModel.Compiler.WorkflowCompilerConfigurationSectionGroup, System.Workflow.ComponentModel, Version=3.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35">  
    30  
    31 <section name="authorizedTypes" type="System.Workflow.ComponentModel.Compiler.AuthorizedTypesSectionHandler, System.Workflow.ComponentModel, Version=3.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" /> 
    32  
    33 </sectionGroup> 
    34  
    35 </configSections> 
    36  
    37 <!-- @Greg: Here is where it starts--> 
    38  
    39 <system.webServer> 
    40  
    41 <security> 
    42  
    43 <requestFiltering> 
    44  
    45 <requestLimits maxAllowedContentLength="73400320" /> 
    46  
    47 </requestFiltering> 
    48  
    49 </security> 
    50  
    51 </system.webServer> 
    52  
    53 <!-- @Greg: And here, where it ends--> 
    54  
    55 <SharePoint> 
    56  
    57 ...  
    58  
    59 </SharePoint> 
    60  
    61 ...  
    62  
    63 </configuration> 
    64  


    I hope this will work for you.




    Pete



    "veritas vos liberabit"
    Wednesday, January 07, 2009 12:26 PM
  • Thank you Pete.  I've been scouring googlewebs for hours looking for this solution.  I tried everything I could find and this ACTUALLY fixed it.



    Thanks again.
    Ruler of the undershorts
    Wednesday, March 25, 2009 7:54 AM
  • Thanks!  This was the key for me as well.
    Cheers,
    Clyde
    Wednesday, October 21, 2009 5:12 PM
  • @ Lunatikk
    Thanks for the post - saved me any more aggravation dealing with this error. I'd already applied what I thought was all the fixed listed in the KB925083 article but now see at the bottom is the IIS7 additional. What a pain! that should have been part of an SP or better described by MS.

    Fix worked as stated.

    Note that the WSS3.0 config.web file should or may already has the <system.web> section - mine was near the bottom. I just added the:

     <security>
            <requestFiltering>
                <requestLimits maxAllowedContentLength="524288000"/>
            </requestFiltering>
        </security>


    With this section (first item right under the existing <system.web>) - note I just added a "0" to the size to get my needed 500MB.

    Thanks again for a helpful question->answer post
    Tuesday, February 09, 2010 7:13 PM
  • I recommend to modify this setting in your root configuration of IIS, if you have a multi-site environment.

     

    Check out IIS manager, double click on the server node, click "Configuration Editor" and navigate to "system.webServer/security/requestFiltering" - "requestLimits/maxAllowedContentLength "

    Value is given in bytes!

    regards, PT-Soft.de

    • Proposed as answer by PT-Soft Wednesday, June 02, 2010 10:38 AM
    Wednesday, June 02, 2010 10:36 AM
  • Hey Pete,

    Fabulous solution!   Worked perfect for me.  Added the following code to the web.config here "C:\inetpub\wwwroot\wss\VirtualDirectories\80" and I can now upload large files.

    Also, like DTGrayston's post above, I added a trailing 0 at the end of maxAllowedContentLength (from 52428800 to 524288000) to get our site to handle uploads of 500mb.

    <system.webServer>
        <security>
            <requestFiltering>
                <requestLimits maxAllowedContentLength="52428800"/>
            </requestFiltering>
        </security>
    </system.webServer>

    Thursday, September 23, 2010 12:28 AM
  • it works like a charm . Thanks mate.
    Monday, June 25, 2012 2:34 AM