none
Vs2012 remote debugging

    Question

  • Hi after installing the remote debugging tools I can successfully remote debug, everything is working as expected. WHich means, connection and permissions are OK.

    However, I cannot get it to deploy anything.

    I did setup everything the way as explained here:

    http://msdn.microsoft.com/en-us/library/vstudio/8x6by8d2.aspx

    Has anyone ever managed to get the deployment part of remote debugging to work?

    FYI my project is x64 native c++, 

    Dev machine: win7 x64

    Target machine: Server 2008R2

    eDIT.

    Did some more testing: it works if the target is win7 or server2012

    Are tehre any special things to do if the target is server 2k8r2, special permissions anywhere ?

    Thursday, June 20, 2013 6:01 PM

All replies

  • Hi robinmi,

    Thanks for your post.

    What do you mean of this :"However, I cannot get it to deploy anything"?

    Do you want to create a deployment project? This is Visual Studio Steup forum but the forum support VS Setup itself. Please clarify your issue so that I can redircet you to the right forum.
    Regards,


    Barry Wang
    MSDN Community Support | Feedback to us
    Develop and promote your apps in Windows Store
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    Friday, June 21, 2013 7:18 AM
  • Nope, what I'm talking about is the capability of the remote debugger to deploy your project output files to the target machine (debuggee).

    Like I said above, it seems to work between win7 and server2012 targets, but not when the target is a 2k8r2 server. At least not in my office, where both the win7x64 dev machine and the 2k8r2 target machine are in the same domain.

    Again, I tried this with win7 dev machine and win7 target machine, it works, also ws2012 target machine, that also works.

    It is either something in the domain setings or the target OS (2k8r2) 



    • Edited by robinmi Friday, June 21, 2013 2:20 PM
    Friday, June 21, 2013 2:18 PM
  • Hi robinmi,

    From your description, I'll move your case to VS debugger which may more appropriate.

    Regards,


    Barry Wang
    MSDN Community Support | Feedback to us
    Develop and promote your apps in Windows Store
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    Monday, June 24, 2013 2:34 AM
  • Hi robinmi,

    Do you mean that you could debug the app remotely in Windows 7/Server 2012, but it doesn’t work in Server 2008 R2?

    Did you get any error message when you debug it? As far as I know, the remote debugging supports in Windows Server 2008 R2.

    http://www.microsoft.com/visualstudio/eng/products/compatibility

    Please install the VS2012 update2 in your windows Server 2008 R2 machine.

    Best Regards,


    Jack Zhai [MSFT]
    MSDN Community Support | Feedback to us
    Develop and promote your apps in Windows Store
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    Monday, June 24, 2013 8:10 AM
    Moderator
  • Sorry for delay,

    I can't do that. The 2008R2 server is the target, and I'm not allowed to pollute it with VS. I can only install the remote debugging tools (which are R2). 

    I think that is also the idea of the remote debugging tools, no?

    My dev machine surely has vs 2012 update 2 on it.

    However, if you'Re suggesting that installing the full vs package on the target might solve the issue, I will try that (on another machine) and see if that helps...

    Wednesday, June 26, 2013 11:10 AM
  • I found another 2k8r2 machine to test.

    -installed vs2012 incl. update 2 on it

    -installeed latest remote tools on it

    - everything is up to date (update-wise)

    - dev machine and target machine are in the same domain and I verified I can use windows authentication to debug

    - remote debugging works as expected, again, cpoying the files to the target does NOT. I have to manually copy the files to the directory specified in the remote-debug dialog in order to be able to debug.

    - infact the 'deploy' part of the does not even connect to the target (i don't see any reaction on the remote debugger monitor)

    Wednesday, June 26, 2013 11:20 AM
  • Hi robinmi,

    Glad to receive your reply.

    So it has the same issue in another 2008 R2 machine, am I right?

    Actually I didn’t have this specific Environment now, and I just repro it in other machine. To help you resolve this issue, would you mind creating connect report for it? You will get email notification for update.http://connect.microsoft.com/VisualStudio/feedback/CreateFeedback.aspx, if you submit it, you could share me the link here, so we could know the latest information from the product team, if I have the same environment, I will try to check it in my side, if I get the same issue as yours, I will help you vote it, thanks for your understanding.

    If there's any concern, please feel free to let me know.

    Sincerely,


    Jack Zhai [MSFT]
    MSDN Community Support | Feedback to us
    Develop and promote your apps in Windows Store
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    Thursday, June 27, 2013 3:21 AM
    Moderator
  • Before I go into that trouble, one more question. What happened to the remote profiling tools? It doesn'T seem to be possible to do remote profiling using a dev machine with VS and again a target machine with the app + rtools. At least I can't find a way to configure that, and noone else seems to have posted any success messages about it.
    Thursday, June 27, 2013 4:16 PM
  • Hi robinmi,

    What happened to the remote profiling tools?

    Just to make this issue clearly, do you mean that you are using the Performance Monitor in your windows or the profiling tool here?

    Actually this forum is to discuss the profiler tool here, but I doubt that you mean that it is related to the Performance Monitor. Not the real expert about it, if you couldn’t use it for the remote machine, you would check whether it is related to the user permission in your two machines.

    Reference:

    http://blogs.msdn.com/b/bclteam/archive/2006/09/08/746900.aspx

    If I have misunderstood anything, please make free feel to let me know.

    Best Regards,


    Jack Zhai [MSFT]
    MSDN Community Support | Feedback to us
    Develop and promote your apps in Windows Store
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    Friday, June 28, 2013 6:42 AM
    Moderator
  • I do mean the performance (profiling) tools coming with VS. I know about perfmon and remote access issues, that is something different. IMO, since vs2012 seems dead already, I think I'll just use use something else then. Windbg is still somewhat alive, I guess. 
    • Edited by robinmi Friday, June 28, 2013 2:48 PM
    Friday, June 28, 2013 2:45 PM
  • hi robinmi,

    according to your describes,ensure you want to  depoy application to remote machine?if you want to deploy application to remote machine, you can read the following  web application to remote machine steps:

    1. Creating a web package using IIS Manager.

    First, I build a web application and it runs well in my dev box.

    Second, right click on the project node ”MyApp”, choose the properties item, switch to the web tab. There you will see a checkbox named “Use Local IIS Web Server”, check on it. Click the button “Create Virtual Directory”.

    Third, after step 2, you will find the web app in your IIS Manger. Start -> Run, input “inetmgr”. Under the Default Web Site node, you can see the web app “MyApp”.

    Forth, right click on “MyApp”, select on Manage Application-> Browser, you can see the web app runs well.Fifth, click on “Export Application” under Deploy pane in right of IIS.

    Click Next until it require you input the save path of package,.click next. Till now you have created the package successfully using IIS manager.

    You can find the MyApp.Zip under “d:\Qixue\” folder.

    2.       Import a Web Application in IIS Manager

    We had created “MyApp.Zip” in my local machine, copy it to the host server and put it in “d:\” folder.

    First, open IIS Manager, using Start-> Run, inetmgr.

    Second, select on Default Web Site, click on Import Application. In the import path, input “D:\MyApp.Zip”,click next. After this, you will see the MyApp Web site under Default Web Site.

    You can browser it to test if it runs well.

    as for server 2k8r2,i don't use it.

    hope this help you.

    thanks.

    Monday, July 15, 2013 1:32 PM