none
Error in installing .Net framework 3.5 and 3.5 SP1 on Windows XP

    Question

  • Hi all,

    I tried to install .Net framework 3.5 downloaded from microsoft on a Windows XP  SP2 machine.
    With .Net Framework Verifier, I verified the frameworks 1.1. SP1 and 2.0 SP2 and 3.0 SP2 to be OK.

    The framework 3.5 installs without error message.
    However, the verification gives an error:
    [04/23/09,17:14:42] Detected operating system: Windows XP (x86)
    [04/23/09,17:14:53] File C:\WINDOWS\Microsoft.NET\Framework\v3.0\WPF\XamlViewer\XamlViewer_v0300.exe is not installed on the system
    [04/23/09,17:14:53] File C:\WINDOWS\Microsoft.NET\Framework\v3.0\WPF\XamlViewer\XamlViewer_v0300.exe.manifest is not installed on the system
    [04/23/09,17:14:53] File C:\WINDOWS\Microsoft.NET\Framework\v3.0\WPF\XamlViewer\XamlViewer_v0300.xbap is not installed on the system
    [04/23/09,17:14:54] Verification failed for product .NET Framework 3.5

    Then the installation of Framework 3.5 SP1 breaks off with the following error:

    [04/23/09,17:45:59] Microsoft .NET Framework 3.5 'package': [2] Error: Installation failed for component Microsoft .NET Framework 3.5 'package'. MSI returned error code 1603
    [04/23/09,17:46:17] WapUI: [2] DepCheck indicates Microsoft .NET Framework 3.5 'package' is not installed.

    any help appreciated



     
     
    Thursday, April 23, 2009 9:39 PM

Answers

All replies

  • That's strange. XamlViewer shouldn't be required on Windows XP, only Vista. I think those files come with VS SDK. Have you installed any VS version first?

    Hobbyist programmer: VB.NET, C++, Pascal
    Friday, April 24, 2009 7:25 AM
  • Yes, before I had installed VS 2008

    Then I decided to deinstall en reinstall the .net framework because I had problems with the system.web.abstractions assembly that could not be loaded.

    Friday, April 24, 2009 10:53 AM
  • There's not a lot I can think of doing in this case. You can try renaming the v3.0 folder to v3.0(old), and then try installing again, and see what happens. That way it will create a new folder and won't have problems interfering with any files in the old folder.
    Saturday, April 25, 2009 6:11 AM
  • Hi Dolphin7,

    You can also try using Cleanup tool to remove .NET Framework 3.0 SP2 and .NET Framework 3.5. Then try installing .NET Framework 3.5 Service Pack 1 (Full Package).

    If you have any issue on installing .NET Framework 3.5 SP1 Full Package, could you please try to help me to use collect tool to collect the log files of .NET Framework 3.5 SP1 Full Package from your "%temp%" folder?
    http://blogs.msdn.com/heaths/archive/2008/05/09/visual-studio-and-net-log-collection-utility.aspx

    Then compress them into a zip file and post a link back. You can upload your log files to SkyDrive and post the link back here.

    Steps:
    - Try to clean your "%temp%" folder
    - Install .NET Framework 3.5 SP1 Full Package
    - Collect the logs from "%temp%" folder

    Thanks

    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    Welcome to the All-In-One Code Framework! If you have any feedback, please tell us.
    • Proposed as answer by etisoppo Tuesday, April 28, 2009 11:02 AM
    • Marked as answer by Dolphin7 Tuesday, April 28, 2009 1:32 PM
    Monday, April 27, 2009 8:51 AM
  • Thank you very much YiChun,

    The cleanup tool and installing the full package finally solved the problem !!

    Best regards
    Tuesday, April 28, 2009 10:49 AM
  • Hi Dolphin7,

    I'm so glad to hear that it works. Cheer. Have a good day.
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    Welcome to the All-In-One Code Framework! If you have any feedback, please tell us.
    Wednesday, April 29, 2009 1:50 AM
  • 09/27/10,16:36:50] ****ERROR**** File C:\WINDOWS\Microsoft.NET\Framework\v3.0\WPF\XamlViewer\XamlViewer_v0300.exe is not installed on the system
    [09/27/10,16:36:50] ****ERROR**** File C:\WINDOWS\Microsoft.NET\Framework\v3.0\WPF\XamlViewer\XamlViewer_v0300.exe.manifest is not installed on the system
    [09/27/10,16:36:50] ****ERROR**** File C:\WINDOWS\Microsoft.NET\Framework\v3.0\WPF\XamlViewer\XamlViewer_v0300.xbap is not installed on the system
    [09/27


    I have been fighting with this for a week, any ideas would be appreaciated.
    Kerry
    Monday, September 27, 2010 10:40 PM