none
Velocity and Release Burndown Reports showing Data not avilable

    Question

  •  

    Hi All,

    Velocity and Release Burndown Reports showing Data not avilable. I have given effort value. I have also used Area and Iteration. These two reports are very important to us. Sprint Burndown report working properly. We are using Microsoft Visual studio SCRUM Process Template 1.0 in TFS 2010.

    Thanks in advance

    Regards

    Durga


    • Edited by Durgarao K Thursday, May 17, 2012 4:29 PM
    Thursday, May 17, 2012 4:28 PM

Answers

All replies

  • Hello Durga,

    What is the detailed error message you got when you would like to access the Velocity and Release Burndown reports?

    Thanks.


    Vicky Song [MSFT]
    MSDN Community Support | Feedback to us

    Friday, May 18, 2012 5:25 AM
  • Hi Vickey,

    Its not showing any error.

    Friday, May 18, 2012 11:45 AM
  • Hi Vickey,

    We are using SCRUM template but insted of Product Backlog Item we are using User Story. Velocity and Release Burndown reports based on Effort in Product Backlog item so i have added the effort field in User Story with Microsoft.VSTS.Scheduling.Effort reference. I also given reportable as Measure. Now reports not displaying any data. when i open report it says data not avilable. it not giving any error. its very imp to us. please provid eme solution.

    Regards

    Durga


    • Edited by Durgarao K Friday, May 18, 2012 5:18 PM
    Friday, May 18, 2012 5:16 PM
  • Hello Durga,

    Based on your above description, as you have added the effort field in the User Story work item type with the Microsoft.VSTS.Scheduling.Effort, you should be able to get the data shown in the Velocity and Release Burndown reports. To deal with your issue, please try to refresh the Tfs_Warehouse manually. See: 

    http://www.ewaldhofman.nl/post/2009/11/25/Refresh-the-TFS-Warehouse-manually.aspx

    Thanks.


    Vicky Song [MSFT]
    MSDN Community Support | Feedback to us

    Monday, May 21, 2012 6:27 AM
  • Thanks Vickey for info.. Velocity report is working after changing the projectguid. By default query is referring wrong team project. when given the right project guid its working.

    Regards

    Durga

    Tuesday, May 22, 2012 10:04 AM
  • Hi Durga,

    Can you please let me know from where you changed the projectguid? I am also facing the same issue, where my velocity chart does not show any data.

    Thanks,

    Priyanka

    Monday, January 27, 2014 12:03 PM
  • Can anyone please suggest me some solution for this. I tried refreshing the warehouse using TFS webservices but still no data in velocity report.

    Thanks,

    Priyanka

    Friday, February 07, 2014 10:10 AM